Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-04-07, 07:15 PM   #13
zuzoid
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: MX440 and TV-out

I`ll reinstall opensuse tomorrow and try it again. Why not?
zuzoid is offline   Reply With Quote
Old 04-08-07, 03:22 PM   #14
zuzoid
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: MX440 and TV-out

suse reinstalled..

as i expected - b/w

i cant understand - why?!

Here one suspicious piece of dmesg:
Code:
nvidia: module not supported by Novell, setting U taint flag.
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-8756  Wed Mar 29 14:26:26 PST 2006
Usual reaction on non-free kernel modules..
but module loads normally.

xorg.conf:
Code:
...
Section "Monitor"
  Identifier   "tv"
  DisplaySize  400 300
  HorizSync    30-50
  ModelName    "Nesco"
  Option       "DPMS"
  VertRefresh  60
  UseModes     "tv_modes"
EndSection

Section "Modes"
  Identifier   "tv_modes"
  Modeline 	"800x600" 40.00 800 856 984 1056 600 617 621 644
  Modeline 	"800x600i"   36.88  800 832 912 1024  600 601 604 621
  Modeline 	"768x576"   33.74  768 792 872 976  576 577 580 596
  Modeline      "720x576i" 13.875 720 744 808 888 576 581 586 625 -hsync -vsync interlace
  Modeline 	"640x480"   23.06  640 656 720 800  480 481 484 497
EndSection

Section "Screen"
  Identifier   "tv_screen"
  Device       "nvidia_mx440"
  Monitor      "tv"
  DefaultDepth 24
  SubSection "Display"
    Depth      24
#    Modes      "800x600"
#    Modes      "768x576"
#    Modes      "728x576i
    Modes      "640x480"
  EndSubSection
EndSection


Section "Device"
  Identifier   "nvidia_mx440"
  VendorName   "NVidia"
  BoardName    "GeForce4 MX 440"
  BusID        "1:0:0"
  Driver       "nvidia"
  Option       "RenderAccel" "1"
  Option       "usevnc" "yes"

  Option       "ConnectedMonitor" "TV"
  Option       "TVStandart" "PAL-B"
# PAL-B/D/G/H/I/K1/M/N/NC
# NTSC-J/M
  Option       "TVOutFormat" "COMPOSITE"

  Option       "IgnoreEDID" "true"
  Option       "TVOverScan" "0.6"
EndSection

Section "ServerLayout"
  Identifier   "TV_Layout"
  InputDevice  "keyboard" "CoreKeyboard"
  InputDevice  "usb_mouse" "CorePointer"
  InputDevice  "vnc_keyboard" "ExtraKeyboard"
  InputDevice  "vnc_mouse" "ExtraPointer"
  Option       "VNC" "3 2"
  Screen       "tv_screen"
EndSection
...
xorg.log:
Code:
X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux puma 2.6.16.21-0.25-default #1 Tue Sep 19 07:26:15 UTC 2006 i686
Build Date: 13 September 2006
	Before reporting problems, check http://wiki.X.Org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  9 05:11:55 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "TV_Layout"
(**) |-->Screen "tv_screen" (0)
(**) |   |-->Monitor "tv"
(**) |   |-->Device "nvidia_mx440"
(**) |-->Input Device "keyboard"
(**) |-->Input Device "usb_mouse"
(**) |-->Input Device "vnc_keyboard"
(**) |-->Input Device "vnc_mouse"
...
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) Input device list set to "/dev/ttyS0,/dev/ttyS1,/dev/ttyS2,/dev/ttyS3,/dev/ttyS4,/dev/ttyS5,/dev/ttyS6,/dev/ttyS7,/dev/ttyS8,/dev/psaux,/dev/logibm,/dev/sunmouse,/dev/atibm,/dev/amigamouse,/dev/atarimouse,/dev/inportbm,/dev/gpmdata,/dev/mouse,/dev/usbmouse,/dev/adbmouse,/dev/input/mice,/dev/input/event0,/dev/pointer0,/dev/pointer1,/dev/pointer2,/dev/pointer3"
(==) ModulePath set to "/usr/X11R6/lib/modules/updates,/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) Open APM successful
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.2
	X.Org Video Driver: 0.8
	X.Org XInput driver : 0.5
	X.Org Server Extension : 0.2
	X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	ABI class: X.Org Video Driver, version 0.8
(--) using VT number 7
...
(II) Bus -1: bridge is at (0:4:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV17 [GeForce4 MX 440] rev 163, Mem @ 0xd6000000/24, 0xd8000000/27, 0xd7800000/19, BIOS @ 0xd77e0000/17
...
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.2
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 6.9.0, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 0.0.1
	ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "vnc"
(II) Loading /usr/X11R6/lib/modules/vnc.so
(II) Module vnc: vendor="xf4vnc Project, see http://xf4vnc.sf.net (4.3.0.999)"
	compiled for 4.3.99.902, module version = 1.1.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.2
(II) Loading extension VNC
(II) Ignore errors regarding the loading of the rfbmouse & rfbkeyb drivers
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.1
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.3
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "rfbkeyb"
(WW) Warning, couldn't open module rfbkeyb
(II) UnloadModule: "rfbkeyb"
(EE) Failed to load module "rfbkeyb" (module does not exist, 0)
(II) LoadModule: "rfbmouse"
(WW) Warning, couldn't open module rfbmouse
(II) UnloadModule: "rfbmouse"
(EE) Failed to load module "rfbmouse" (module does not exist, 0)
(II) v4l driver for Video4Linux
(II) NVIDIA dlloader X Driver  1.0-8776  Mon Oct 16 21:57:32 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 0.1.0
	ABI class: X.Org Video Driver, version 0.8
(II) resource ranges after xf86ClaimFixedResources() call:
...
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "IgnoreEDID" "true"
(**) NVIDIA(0): Option "ConnectedMonitors" "TV"
(**) NVIDIA(0): Option "TVOutFormat" "COMPOSITE"
(**) NVIDIA(0): Option "RenderAccel" "1"
(**) NVIDIA(0): Option "TVOverScan" "0.6"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Forcing COMPOSITE video output
(**) NVIDIA(0): ConnectedMonitor string: "TV"
(WW) NVIDIA(0): 
(WW) NVIDIA(0): The IgnoreEDID and NoDDC options have been deprecated.  The
(WW) NVIDIA(0):     NVIDIA X driver makes use of a display device's EDID
(WW) NVIDIA(0):     during construction of its modePool.  It is recommended
(WW) NVIDIA(0):     that you allow the X driver to make use of any available
(WW) NVIDIA(0):     EDID.  If, however, you know what you are doing and have
(WW) NVIDIA(0):     good reason to do so, you can disable the X driver's use
(WW) NVIDIA(0):     of EDIDs by setting the "UseEDID" X configuration option
(WW) NVIDIA(0):     to FALSE; e.g.,
(WW) NVIDIA(0): 
(WW) NVIDIA(0):   Option "UseEDID" "FALSE"
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Note that, rather than globally disable all uses of the EDID,
(WW) NVIDIA(0):     you can individually disable each particular use of the
(WW) NVIDIA(0):     EDID; e.g.,
(WW) NVIDIA(0): 
(WW) NVIDIA(0):   Option "UseEDIDFreqs" "FALSE"
(WW) NVIDIA(0):   Option "UseEDIDDpi" "FALSE"
(WW) NVIDIA(0):   Option "ModeValidation" "NoEdidModes"
(WW) NVIDIA(0): 
(WW) NVIDIA(0): See the README for details on each of these options.
(WW) NVIDIA(0): 
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.00.24.00
(II) NVIDIA(0): Detected AGP rate: 2X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 at PCI:1:0:0:
(--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA
(II) NVIDIA(0): Assigned Display Device: TV-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.so
(II) Module int10: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	ABI class: X.Org Video Driver, version 0.8
(II) NVIDIA(0): Primary V_BIOS segment is: 0xc000
(**) NVIDIA(0): DPI set to (40, 40); computed from "DisplaySize" Monitor section option
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
...
(II) NVIDIA(0): Setting mode "640x480"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(WW) NVIDIA(0): Option "usevnc" is not used
(WW) NVIDIA(0): Option "TVStandart" is not used
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
...
(II) XINPUT: Adding extended input device "vnc_mouse" (type: rfbMouse)
(II) XINPUT: Adding extended input device "vnc_keyboard" (type: rfbKeyb)
(II) XINPUT: Adding extended input device "usb_mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "keyboard" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) usb_mouse: ps2EnableDataReporting: succeeded
One evil string from it:
(WW) NVIDIA(0): Option "TVStandart" is not used
zuzoid is offline   Reply With Quote
Old 04-09-07, 06:17 AM   #15
zuzoid
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: MX440 and TV-out

[Stupidly solved]

TVStandart != TVStandard

My brain was broken down..
zuzoid going to school for better learning english language for kids
zuzoid is offline   Reply With Quote
Old 04-19-07, 11:05 AM   #16
jdsimmons
Registered User
 
Join Date: Apr 2007
Posts: 1
Default Re: [Resolved] Re: MX440 and TV-out

Sarabanjina,

I'm having what seems to be the same problem as you. I had a GeForce MX 440 card in a PC I built in August of 2003 which I used to run Freevo. It worked fine with the nvidia driver at that time, but freevo was buggy, so a couple of weeks ago I decided to upgrade to openSUSE 10.2 and to completely reinstall Freevo. The current nvidia driver works fine displaying to a monitor but TV-out looks like its swapping the A and B fields so everything has jagged edges and text is unreadable. I submitted a bug report to nvidia and last Friday heard that they had been able to reproduce the problem. They wanted to know what was the last driver I had that was working, and I had foolishly deleted the install for the old driver but was able to deduce that it was current as of August 2003.

I'm still waiting to hear back from them.

It sounds like you did a lot of stuff to try and get this working, and I'm hoping to avoid all that you went through. If you had it to do over, what would you try?

Thanks,

James Simmons


Quote:
Originally Posted by sarabanjina
Yesss,

I finally got it working right...

I spent one month on this problem :
- recompiled Xorg
- recompiled Xorg with debug
- tried every driver versions
- tried every bios tweaks
- tried multiple kernels
- ...

My conclusions are (at least for GeForce 4 MX440 integrated) :
- driver 8xxx is broken in XVideo extension
- driver 9xxx is broken in TV-out (flickerness)
- driver 7184 crashes Xorg

BUT, if you remove libvm86.so AND libx86emu.so from your Xorg modules, it works like before (no Xorg crash)! I just watch one hour of divx (non interlaced) and image is perfect, at least...

I have absolutely no idea why it works when you remove these modules, but honestly, I don't care as I have now a good XVideo output from my HTPC with latest XOrg...

I don't understand why nobody reports this problem before (am I alone in this case?), but I hope it will help someone to get a good TV output from MX440 integrated...

Sarabanjina
jdsimmons is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.