Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-08-07, 10:58 AM   #1
Squishy
Registered User
 
Join Date: Apr 2007
Posts: 14
Default X freezes on startup with 1.0-9755 + 7600GS

I recently bought a XFX GeForce 7600 GS. After installing the 1.0-9755 (I tried others as well), Xorg freezes on startup. The screen is blank and I can use my keyboard for a couple of second. (I can press numlock, etc.) but after a a few seconds it won't react anymore.

The nvidia report log unfortunately isn't with the driver activated in Xorg as I can't even get to tty1 and have to reboot in recovery mode to set the driver to "nv" to actually be able to do something.

Running Ubuntu Feisty Fawn (7.04). The packages (nvidia-glx and nvidia-glx-legacy) seem to produce the same results (blank screen). Except that the nvidia-glx-legacy driver doesn't give any errors in the Xorg.0.log, and the keyboard reacts, I just don't see anything and can't get to tty1 either. The xorg.conf I used to start is the same as in the report except for the nv replaced with nvidia.

Hope you guys have a clue how to get rid of this problem.
Attached Files
File Type: log nvidia-bug-report.log (146.1 KB, 111 views)
Squishy is offline   Reply With Quote
Old 04-08-07, 02:22 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X freezes on startup with 1.0-9755 + 7600GS

http://www.nvnews.net/vbulletin/showthread.php?t=58498
netllama is offline   Reply With Quote
Old 04-08-07, 02:50 PM   #3
Squishy
Registered User
 
Join Date: Apr 2007
Posts: 14
Default Re: X freezes on startup with 1.0-9755 + 7600GS

Quote:
Originally Posted by netllama
Already checked that list and none of those points apply.

Running kernel 2.6.20 (ubuntu 2.6.20-14-386 kernel, to be precise).
Squishy is offline   Reply With Quote
Old 04-09-07, 08:08 AM   #4
Squishy
Registered User
 
Join Date: Apr 2007
Posts: 14
Default Re: X freezes on startup with 1.0-9755 + 7600GS

I managed to do a nvidia-bug-report with the driver loaded by manually starting using nv, installing the drivers and starting up gdm again.

Still the same problem of the blank screen and locking up.
Attached Files
File Type: log nvidia-bug-report.log (87.9 KB, 113 views)
Squishy is offline   Reply With Quote
Old 04-09-07, 11:33 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X freezes on startup with 1.0-9755 + 7600GS

The only thing that I see in the latest bug report is the uninstallation of 1.0-9755 followed by an X start failure due to the missing driver.
netllama is offline   Reply With Quote
Old 04-09-07, 11:53 AM   #6
Squishy
Registered User
 
Join Date: Apr 2007
Posts: 14
Default Re: X freezes on startup with 1.0-9755 + 7600GS

Quote:
Originally Posted by netllama
The only thing that I see in the latest bug report is the uninstallation of 1.0-9755 followed by an X start failure due to the missing driver.
Because I reinstalled it.

Code:
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-9755):
   executing: '/sbin/ldconfig'...
   executing: '/sbin/depmod -aq'...
-> done.
Squishy is offline   Reply With Quote
Old 04-09-07, 12:12 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X freezes on startup with 1.0-9755 + 7600GS

You're correct, sorry about that.

Even so, something is still wrong with the installation, as X appears to be segfaulting just loading the glx module:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
Backtrace:
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.