Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-29-07, 03:05 PM   #1
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Kubuntu Feisty - 8800GTS - dual 1680x1050

I'm on Kubuntu 7.04. I have an eVga 8800GTS and I'm trying to use 2 Dell 2007WFP monitors. I used adept to add nvidia-glx (version 1.0.9755...see below), and then I ran nvidia-xconfig --twinview (also tried without the twinview), and restarted. However, I only get a black screen. If I press ctrl+alt+f1, I get a text login (that you can't see...however, if I type my username and press enter, I can see the password prompt). I had to log in, and set the driver back to vesa.
Code:
aaroncampbell@aaron-linux:~$ aptitude show nvidia-glx | grep -i version
Version: 1.0.9755+2.6.20.4-13.12
I tried running nvidia-settings, but I only get a few irrelevant settings, so I ran it from console, and this is the output:
Code:
aaroncampbell@aaron-linux:~$ nvidia-settings

ERROR: NV-CONTROL extension not found on this Display.


ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.


ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.


ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'.

aaroncampbell@aaron-linux:~$
Also, here is my current xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  #    InputDevice    "stylus" "SendCoreEvents"
  #    InputDevice    "cursor" "SendCoreEvents"
  #    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

  # path to defoma fonts
  FontPath "/usr/share/fonts/X11/misc"
  FontPath "/usr/share/fonts/X11/cyrillic"
  FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/Type1"
  FontPath "/usr/share/fonts/X11/100dpi"
  FontPath "/usr/share/fonts/X11/75dpi"
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "vbe"
  load "glx"
  load "GLcore"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "us"
  option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ImPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
#    Identifier     "stylus"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"       # Change to
#    Option         "Type" "stylus"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
#    Identifier     "eraser"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"       # Change to
#    Option         "Type" "eraser"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
#    Identifier     "cursor"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"       # Change to
#    Option         "Type" "cursor"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

Section "Monitor"
  identifier "Generic Monitor"
  vendorname "Plug 'n' Play"
  modelname "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  gamma 1.0
EndSection

Section "Device"
  identifier "Generic Video Card"
  boardname "vesa"
  busid "PCI:2:0:0"
  driver "vesa"
  screen 0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "Generic Video Card"
  Monitor "Generic Monitor"
  DefaultDepth 24
  option "TwinView" "True"
  option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
  SubSection "Display"
    depth 24
    modes "640x480@60"
  EndSubSection
EndSection

Section "ServerFlags"
EndSection
Any Ideas?
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 03:10 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

According to the information above, you're using the vesa X driver, not the nvidia X driver.
netllama is offline   Reply With Quote
Old 03-29-07, 03:21 PM   #3
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

From my first message:
Quote:
then I ran nvidia-xconfig --twinview (also tried without the twinview), and restarted.
That set it to nvidia.
Quote:
However, I only get a black screen. If I press ctrl+alt+f1, I get a text login (that you can't see...however, if I type my username and press enter, I can see the password prompt). I had to log in, and set the driver back to vesa.
Here I had to manually set it back to vesa to get back into X. So it's using vesa now, because that's the only way it works...but I WANT to use nvidia.
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 03:26 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Then perhaps you should follow these instructions:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 03-29-07, 04:04 PM   #5
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Thanks, I didn't even know about the bug reports. I've attached one. It was too big for the forum, so I had to bzip it. It looks like I followed the rest of the instructions (to the best of my abilities).
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (34.1 KB, 94 views)
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 04:27 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Here's the problem:
(EE) NVIDIA(0): Need libwfb but wfbScreenInit not found

Does this problem persist if you install the official NVIDIA driver package?
netllama is offline   Reply With Quote
Old 03-29-07, 05:47 PM   #7
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

I can't seem to install the official package. First it said it needed libc, so I installed that. Then it said it needed the kernel source. I tried to install that, but it still says it needs it.
Attached Files
File Type: log nvidia-installer.log (3.0 KB, 105 views)
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 05:48 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Again, you should read the sticky posts, they exist for a reason:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote

Old 03-29-07, 06:16 PM   #9
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Sorry, I had followed that (after a search), but it seems I had gotten the wrong linux-header package (generic x86 rather than i386). Now it compiled and installed, and xserver started fine. However, it's still a single monitor rather than two, and I can't seem to make any changes from inside System Settings. Is this something that is likely to be fixed soon in the Ubuntu package? Maybe I should just wait?
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 06:27 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

I couldn't comment on the state of Ubuntu packages, but this certainly looks like a bug in their packages if it works with the official package and not Ubuntu's.

I'd need to see a new bug report to comment on your current problem.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 03-29-07, 06:35 PM   #11
aaroncampbell
Registered User
 
Join Date: Mar 2007
Posts: 10
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

Here you go.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (33.8 KB, 90 views)
aaroncampbell is offline   Reply With Quote
Old 03-29-07, 06:40 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Kubuntu Feisty - 8800GTS - dual 1680x1050

According to your bug report, you've not configured X to use more than one display device. A quick fix is to run the following as root:
nvidia-xconfig --twinview

and then restart X. See the driver README for more information on Twinview or Xinerama.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.