Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-31-07, 07:25 AM   #1
Jayton
Registered User
 
Join Date: Mar 2007
Posts: 1
Exclamation Re: (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Hello!

I seem to have a problem with the GLX module loading, I have been trying for a week now, copying files here there and everywhere. I am so desperate to have beryl working on FreeBSD rather than switching to ubuntu just for beryl.

I have followed the instructions from GKontos on the beryl wiki and the original post on the bsd forums to no avail. I have searched for countless hours, tried so many things, reinstalled a few times, installed new partitions. I am using the latest nvidia driver, I have a 6600GT PCI-E.

Code:
beryl# uname -a
FreeBSD beryl.home 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 10:40:27 UTC 2007     root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386

beryl# kldstat
Id Refs Address    Size     Name
 1   37 0xc0400000 6f6544   kernel
 2    2 0xc0af7000 1adb8    linux.ko
 3   30 0xc0b12000 22b88    sound.ko
.... ALL sound drivers loaded until i figure out which i need ....
29    1 0xc0bea000 6d3ea0   nvidia.ko
30    1 0xc12be000 59f20    acpi.ko
The Xorg.0.log error:
Code:
beryl# grep 'EE' /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "glx" (module does not exist, 0)
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "wfb" (module does not exist, 0)
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
Please help me!
Attached Files
File Type: zip xconf-xlog.zip (4.5 KB, 230 views)
Jayton is offline   Reply With Quote
Old 03-31-07, 04:55 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: (EE) Failed to load module "glx" (module does not exist, 0)

Jayton,
Your post was totally unrelated to the thread you posted it in and was in the wrong forum, so I moved it. In addition, your .zip file appears to be corrupt:
Code:
$ unzip xconf-xlog.zip 
Archive:  xconf-xlog.zip
error [xconf-xlog.zip]:  missing 5431 bytes in zipfile
  (attempting to process anyway)
error [xconf-xlog.zip]:  attempt to seek before beginning of zipfile
  (please check that you have transferred or created the zipfile in the
  appropriate BINARY mode and that you have compiled UnZip properly)
  (attempting to re-compensate)
  inflating: xorg.conf               
file #2:  bad zipfile offset (local header sig):  4446
  (attempting to re-compensate)
error [xconf-xlog.zip]:  attempt to seek before beginning of zipfile
  (please check that you have transferred or created the zipfile in the
  appropriate BINARY mode and that you have compiled UnZip properly)
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 06:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.