Go Back   nV News Forums > Hardware Forums > CPUs, Motherboards And Memory

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-31-07, 05:48 PM   #1
jcrox
Mahna Mahna
 
jcrox's Avatar
 
Join Date: Jul 2006
Location: Madison, Wi
Posts: 6,134
Default EVGA 680i .....D.O.A.

Well, I finally went and upgraded to C2D and of course, I'm one of the lucky ones. Got everything installed and right when I'm on the verge of jumping out of my skin in anticipation, I plug the beast in....hit the power button and....nothing. Just to double check, borrowed a friends Intel board and plugged everything into that, fired right up. RMA time for the EVGA 680i. Soooooo disappointed. I'm seriously thinking about getting a different board all together and avoiding EVGA motherboards from here on out...my NF41 board stunk it up too.
__________________

Gaming

MSI MPower Z87 | 4770k | CNPS9900MAX-B | 8GB G.Skill 1866 | EVGA GTX760 |ThermalTake 850w | X-Fi Titanium | HAF | Asus PA248Q | Lycosa | Death Adder | Win8 Pro 64

Dev/Backup

MSI GD65 | 2500k | H50 | 8GB G.skill | GTX570 | Ubuntu 13.10

Laptop

17" Inspiron | i5 | 4GB DDR3 | 500GB HDD | Win7 Pro 64

jcrox is offline   Reply With Quote
Old 03-31-07, 06:03 PM   #2
OrangeBlast
Registered User
 
Join Date: Sep 2005
Posts: 394
Default Re: EVGA 680i .....D.O.A.

Wasn't a grounding issue? PSU was plugged in right to the 680i? RAM and all cards pushed in to slot all the way? CMOS battery was in? CPU was mounted right along with the HSF assembly? The Computer Case's reset and power switch buttons were plugged in board properly? Did you try it with 1 stick of RAM at all? Possible ESD, were you grounded when plugging in all your parts?

just some questions and things to try for the future.
OrangeBlast is offline   Reply With Quote
Old 03-31-07, 06:27 PM   #3
jcrox
Mahna Mahna
 
jcrox's Avatar
 
Join Date: Jul 2006
Location: Madison, Wi
Posts: 6,134
Default Re: EVGA 680i .....D.O.A.

Everything was connected and ready to go. Like I said, put everything in a different motherboard and it worked perfect. I did put everything back into the EVGA mobo a 2nd time just to make sure....nothing. Not a fan spinning, not a single noise. I didn't mind waiting to upgrade but now that I have the memory and the processor in hand.....this really bites!!!
__________________

Gaming

MSI MPower Z87 | 4770k | CNPS9900MAX-B | 8GB G.Skill 1866 | EVGA GTX760 |ThermalTake 850w | X-Fi Titanium | HAF | Asus PA248Q | Lycosa | Death Adder | Win8 Pro 64

Dev/Backup

MSI GD65 | 2500k | H50 | 8GB G.skill | GTX570 | Ubuntu 13.10

Laptop

17" Inspiron | i5 | 4GB DDR3 | 500GB HDD | Win7 Pro 64

jcrox is offline   Reply With Quote
Old 03-31-07, 06:37 PM   #4
OrangeBlast
Registered User
 
Join Date: Sep 2005
Posts: 394
Default Re: EVGA 680i .....D.O.A.

hrm, its bound to happen I guess. I've gotten my share of bad HW before, just a simple RMA or exchange usually fixes that
OrangeBlast is offline   Reply With Quote
Old 03-31-07, 09:51 PM   #5
Xion X2
Registered User
 
Xion X2's Avatar
 
Join Date: May 2006
Location: U.S.
Posts: 6,701
Default Re: EVGA 680i .....D.O.A.

Toss it on the junk pile with all the rest of them.
__________________

i7-2700k @ 5.0 GHz
Nvidia GeForce 570 2.5GB Tri-SLI
Asus P67 WS Revolution (Tri-SLI)
OCZ Vertex SSD x 4 (Raid 5)
G.Skill 8GB DDR3 @ 1600MHz
PC Power & Cooling 950W PSU
Xion X2 is offline   Reply With Quote
Old 04-02-07, 01:42 PM   #6
jcrox
Mahna Mahna
 
jcrox's Avatar
 
Join Date: Jul 2006
Location: Madison, Wi
Posts: 6,134
Default Re: EVGA 680i .....D.O.A.

New board arrived this morning. Got everything set up, fired right up and OCing to 3ghz was a breeze. Played for about an hour and right in the middle of Stalker my system just shuts off for no reason. No BSOD, no crash to desktop, just completely off. Wont turn back on. Guessing it's return time. Enough with the EVGA mobo's. This is my last one. Think I'll sell my 2 640meg GTS's get 1 GTX and a 965 board.
__________________

Gaming

MSI MPower Z87 | 4770k | CNPS9900MAX-B | 8GB G.Skill 1866 | EVGA GTX760 |ThermalTake 850w | X-Fi Titanium | HAF | Asus PA248Q | Lycosa | Death Adder | Win8 Pro 64

Dev/Backup

MSI GD65 | 2500k | H50 | 8GB G.skill | GTX570 | Ubuntu 13.10

Laptop

17" Inspiron | i5 | 4GB DDR3 | 500GB HDD | Win7 Pro 64

jcrox is offline   Reply With Quote
Old 04-02-07, 01:46 PM   #7
LORD-eX-Bu
Horus the pointy master
 
LORD-eX-Bu's Avatar
 
Join Date: Jul 2002
Location: Salt Lake City, UT
Posts: 4,609
Default Re: EVGA 680i .....D.O.A.

have you checked your PSU? maybe it killed your mobo, or it could just be Foxconn's wonderful quality

sorry man, that sucks, I had to RMA my board as well. I'm gonna go P965 and never look back at nVIDIA chipsets.
__________________
http://www.nvnews.net/vbulletin/image.php?type=sigpic&userid=171&dateline=12152329  84
ΜΟΛΩΝ ΛΑΒΕ!
LORD-eX-Bu is offline   Reply With Quote
Old 04-02-07, 02:43 PM   #8
Slammin
Registered User
 
Join Date: Oct 2004
Posts: 1,123
Default Re: EVGA 680i .....D.O.A.

My guess would be the PSU as well. I smoked an OCZ PS520 and they are pretty good. I don't know if I'd trust their multi-rail 700w PSU's in a Sli box with an overclocked CPU though.
__________________
Abit IN9 32x MAX- Kentsfield QX6700 @3520
1.5 vcore watercooled D-Tek Fuzion/PA-160/MCR120/2x MCP655
2x2GB G-Skill 1066 5-5-5-15 2T@1.9vdimm
2x EVGA 580GTX 1.5GB Sli
2x 74GB Sata Raptor Raid0
2x 320GB Hitachi Sata II
X-FI Elite Pro
Dell U3011
Lian Li V2100B
Corsair HX1000
Slammin is offline   Reply With Quote

Old 04-02-07, 05:10 PM   #9
snilloconator
Registered User
 
Join Date: Jul 2006
Location: Orlando
Posts: 157
Send a message via MSN to snilloconator Send a message via Yahoo to snilloconator
Default Re: EVGA 680i .....D.O.A.

Yeah you don't mention your power supply.... What is it?
__________________
ROBBED


Please visithttp://www.uxcclan.com
snilloconator is offline   Reply With Quote
Old 04-02-07, 05:11 PM   #10
LORD-eX-Bu
Horus the pointy master
 
LORD-eX-Bu's Avatar
 
Join Date: Jul 2002
Location: Salt Lake City, UT
Posts: 4,609
Default Re: EVGA 680i .....D.O.A.

first line of his sig states OCZ 700W PSU
__________________
http://www.nvnews.net/vbulletin/image.php?type=sigpic&userid=171&dateline=12152329  84
ΜΟΛΩΝ ΛΑΒΕ!
LORD-eX-Bu is offline   Reply With Quote
Old 04-02-07, 08:33 PM   #11
jcrox
Mahna Mahna
 
jcrox's Avatar
 
Join Date: Jul 2006
Location: Madison, Wi
Posts: 6,134
Default Re: EVGA 680i .....D.O.A.

Borrowed a friends 965 board...everything is running great for 4+ hours now. 680i can kiss my rear end. I'll definitely be dropping the 680i all together.
__________________

Gaming

MSI MPower Z87 | 4770k | CNPS9900MAX-B | 8GB G.Skill 1866 | EVGA GTX760 |ThermalTake 850w | X-Fi Titanium | HAF | Asus PA248Q | Lycosa | Death Adder | Win8 Pro 64

Dev/Backup

MSI GD65 | 2500k | H50 | 8GB G.skill | GTX570 | Ubuntu 13.10

Laptop

17" Inspiron | i5 | 4GB DDR3 | 500GB HDD | Win7 Pro 64

jcrox is offline   Reply With Quote
Old 04-02-07, 08:39 PM   #12
A101Sugar
Registered User
 
A101Sugar's Avatar
 
Join Date: Nov 2006
Location: CA
Posts: 292
Send a message via AIM to A101Sugar
Default Re: EVGA 680i .....D.O.A.

I can take it off your hands for you
A101Sugar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
EVGA GeForce GTX 670 2GB Superclocked Review News Archived News Items 0 05-16-12 03:20 AM
EVGA GTX 670 Superclocked Graphics Card Review (Overclockers Club) News GeForce GTX 670 Reviews 0 05-11-12 06:00 AM
Product Spotlight ' EVGA GTX 670 Review Round Up News GeForce GTX 670 Reviews 1 05-11-12 12:15 AM

All times are GMT -5. The time now is 08:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.