Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-02-07, 03:03 PM   #1
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default How to enable the right AGP driver?

I'm having some trouble getting my nVidia driver setup. It used to work some time ago on my first Ubuntu install (9 months ago). But somehow it got wrecked and with every fresh system install with no software added or removed, when I install the nVidia driver by the book, my screen goes black and the system becomes non-responsive at the point of loading gdm.
I have this problem when I install the repository-driver, the Envy script and with the package from nvidia.com on Ubuntu 6.06, 6.10 and 7.04.
So I started playing with some settings and now I have found some kind of workaround by adding "NvAGP" "1" to my xorg.conf, but it seems slow. I still get the AGP: Disabled warning from /proc/driver/nvidia/agp/status and when I start Beryl my system will slow down (it even froze when opening up Firefox....)
My xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "Monitor"
    Identifier     "Philips 107E6"
    HorizSync       30.0 - 71.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation N43 [GeForce 6600]"
    Driver         "nvidia"
    Option         "NvAGP" "1"
    Option         "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation N43 [GeForce 6600]"
    Monitor        "Philips 107E6"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
The bugreport was created while running X and Gnome using the above configuration. Beryl wasn't running at the time.
I'm clueless as to where to go from here. How do I get my system to use the right AGP driver/module in order to gain maximum performance (again, since it has worked in the past). I'm aware of the fact I'm using beta software regarding Ubuntu 7.04, but since this error/problem occurs on all Ubuntu versions and Gentoo 2006.1 as well, I'd really like to know what goes wrong. Am I overlooking something? Is it not the AGP driver after all but something else?
If you need any more info I'll of course try to give it any way possible.
Thanx in advance.
Attached Files
File Type: log nvidia-bug-report.log (116.5 KB, 116 views)
Theimon is offline   Reply With Quote
Old 04-02-07, 03:08 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: How to enable the right AGP driver?

According to your bug report, the kernel's AGP driver is already loaded, so you can't use the NVIDIA AGP driver.

This sounds like an AGP driver, BIOS, or motherboard bug (and not an nvidia driver bug). You should probably verify that you're using the latest motherboard BIOS, and, if possible, test with a lower AGP rate.

thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-03-07, 01:47 PM   #3
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

Hmm, but what if I told you I'm using the same BIOS without conflicts for over the last 2 years? Could it be that the 9755 driver is conflicting with the hardware because it too "new"?

I'll try your options. And I'll build a new kernel and play with some module/driver options.
Because it has worked before with the same BIOS, hardware and software.
Thanks for your quick reply
Theimon is offline   Reply With Quote
Old 04-03-07, 02:00 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: How to enable the right AGP driver?

You're stating that nothing has changed on this system in the past 2 years, other than the version of the NVIDIA driver?
netllama is offline   Reply With Quote
Old 04-03-07, 03:05 PM   #5
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

Quote:
Originally Posted by netllama
You're stating that nothing has changed on this system in the past 2 years, other than the version of the NVIDIA driver?
Apart from adding 2 harddisks and switching Operating Systems, I guess I can say I've been having the same setup for about 1,5+ years. Nothing fancy but it still works like a charm for me.
So as far as graphics are concerned, basically the only thing changed is indeed the nVidia driver version.

I'll try to play around with different driver versions and fiddle with some kernel settings. Maybe I can somehow isolate the problem.
As fas as I know the GeForce 6600 is still supported by the default driver (as in: not the legacy) so I can't imagine I'm using "too recent software". My system components aren't that old. So like I said: it has worked before, so it will work again!
Theimon is offline   Reply With Quote
Old 04-07-07, 08:55 AM   #6
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

I rebuilt my kernel and while in that process I took out /dev/agpgart support altogether. Compiled it, installed it and rebooted.
At startup I uninstalled the nVidia-driver and reinstalled it, making sure it pointed to the right kernel headers. I rebooted the system again to make sure it loaded all the right modules, but when I check for AGP status, it still says: Disabled. When trying to load nvagp, the module can't be found (nor is any variation on that name).
Agpgart obviously can't be loaded either since it has been removed from the kernel. So that can't be the problem in any way. I attached a bug report while running in the above-mentioned configuration. The nvidia module is loaded correctly.
Attached Files
File Type: log nvidia-bug-report.log (115.2 KB, 112 views)
Theimon is offline   Reply With Quote
Old 04-09-07, 03:30 AM   #7
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

Any suggestions?
Theimon is offline   Reply With Quote
Old 04-09-07, 05:10 AM   #8
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: How to enable the right AGP driver?

Could you please post your /proc/config.gz here?
piotrq__ is offline   Reply With Quote

Old 04-09-07, 06:40 AM   #9
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

I currently have /dev/agpgart enabled in my kernel again. I'm using the 9629.run package at the moment. When it was building it failed on unknown symbols, all pointing at agp_*. This was because there was no agpgart present on my system.
I reenabled it, and now the driver compiled ok, but I still have the same problem. So how come the driver needs agpgart when, when it's properly compiled, starts to conflict with it as soon as they're both loaded?
Also, it's not clear to me how to "call" the nvagp, the internal nvidia agp driver. I'm unsure if it gets loaded when I entirely disable agpgart. Is it loaded when I modprobe nvidia? Or is there a second command to make sure the agp gets loaded as well? I can't find anything on that anywhere.
Just load nvidia and pray for the best? When I force the use of nvagp through xorg.conf, the /proc status still gives me disabled (agpgart enabled or disabled in the kernel doesn't matter, outcome is the same.)
I can't provide /proc/config.gz since I had it disabled in my kernel. I'll start with a clean slate, enable that option and post it here as soon as I can.
Theimon is offline   Reply With Quote
Old 04-09-07, 06:51 AM   #10
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: How to enable the right AGP driver?

The .config file from you current kernel sources directory will be enough.
You should also make sure, you've got both VIA AGP and AGPGART support enabled and compiled as modules in your kernel.

The config file should contain the following entries:
CONFIG_AGP=m
CONFIG_AGP_VIA=m
piotrq__ is offline   Reply With Quote
Old 04-09-07, 07:52 AM   #11
Theimon
Registered User
 
Join Date: Jan 2007
Posts: 10
Default Re: How to enable the right AGP driver?

I have attached the config which is used for compilation as we speak. I'm guessing I can install and reboot within ~15 mins. Then reinstall the nvidia driver and then keep my fingers crossed :/

Edit: somehow it failed to implement SATA support (while it was fully enabled), so I'm having a new go at compiling it.
Attached Files
File Type: txt config.txt (61.6 KB, 121 views)
Theimon is offline   Reply With Quote
Old 04-09-07, 08:48 AM   #12
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: How to enable the right AGP driver?

Why are you trying to build a custom kernel anyway? Wasn't the Ubuntu's default one OK?
piotrq__ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
POSSIBLE AGP TROUBLE (mandrake 9.0) chrono86 NVIDIA Linux 4 10-12-02 12:09 PM
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 10:36 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM
Can't enable AGP mr_dinu NVIDIA Linux 7 07-31-02 02:32 AM

All times are GMT -5. The time now is 06:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.