Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-30-07, 12:55 PM   #1
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default nvidia+amd64+2.6.20+feisty = stone dead computer

Hi there,

I have trouble with my 6200(msi i guess) card which started after switching to feisty+2.6.20 kernels(generic and lowlatency, no custom built ones) I'm absolutely unable to use legacy nvidia drivers both via restricted modules and with nvidia installer. Everything used to work up to 2.6.17(where I have to stay) so it's not the xorg configuration problem. And when any of 2.6.20 kernels are booted computer dramatically hangs(no ctrl+alt+f1 & co, just hard reboot) even without writing the xorg.0.log so I have no information on what can go wrong...

I assume this problem is kernel-driver conflict so I'm attaching also the kernel config and please note that log contains data *after* reboot and switch to nv driver so at least I can start the x server.

Thanks in advance.
Attached Files
File Type: zip nvidia-bug-report.log.zip (20.2 KB, 85 views)
File Type: zip config-2.6.20-12-lowlatency.zip (19.6 KB, 84 views)
durilka is offline   Reply With Quote
Old 03-31-07, 12:00 PM   #2
Prozzaks
Registered User
 
Join Date: Mar 2007
Posts: 5
Angry Re: nvidia+amd64+2.6.20+feisty = stone dead computer

I have the exact same problem using a 2.6.20.4 kernel I built myself on Gentoo. I can load the nvidia kernel module (modprobe nvidia) without any problem. However, as soon as I try to start X, the screen goes blank, and I can't do anything (VT-switch, ALT-CTRL-DEL, ALT-CTRL-BACKSPACE, etc...). I saw in the driver README that it might be a problem with some buggy BIOSes, so I left my computer like that for 30 mins, and nothing happened.

As you have said, there is nothing written in /var/log/Xorg.0.log.

Of course, in the included log, I'm using the Open Source nv driver since I can't get X to work with the NVidia driver.
Attached Files
File Type: log nvidia-bug-report.log (78.5 KB, 93 views)
File Type: txt config-2.6.20.4.txt (36.8 KB, 88 views)
Prozzaks is offline   Reply With Quote
Old 03-31-07, 02:16 PM   #3
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

well, this can be bios problem. 2.6.20 is quite a radical release so bios parts could've been changed, but i don't beleive that waiting can help. when linux hangs - it does it seriously ;-=-)
durilka is offline   Reply With Quote
Old 03-31-07, 04:01 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

Have you verified that you're using the most recent motherboard BIOS?
netllama is offline   Reply With Quote
Old 04-01-07, 08:55 PM   #5
Prozzaks
Registered User
 
Join Date: Mar 2007
Posts: 5
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

No I haven't, but I will verify this now.
Prozzaks is offline   Reply With Quote
Old 04-02-07, 03:07 AM   #6
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

funny enough looks like we have similar mainboards. too much nvidia in our computers?

i'll try to upgrade the bios too if i'll find a way to run .exe files...
durilka is offline   Reply With Quote
Old 04-02-07, 03:11 PM   #7
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

Hi Netllama,

the bios is latest now. the board is quite old: GA-K8NS(last bios update was published in march 2006). Problem remains.
durilka is offline   Reply With Quote
Old 04-02-07, 11:07 PM   #8
Prozzaks
Registered User
 
Join Date: Mar 2007
Posts: 5
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

I upgraded to. Guess what? I also have a Gigabyte motherboard : GA-K8NSC-939. I upgraded the BIOS to the latest version which is "F8". It didn't solve the problem.
Prozzaks is offline   Reply With Quote

Old 04-03-07, 07:53 AM   #9
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

So to summarize:
Nvidia graphic cards hang computer having mainboard built on nvidia chipsets when using 2.6.20 kernel family.
(Am i doing too much of SQL? )


comments from nvidia?
(On the other hand this site provides quite extensive set of emo-icons. that's sweet.)
durilka is offline   Reply With Quote
Old 04-03-07, 09:19 PM   #10
Prozzaks
Registered User
 
Join Date: Mar 2007
Posts: 5
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

I think that is a bit excessive. I would much rather say that the Nvidia 9755 driver hags with a 2.6.20.x kernel while running on GA-K8NSC Mobo, but even then, two sample is not enough to draw such a conclusion.

What is the brand and model of your graphics card? It seems much more likely to me that a given graphics card model would cause the problem. Why does my card work with the previous drivers (I used something like 87xx)? Why am I getting frame rates that are 10x faster on UT2004 while running a demo in 32bits instead of 64bits? There are too many variables and unidentified symptoms! Unfortunately, I don't know where to start probing. The hard lock with the 9755 drivers and the 2.6.20.4 kernel was a complete show stopper so I came here to seek the word of the wise.

My graphic card is a PNY Verto GeForce 6800GT 256MB.
Prozzaks is offline   Reply With Quote
Old 04-04-07, 03:39 AM   #11
durilka
Registered User
 
Join Date: Mar 2007
Posts: 7
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

Quote:
Originally Posted by Prozzaks
I think that is a bit excessive...
Hey, you're lucky. For me no binary driver works with 2.6.20 (just checked and I haven't tried the 87xx series - will do that tonight).
My card is probably ASUS on 6200 chipset with 128MB. I don't remember exactly.
So the only common part we have is nvidia mobo chipsets. I have a gut feeling that the root of the problem is there...
durilka is offline   Reply With Quote
Old 04-04-07, 11:58 PM   #12
Prozzaks
Registered User
 
Join Date: Mar 2007
Posts: 5
Default Re: nvidia+amd64+2.6.20+feisty = stone dead computer

With 2.6.20.4 no binary driver work. The 87xx worked with kernel 2.6.17.8. Even then, on a given UT2004 demo (self made), I got 8 fps avg, whereas with kubuntu 32 bits running I don't know what kernel version and NVidia drivers 87xx I got 85 fps avg. Even if they ran, it was far from playable. I haven't seen a lot posts about performance problem on amd64, and if it was a wide spread problem, then why would the developers of UT2004 bother to include the 64bits version?

Oh! I not just UT2004! I also get sucky performance with sauerbraten. Most people I have seen reporting performance problems didn't have GLX configured properly. I only I had another graphic card, I could rule out the video card.
Prozzaks is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM

All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.