Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-26-05, 11:20 AM   #1
Pixie
Registered User
 
Join Date: May 2005
Posts: 4
Exclamation Nvidia wont go back to 1600x1200 on FC3

Hi,

I'm running a GeForce 4 on a Dell Latitude C840 using Fedora Core 3. I once before had 1600x1200 using the Nvidia drivers but now I can't seem to get it right. I install using sh NVIDIA*

then I go through the whole process of

modprobe nvidia
cp -a /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*

then I reboot and this did once upon a time work but now it just goes into 1400x1050 and has these colourful lines on the side of my screen and the top pf my screen shows up again at the bottom!

my xorg.conf looks like this:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Dell"
ModelName "Dell 1600x1200 Laptop Display Panel"
HorizSync 31.5 - 90.0
VertRefresh 59.0 - 85.0
ModeLine "1600x1200_60.00" 161.0 1600 1704 1880 2160 1200 1201 1204 1242 -hsync -vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


I did add the modeline bit using gtf after much searching for a solution to my problem but no luck for me

My Xorg.0.log says the folowing:


(II) NVIDIA(0): Monitor0: Using hsync range of 31.50-65.00 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh range of 59.00-60.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(II) NVIDIA(0): Not using mode "1600x1200_60.00" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x350" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x175" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "720x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "360x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "512x384" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "512x384" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "512x384" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "832x624" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "416x312" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1152x768" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "576x384" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(WW) (1400x1050,Monitor0) mode clock 122MHz exceeds DDC maximum 110MHz
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using mode "1600x1200" (no mode of this name)
(II) NVIDIA(0): Not using mode "1152x864" (no mode of this name)
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0): Default mode "1400x1050": 122.0 MHz, 64.9 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "1280x1024": 108.0 MHz, 64.0 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "1280x960": 108.0 MHz, 60.0 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "700x525": 61.0 MHz, 64.9 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "640x512": 54.0 MHz, 64.0 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "640x480": 54.0 MHz, 60.0 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1400 x 1050
(--) NVIDIA(0): Display dimensions: (320, 240) mm



If anyone has any idea of what the problem is your help would be greatly appreciated. This did once work and I was able to use 1600x1200 so I'm not to sure what could have changed....
Pixie is offline   Reply With Quote
Old 05-26-05, 04:04 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Nvidia wont go back to 1600x1200 on FC3

First of all provide your WHOLE log next time(you can attach files here).

If you want to force Xorg to use your manually provided vsync and hsync, you need to give the option "IgnoreEDID" in the "Device" section.
Quote:
Option "IgnoreEDID" "1"
With the correct vsync and hsync, modelines are not necessary.
Lithorus is offline   Reply With Quote
Old 05-27-05, 05:55 AM   #3
Pixie
Registered User
 
Join Date: May 2005
Posts: 4
Default Re: Nvidia wont go back to 1600x1200 on FC3

Thanks for the help, I tried adding the option below and it did make a difference. Only now my screen is split in two. I have two identical desktops on my screen both stretched out using the whole screen though....Sort of like two 800x600 screens on top of each other. I have attached the files this time
Attached Files
File Type: txt myxorglog.txt (28.6 KB, 148 views)
File Type: txt myxorgconf.txt (2.8 KB, 166 views)
Pixie is offline   Reply With Quote
Old 05-27-05, 06:22 AM   #4
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Nvidia wont go back to 1600x1200 on FC3

Change the line
Quote:
Screen 0 "Screen0" 0 0
into
Quote:
Screen "Screen0"
Lithorus is offline   Reply With Quote
Old 05-27-05, 08:30 AM   #5
Pixie
Registered User
 
Join Date: May 2005
Posts: 4
Default Re: Nvidia wont go back to 1600x1200 on FC3

Didn't seem to change anything, still a double screen. I've attached both files again. Really appreciate the help Lithorus
Attached Files
File Type: txt myxorgconf.txt (2.8 KB, 154 views)
File Type: txt myxorglog.txt (28.4 KB, 143 views)
Pixie is offline   Reply With Quote
Old 05-28-05, 07:42 AM   #6
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Nvidia wont go back to 1600x1200 on FC3

Hmm.. which monitor is it?
Seems the hsync and vrefresh is incorrect.
The values for my monitor(dell 2001FP) is :
hsync 31 - 80 kHz
vrefresh 56 - 76 Hz

The following mode is above the maximum of 162 on DVI :
Quote:
Default mode "1600x1200": 189.0 MHz, 87.5 kHz, 70.0 Hz
Lithorus is offline   Reply With Quote
Old 05-30-05, 03:30 AM   #7
LeDmagNeT
Registered User
 
Join Date: May 2005
Posts: 5
Default Re: Nvidia wont go back to 1600x1200 on FC3

Try these settings in the Monitor section of your xorg.conf:
HorizSync 75
VertRefresh 60
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync -Vsync

Those values above for Modeline should all be on the same line, that is, Modeline should include everything up to & including that -Vsync

Hope this helps.
You can thank Kingsnake for his post at linuxquestions.org
http://www.linuxquestions.org/questions/history/312349

LeDmagNeT is offline   Reply With Quote
Old 05-30-05, 03:39 AM   #8
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Nvidia wont go back to 1600x1200 on FC3

My advice would be to avoid using modelines unless you REALLY have to. That way you avoid having to specify every single resolution. With the correct hsync and vrefresh all resolutions should be ok.
Lithorus is offline   Reply With Quote

Old 05-30-05, 06:49 AM   #9
Pixie
Registered User
 
Join Date: May 2005
Posts: 4
Default Re: Nvidia wont go back to 1600x1200 on FC3

Quote:
Originally Posted by Lithorus
Hmm.. which monitor is it?
Seems the hsync and vrefresh is incorrect.
The values for my monitor(dell 2001FP) is :
hsync 31 - 80 kHz
vrefresh 56 - 76 Hz

The following mode is above the maximum of 162 on DVI :
It's the normal display on my laptop. Dell 1600x1200 display panel should be correct. I'll mess around with hsync and vrefresh and see if I can get it right. Thanks for the help.
Pixie is offline   Reply With Quote
Old 06-02-05, 05:12 AM   #10
LeDmagNeT
Registered User
 
Join Date: May 2005
Posts: 5
Default Re: Nvidia wont go back to 1600x1200 on FC3

Quote:
Originally Posted by Pixie
It's the normal display on my laptop. Dell 1600x1200 display panel should be correct. I'll mess around with hsync and vrefresh and see if I can get it right. Thanks for the help.
You have the Dell C840 with the Samsung SEC3250 1600x1200 LCD which is believed to report incorrect EDID data.
I also have a c840 with that LCD and have the exact same problem. Many other users of this LCD screen are reporting the same probs.
This problem is also evident using WinXP and the fix is the same in concept.
You basically have to override the reported EDID data. Hence the requirement of the Option "IgnoreEDID" in your "Device" section.
Unfortunately you will need a modeline or modes to specify timings as you are overriding the EDID after all, and it seems the standard Vesa timings that come with xorg don't work for us. Well, that's how I understand it anyway. Someone please correct me if I'm wrong.

So, in short you need:
Option "IgnoreEDID" in your "Device" section
and the following in your "Monitor" section:
HorizSync 75
VertRefresh 60
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync -Vsync

That's the only fix I've managed to find that works so far.

I am using this config on my c840 and it works well under kubuntu.

Good luck.
LeDmagNeT is offline   Reply With Quote
Old 06-02-05, 11:24 AM   #11
Jiaozi
Registered User
 
Join Date: Jun 2005
Posts: 3
Talking Re: Nvidia wont go back to 1600x1200 on FC3

I've got that laptop running 2.4.29 and Xorg 6.8.2 and NV 7664. You don't need a Modeline. Just add "options nvidia NVreg_Mobile=0" to the /etc/modules.conf file or equivalent. Posted somewhere here previously.

... and don't close the laptop's lid.
Jiaozi is offline   Reply With Quote
Old 04-07-07, 05:41 PM   #12
pugsley
Registered User
 
Join Date: Jun 2004
Posts: 1
Default Re: Nvidia wont go back to 1600x1200 on FC3

I too had similar problems on a Dell Insperon 8200 - same samsung monitor with dud EDID. Had to use the customer EDID referred to in:

http://www.nvnews.net/vbulletin/show...highlight=EDID

Worked a treat for me. Also do not use SAX2 if on SUSE as that really made a muddle of Xorg.conf

good luck.
pugsley is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA and J├╝lich Join Forces to Drive GPU Computing Innovation News Archived News Items 0 06-18-12 09:50 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ę1998 - 2014, nV News.