Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-05-07, 10:37 AM   #1
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default OpenGL performance issues on SLI'd GeForce 8800's

I am running into a performance problem with the NVIDIA GeForce 8800 GTS on a Opteron platform when in SLI mode. It seems as though OpenGL performance while SLI is enabled is extremely poor.

My system configuration is the following:

4U chassis with a 1000 watt high efficiency power supply
(2) Opteron 2220 (2.8 GHz) Socket 1207 processors
(8) 2 GB DDR2-667 memory modules
146 GB SAS local disk
(2) NVIDIA GeForce 8800 GTS (640MB) hardware configured in SLI mode


I have attempted SLI on both SLES10, as well as RHEL4 with a 2.6.20 kernel having module support included by the NVIDIA linux binary, however replicated the same issue on both platforms.

When I have in my xorg.conf file `Option "SLI" "0"` with this hardware configuration I get about 22,000 frames per second when running glxgears however when I enable SLI by using `Option "SLI" "1"` or `Option "SLI" "AFRofAA"` I run into a terrifying performance hit. Running glxgears I get about ** 2.4 to 2.6 frames per second. **

I attempted to contact PNY about this (the manufacturer of my card) and they told me that they "Don't support Linux".

I fear there is a complication in my hardware configuration with the 8800 GTS configured in SLI mode. I say this because I replace my (2) 8800 GTS's with (2) Quadro 4500's configured in SLI and I get no such performance hit.

Please, if anyone has insight on this, I would greatly appreciate it!


Debug information which may or may not be usefull...

/etc/X11/xorg.conf file:
http://www.belongt0.us/2915_xorg.conf.txt


/var/log/Xorg.0.log file:
http://www.belongt0.us/2915_Xorg.0.log.txt

Kernel:
Linux version 2.6.20 (root@ls1host) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 SMP Wed Apr 4 21:07:57 MDT 2007

NVIDIA module:
NVIDIA-Linux-x86_64-1.0-9755-pkg2.run

BIOS version:
TYAN BIOS version 1.1
sysinu is offline   Reply With Quote
Old 04-05-07, 11:20 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

glxgears is not a useful benchmark. Are you experiencing performance problems with real world OpenGL applications?

Also, see the driver README's discussion of why glxgears will have lessor performance when SLI is enabled.

And finally:
http://www.nvnews.net/vbulletin/showthread.php?t=46678

thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-05-07, 11:56 AM   #3
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

Yes, I have tested against other "real" benchmarks for example the following:

Code:
Configuration       RHEL4 1 8800          RHEL4 2 8800's SLI
3dsmax-04          3.656                       0.1897
catia-02              10.28                       0.1661
ensight-03           14.23                       0.1278
light-08               8.235                       0.2644
maya-02            19.51                        0.3305
proe-04               7.545                       0.1151
sw-01                 6.157                       0.2864
ugnx-01              3.335                       0.02893
tcvis-01              4.356                        0.05313

This is a comparison of runs of SPECViewperf. I only use glxgears as a simple openGL application to demonstrate the dramatic effect of how enabling SLI for me inhibits my performance... 22,000 frames per second going down to 2.4 frames per second specifically. Similar performance characteristics are seen in my SPECViewperf benchmarks as well.
sysinu is offline   Reply With Quote
Old 04-05-07, 11:58 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 04-05-07, 12:07 PM   #5
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

Also... here is a gzip of my nvidia bug report log.
Attached Files
File Type: gz nvidia-bug-report.log.gz (122.3 KB, 95 views)
sysinu is offline   Reply With Quote
Old 04-05-07, 12:37 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

The problem here is:
NVRM: PAT index 2 already configured for Write-Combining!
NVRM: Aborting, due to PAT already being configured

All of your CPUs appear as "AMD Engineering Sample". What exactly are these CPUs? Does this problem persist if you're using a system where the CPUs are production level?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-05-07, 04:20 PM   #7
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

Heh, actually... those are TTK's (thermal test kit) from AMD. I replicate the same problem in a box with Production Opteron 2220's.
sysinu is offline   Reply With Quote
Old 04-05-07, 04:21 PM   #8
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

Silly question on my part... but what does "NVRM: PAT index 2 already configured for Write-Combining!" apply to directly? Is this something I'm doing incorrectly in my xorg.conf file? or? (sorry for sounding newbish)
sysinu is offline   Reply With Quote

Old 04-05-07, 04:33 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

The 'PAT index 2....' messages just point to an issue with how PAT is setup on the CPUs, which is what is causing the poor performance. I also noticed in your dmidecode output that you're using some kind of 'reference' or sample motherboard from Tyan. Is the 'other' system that has production quality CPUs using the same motherboard, or a production quality board?

Does this also reproduce with an official SUSE kernel?

The fact that no one else has reported this problem (and there are clearly a decent number of people using GeForce 8800 cards in SLI) really leads me to think that something in your environment is causing this, and not a driver bug. If you could provide otherwise that would be great.
netllama is offline   Reply With Quote
Old 04-05-07, 04:38 PM   #10
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

It refers to the processor's page attribute table configuration. The reset value for PAT index 2 should be UC-, not WC. Are you using a vanilla kernel?
zander is offline   Reply With Quote
Old 04-05-07, 05:13 PM   #11
sysinu
Registered User
 
Join Date: Apr 2007
Posts: 10
Default Re: OpenGL performance issues on SLI'd GeForce 8800's

Yes the other motherboard is a TYAN S2915.
Yes this is a vanilla kernel (2.6.20) -- I will give it a whirl using a 2.6.16.21-0.8 kernel (official SLES)

Both motherboards are production quality. Let me generate the NV bug report on this new box once I get the other card in it.
sysinu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM

All times are GMT -5. The time now is 09:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.