Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-07, 09:01 AM   #1
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default No XServer after Kernel-Update and reinstall of GFX-Drivers

Hi,
I am running Debian Etch on AMD 3800+ X2 with GeForce 7900 GTX.
I installed Etch with standard-Kernel 2.6.18 (32 bit), Debian NVidia-drivers and all was fine.
Then i activeted highmem and smp in the standard-Kernel (nothing else) and reinstalled the driver.
Did not work.
Freezes, when starting x.
I checked xorg.conf and it is ok (i think).
Now i just can start the xserver with "nv" instead of "nvidia" in xorg.conf.
The next problem is, i get "Segmentation fault" when i try to start some apps like xmms or krita.
The i tried to install the original drivers 9746 and 9755, but it is all the same.
Freezing, when startin x and segmentation fault, when starting xmms.
I have attached my xorg.conf, do not know, what you need.

Achmed

p.s.:Sorry for my bad english.
Attached Files
File Type: zip nvidia-bug-report.zip (24.3 KB, 98 views)

Last edited by Achmed; 04-11-07 at 09:39 AM.
Achmed is offline   Reply With Quote
Old 04-07-07, 11:33 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 04-07-07, 12:48 PM   #3
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

I added the bugreport and installer-log on my first post, but just with the nv-driver, not the "nvidia" in xorg.conf.
Achmed is offline   Reply With Quote
Old 04-07-07, 12:51 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

A bug report against the 'nv' X driver doesn't tell me anything about the problem you're reporting. You'll need to generate a bug report against the nvidia driver.
netllama is offline   Reply With Quote
Old 04-08-07, 04:00 AM   #5
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

Ok...my next try.
Here is the bug-report (i hope).

Last edited by Achmed; 04-09-07 at 01:16 PM.
Achmed is offline   Reply With Quote
Old 04-08-07, 01:10 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

According to this bug report, you uninstalled 1.0-9746:
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
Linux-x86 (1.0-9746) is complete.

however, I don't see where 1.0-9755 was installed. Does this problem persist if you (re)install the 1.0-9755 driver?
netllama is offline   Reply With Quote
Old 04-08-07, 01:40 PM   #7
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

1.0-9746 was uninstalled by the 9755-installer.
I will try tomorrow to reinstall the driver.
Achmed is offline   Reply With Quote
Old 04-09-07, 05:29 AM   #8
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

Hi again,
i reinstalled the driver today, but it is all the same.

But when i start X via ssh i get an error-message:
Code:
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining
X is not starting, and my bug-report was useless i think.
Achmed is offline   Reply With Quote

Old 04-09-07, 10:23 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

Your last bug report was basically useless as all it showed was that you uninstalled 1.0-9746 without ever installing 1.0-9755. I'll need to see a bug report which includes the installation of 1.0-9755 and the issue you just mentioned.
netllama is offline   Reply With Quote
Old 04-09-07, 01:27 PM   #10
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

Ok, i attached the bug-report again.
But again without runnning "nvidia".
I do not know, how to manage this, when X is crashing after 1 second, if running "nvidia".
Achmed is offline   Reply With Quote
Old 04-09-07, 01:35 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

You can generate the bug report after rebooting, yet before starting X.
netllama is offline   Reply With Quote
Old 04-11-07, 09:46 AM   #12
Achmed
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: No XServer after Kernel-Update and reinstall of GFX-Drivers

Quote:
Originally Posted by netllama
You can generate the bug report after rebooting, yet before starting X.
Ok, i did.
Hope, that helps.
And thank you, for your patience.
Achmed is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.