Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-07, 05:48 PM   #1
pdisessa
Registered User
 
Join Date: Apr 2007
Posts: 4
Default 8 displays (4 graphics cards) xorg problem

I have 4x 7900 GTs in my Asus P5W64 WS Professional motherboard. I am trying to configure xorg to run all 8 displays on projectors. I am able to configure 4 displays on the first two cards; however, when I add the fifth display on the third card, there is an error:

(EE) NVIDIA(4): Failed to initialize the NVIDIA graphics device!
NVIDIA: could not open the device file /dev/nvidia1 (Input/output error).
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).

I have them configured as follows:

--------------------------------

# VGA CARD 1
Section "Device"
Identifier "nvidia0"
Driver "nvidia"
Option "HorizSync" "28-95"
Option "VertRefresh" "59.9-60.1"
BusID "PCI:4:0:0"
Screen 0
EndSection

Section "Device"
Identifier "nvidia1"
Driver "nvidia"
Option "HorizSync" "28-95"
Option "VertRefresh" "59.9-60.1"
BusID "PCI:4:0:0"
Screen 1
EndSection

# VGA CARD 2
Section "Device"
Identifier "nvidia2"
Driver "nvidia"
Option "HorizSync" "28-95"
Option "VertRefresh" "59.9-60.1"
BusID "PCI:8:0:0"
Screen 0
EndSection

Section "Device"
Identifier "nvidia3"
Driver "nvidia"
Option "HorizSync" "28-95"
Option "VertRefresh" "59.9-60.1"
BusID "PCI:8:0:0"
Screen 1
EndSection

# VGA CARD 3
Section "Device"
Identifier "nvidia4"
Driver "nvidia"
Option "HorizSync" "28-95"
Option "VertRefresh" "59.9-60.1"
BusID "PCI:7:0:0"
Screen 0
EndSection

Section "Screen"
Identifier "Screen0"
Device "nvidia0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "SONY"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "nvidia1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "SONY"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "nvidia2"
Monitor "Monitor2"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "SONY"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen3"
Device "nvidia3"
Monitor "Monitor3"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "SONY"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen4"
Device "nvidia4"
Monitor "Monitor4"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "SONY"
EndSubSection
EndSection

Section "Monitor"
Identifier "Monitor0"
HorizSync 28-80
VertRefresh 59.95-60.02

Option "ExactModeTimingsDVI" "True"
Modeline "1920x1080p60" 148.5 1920 1976 2008 2200 1080 1083 1085 1125 +Hsync +Vsync
Modeline "ATSC-1080-60p" 148.4 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync
Modeline "1920x1080" 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +HSync -Vsync
Modeline "SONY" 151.2 1920 1936 1992 2240 1080 1082 1088 1125 +hsync +vsync
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Screen0" 0 0
Screen "Screen1" RightOf "Screen0"
Screen "Screen2" RightOf "Screen1"
Screen "Screen3" RightOf "Screen2"
Screen "Screen4" RightOf "Screen3"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

--------------------------

Each MonitorN is set up exactly like Monitor0

Thank you in advance for any help.
pdisessa is offline   Reply With Quote
Old 04-16-07, 07:03 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8 displays (4 graphics cards) xorg problem

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 04-17-07, 10:10 AM   #3
pdisessa
Registered User
 
Join Date: Apr 2007
Posts: 4
Default Re: 8 displays (4 graphics cards) xorg problem

Ok, well I have searched the NVIDIA Linux Forum, and though there are similar threads, NONE give a solution. There were some posts that said they achieved 8 displays on one machine, but they failed to mention how.

Here is a copy of then nvidia-bug-report.log file.
Attached Files
File Type: zip nvidia-bug-report.zip (26.2 KB, 97 views)
pdisessa is offline   Reply With Quote
Old 04-17-07, 10:22 AM   #4
pdisessa
Registered User
 
Join Date: Apr 2007
Posts: 4
Default Re: 8 displays (4 graphics cards) xorg problem

Here is my xorg.conf file. I have commented out devices/screens/monitors 5-7. When I add device/screen/monitor 4, it does not display anything; however, 0-3 do display correctly. If I comment out 2 and 3, and use 4 and 5, then they work. It seems only 4 displays across 2 cards can be configured at a time. To reiterate, I am trying to run 8 displays over 4 PCI-E 7900 cards.

The PCI busIDs are:
# lspci | grep VGA
04:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GT (rev a1)
07:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GT (rev a1)
08:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GT (rev a1)
09:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GT (rev a1)
Attached Files
File Type: zip xorg-conf.zip (1.6 KB, 97 views)
pdisessa is offline   Reply With Quote
Old 04-17-07, 11:39 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8 displays (4 graphics cards) xorg problem

In your bug report, I see:
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
NVRM: RmInitAdapter failed! (0x23:0xffffffff:679)
NVRM: rm_init_adapter(0) failed

This issue is discussed in the driver README.
netllama is offline   Reply With Quote
Old 04-17-07, 12:34 PM   #6
pdisessa
Registered User
 
Join Date: Apr 2007
Posts: 4
Default Re: 8 displays (4 graphics cards) xorg problem

Thank for the help. I must have not seen that when I looked at the log. I added the kernel and grub options listed in a previous thread and the 8 displays work. However, during this whole thing, I installed 1.0.9755 drivers direct from Nvidia. Now, when I reboot the computer X segfaults. I have to reinstall the NVIDIA-Linux-x86-1.0-9755 drivers in order to resolve this. Is there a thread on the forum discussing this issue???
pdisessa is offline   Reply With Quote
Old 04-17-07, 12:39 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8 displays (4 graphics cards) xorg problem

There is this thread:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

Beyond that I'd need to see a new bug report, although its unlikely that the segfault is a driver bug if reinstalling the driver fixes the issue.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 09:43 AM

All times are GMT -5. The time now is 12:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.