Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-07, 09:01 PM   #1
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default GLX Extension hangs Xorg

Hi, i have installed the 5 most recent version of nVidias linux drivers trying to get them to work(no luck). The card is a GeForce 7800 GT For some reason, the glx extension just freezes xorg, and i have to CTRL+ALT+F1 to get out. I just re installed gentoo linux, and this has not been a problem in the past. Here is some info about my system(yes, binary drivers are not supported on hardened, but this kernel/exact system is not new for me, i am sure it is a configuration error on my system, never had trouble with hardened in the past(this is a fresh install, but all the software versions are the previous ones)):

xorg-x11 7.0

Portage 2.1.2.2 (hardened/x86/2.6, gcc-3.4.6, glibc-2.3.6-r5, 2.6.19-hardened-r6 i686)
================================================== ===============
System uname: 2.6.19-hardened-r6 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 17 Apr 2007 04:30:01 +0000
dev-lang/python: 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.60
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=i686 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac aim alsa arts avi bash-completion bashlogger berkdb bitmap-fonts cairo cdr chroot cli cpudetection crypt cups dbus dlloader dri dvd dvdr eds emboss encode esd fam firefox fortran gdbm gif gimp gmail gnome gphoto2 gpm gstreamer gtalk gtk gtkspell hal hardened ipv6 irssi isdnlog jpeg ldap libg++ mad midi mikmod mmx mono mp3 mpeg mpeg2 mplayer nautilus ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl pic png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl symlink tcpd truetype truetype-fonts type1-fonts udev unicode vorbis win32codecs x86 xchat xchattext xinerama xml xorg xv zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nv vesa"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Here is the actuall Xorg.log showing the freeze:

(II) NVIDIA(0): Setting mode "1280x1024,1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX

Full log:
http://pastebin.ca/445721


xorg.conf:
http://pastebin.ca/445722

nvidia installer log:
http://pastebin.ca/445727

nvidia bug report:
http://pastebin.ca/446364

Please help! i have googled around all day to no avail on this freeze! i am positive its a configuration error somewhere!

Also for anyone who thinks : "why the crap are you using grsecurity and Pax? its a desktop machine!"
1st of all: i disabled both and glx still fails to load
2nd of all: I run openssh, and openvpn daemons for a secure connection at public wifi. Even windows vista has some of the security offered by pax and grsecurity(although not nearly as much)
Pax problems are immediately identifiable, with a swift "Killed"
Grsecurity are less identifiable, but the problems loading GLX are still their with both pax and grsecurity gone.
and for the second time: nvidia worked fine in the past on this exact kernel(with grsec and pax)...
Ov3nCleaner is offline   Reply With Quote
Old 04-17-07, 09:11 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GLX Extension hangs Xorg

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 04-17-07, 09:33 PM   #3
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

added the nVidia bug report... is that what you wanted me to do by saying that? i have allready searched the forums... also added card specifics
Ov3nCleaner is offline   Reply With Quote
Old 04-17-07, 10:02 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GLX Extension hangs Xorg

In your bug report I see:
(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)

Does this problem persist if you're using a kernel.org kernel rather than a grsecurity kernel?
netllama is offline   Reply With Quote
Old 04-17-07, 10:08 PM   #5
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

I turned GRsecurity and Pax off in my kernel(which basicly makes it vanilla), but i could build a kernel.org kernel if you would like(like i said before, i am on a tried and true pax+grsecurity kernel that has never failed before, but im sure it could). Thats strange that it dosnt exist.... i CLEARLY see a libglx (libglx.so.1.0.9755) in /usr/libs/xorg/modules/extensions. i will making a symlink to it as libglx.so.1, libglx.so.2, and libglx.so. Xorg is going whack on me or something, and i dont think this is a dll loader problem by the looks of it.

EDIT:

i tried creating symlinks, its still failing. Where does Xorg look for the extension? im so confused :X. I clearly see the library in /usr/lib/xorg/modules/extensions... what could i be doing wrong?

SECOND IMPORTANT EDIT:
#
(II) LoadModule: "glx"
#
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
#
(II) Module glx: vendor="NVIDIA Corporation"
#
compiled for 4.0.2, module version = 1.0.9755
#
Module class: X.Org Server Extension
#
ABI class: X.Org Server Extension, version 0.1
#
(II) Loading extension GLX

that was from my last Xorg.log. It loads just fine... wtf!
it looks like nvidia bug report posted when i switched to the opengl interface "x11-xorg"
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 12:50 AM   #6
JustinVenus
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: GLX Extension hangs Xorg

Ov3nCleaner

Since you are running Gentoo execute `eselect opengl list` and make sure your OpenGL implementation is set to nvidia and not xorg-x11

if you need to set your implementation to nvidia you can execute `eselect opengl set nvidia`
JustinVenus is offline   Reply With Quote
Old 04-18-07, 08:18 AM   #7
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

Yeah i allready made sure of that, did it several times. let me get you a newer bug report.sh error.
http://pastebin.ca/446364

^^^^ Updated actual bug report.
GLX loads fine, it just wont initialize

Ill try using my brothers graphics card, and then ill try a kernel.org kernel(although i turned of pax and grsecurity), althought i dont know why the Xorg GLX module could crash it if its not running in the kernel?
I also tried changing to a vanilla GCC.

Check this out:
#
(II) LoadModule: "glx"
#
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
#
(II) Module glx: vendor="NVIDIA Corporation"
#
compiled for 4.0.2, module version = 1.0.9755
#
Module class: X.Org Server Extension
#
ABI class: X.Org Server Extension, version 0.1
#
(II) Loading extension GLX
#
(II) LoadModule: "nvidia"
#
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
#
(II) Module nvidia: vendor="NVIDIA Corporation"
#
compiled for 4.0.2, module version = 1.0.9755
#
Module class: X.Org Video Driver

The glx extension and nvidia driver are compiled for xorg 4.0.2? that makes no sense, unless that version number means something else.
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 10:50 AM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GLX Extension hangs Xorg

How did you install the driver? Does it work if you uninstall the driver via Gentoo and use the .run installer? It sounds like Gentoo's ebuilds are installing the wrong TLS libraries.
AaronP is offline   Reply With Quote

Old 04-18-07, 10:54 AM   #9
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

AaronP: i have tried both. All 5 current ebuilds, and The most current nVidia driver, which worked before(same kernel version and config as my last install, down to the last option). Same error with them all. i dont think the problem is driver specific. This current nvidia-bug report was nvidia-drivers ebuild 9755 (the most current one from nVidias website). Ill grab a bug report from the nVidia installer, but im sure it will be the same.
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 10:59 AM   #10
JustinVenus
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: GLX Extension hangs Xorg

My Xorg.0.log contains the same entry.

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.9755
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX

No VBIOS information

#/proc/driver/nvidia/cards/0
#Model: GeForce 7800 GT
#IRQ: 20
#Video BIOS: ??.??.??.??.??
#Card Type: PCI-E
#DMA Size: 39 bits
#DMA Mask: 0x7fffffffff

This may sound weird, but try adding the following to your kernel line in your grub.conf
pci=nommconf vmalloc=256MB

That fixed a whole bunch of problems for my box ... weird lock-ups and such

/proc/driver/nvidia/cards/0
Model: GeForce 7600 GT
IRQ: 22
Video BIOS: 05.73.22.51.05
Card Type: PCI-E
DMA Size: 39 bits
DMA Mask: 0x7fffffffff

____________________________________________

/proc/driver/nvidia/cards/1
Model: GeForce 7600 GT
IRQ: 22
Video BIOS: 05.73.22.51.25
Card Type: PCI-E
DMA Size: 39 bits
DMA Mask: 0x7fffffffff
JustinVenus is offline   Reply With Quote
Old 04-18-07, 11:09 AM   #11
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

just added it to my grub boot options, will try it when im home (im ssh'd to my box from school)
And what was that earlier about TLS library issues? any idea how to fix?
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 12:11 PM   #12
MCMcButtah
Registered User
 
Join Date: Feb 2007
Posts: 26
Default Re: GLX Extension hangs Xorg

I have a 7900GS running on Kubuntu 6.10. Last week after working great for months GLX was crashing X for no reason. xorg.log showed that it didn't load the module. If I tried to use anything that touched GLX, X would restart. I reinstalled the 9755 drivers and it fixed my problem.
MCMcButtah is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 03:42 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 03:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.