Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-18-07, 03:00 PM   #13
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

tried reinstalling/ uninstalling in many combinations, many times, on many kernels (gentoo-sources,hardened-sources,vanilla-sources)
Its a brand new gentoo installation btw.
didnt work for me.

if the stupid glx module was open source i could edit it and add verbose debug messages for every step, but Intellectual Property > Customer apparently. All the dll loader issues on hardened kernels have been fixed since Xorg 7.*, so im possitive the problem is with the glx extension
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 05:34 PM   #14
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GLX Extension hangs Xorg

Ov3nCleaner,
You can force the installer to use a particular TLS mechanism:
Code:
       --force-tls=FORCE-TLS
              NVIDIA's OpenGL libraries are compiled with one of two different
              thread local storage (TLS) mechanisms: 'classic  tls'  which  is
              used  on systems with glibc 2.2 or older, and 'new tls' which is
              used  on  systems  with  tls-enabled   glibc   2.3   or   newer.
              nvidia-installer  will  select  the OpenGL libraries appropriate
              for your system; however, you may use this option to  force  the
              installer  to install one library type or another.  Valid values
              for FORCE-TLS are 'new' and 'classic'.
AaronP is offline   Reply With Quote
Old 04-18-07, 06:11 PM   #15
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

still no good :[. i just tried another kernel version (2.6.17) and i still am getting the screen, except this time, it hard froze, i couldnt even CTRL+ALT+F1. Tried the TLS options as well, no go, no difference.

i allready tried a clean GCC profile with no stack smash protection or PIE enabled. what could possibly be the problem? i am completely confused, and the lack of debug notices/symbols really hurts my ability to fix my own system (which i normally do)
Ov3nCleaner is offline   Reply With Quote
Old 04-18-07, 06:12 PM   #16
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GLX Extension hangs Xorg

I'd like to see a new bug report.
netllama is offline   Reply With Quote
Old 04-18-07, 10:18 PM   #17
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

Posted new bug report, but for some reason, its the hardened sources one. Sorry, one secodn

Edit: here it is
http://pastebin.ca/447486

thanks for being patient with me, its a really new thing for the nVidia drivers to just refuse to work for me. Worked accross 3 different distros with no problems :[

looks like the same hanging bug to me....
Im going to swap me and my brothers cards and try.

EDIT:

There are a bunch of updates to X on gentoo stable, updating and seeing if i have any luck :]

Update:

Nope, no luck. same bug with the glx module still here :[
Ov3nCleaner is offline   Reply With Quote
Old 04-19-07, 06:28 PM   #18
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

bump :[
Ov3nCleaner is offline   Reply With Quote
Old 04-19-07, 08:15 PM   #19
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GLX Extension hangs Xorg

In your bug report, I see:
-> License not accepted. Aborting installation.

If this problem persists after installing the official driver package, I'd like to see a new bug report.
netllama is offline   Reply With Quote
Old 04-20-07, 10:24 PM   #20
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

screw it, i am re installing. thanks for the help anyway, not sure what was wrong :[
Ov3nCleaner is offline   Reply With Quote

Old 04-26-07, 11:59 PM   #21
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

well i re installed, but no luck. Is their a build of the GLX module with verbose output? because im getting **** from the module :[. I should be able to use nvidia drivers on a hardened system... and i have almost proved my Pax + Grsecurity kernel is not to blame by switching kernels. I tried my brothers geforce 6600 GT and it didnt work either. so im POSSITVE its nvidias drivers and something in my userland....
Has anyone else had issues on a hardened system recently?
Ov3nCleaner is offline   Reply With Quote
Old 04-28-07, 11:55 AM   #22
Ov3nCleaner
Registered User
 
Join Date: Apr 2007
Posts: 21
Default Re: GLX Extension hangs Xorg

bump :[
Ov3nCleaner is offline   Reply With Quote
Old 05-07-07, 08:22 AM   #23
angra
Registered User
 
Join Date: May 2007
Posts: 1
Default Re: GLX Extension hangs Xorg

I had almost same problem though not in gentoo but debian/etch. No difference if I used default debian non-free nvidia-glx package or if used latest drivers from nvidia site. Just after installing binary drivers X starts fine. I can restart X several times and it will continue to work. But rebooting of my PC leads to described problem (black screen, nothing in log after "Initializing extension GLX"). So it doesn't look like kernel or distro specific. And, yes, I tried several versions of binary drivers, same problem with all of them. Nothing unusual in dmesg too.

I've examined /etc/init.d and found several nvidia* scripts there. I think some nvidia packages I had in past created this scripts but did not removed them after deinstallation. Quick look at these scripts shows that they do something with nvidia TLS. I've removed all nvidia* scripts from /etc/init.d, reinstalled driver and rebooted PC - now it starts fine. I do not remember where exactly init scripts are in gentoo but I think you know , so check if this will help you.
angra is offline   Reply With Quote
Old 05-13-07, 03:59 PM   #24
AciDLog
Registered User
 
Join Date: Mar 2005
Posts: 17
Default Re: GLX Extension hangs Xorg

Hello,

i have a DELL Inspiron 9400 with a 7900gs go.

i have the same problem like ovm3cleaner. i use xorg-x11 7.2 and i tryed every nvidia driver into gentoo (1.0.8776-r1 ~1.0.9631-r1 ~1.0.9746-r1 ~1.0.9755-r1). the first driver is market as stable and works without glx perfectly but when i activate glx into the xorg file and i start kde with startx my screen is white and the computer is hangup. i can only restart. i think its a bug. i dont know. i tryed also the driver from the nvidia website. same problem.

are there any solutions at the moment?
AciDLog is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 04:42 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 06:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.