Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-04-08, 01:56 PM   #1
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Exclamation Sporadic lock-up upon X startup (up to 169.12 affected)

On my Asus W7J, X happens to lock up when it starts.

It looks like a race condition is taking place, because the blinking text cursor (placed at top left, right after switch to vt7) stops blinking for a variable duration not explained by cpu load. At that time either it resumes blinking, or not.
When it resumes blinking, screen resolution change takes place and X continues loading, and everything is fine and stable.
When it does not resume, the computer is locked up, fan (which is controlled for both cpu and gpu) spins up a lot, suggesting heavy load on either cpu or gpu, and I can Alt+SysRq+REISUB. It then reboots and usually locks again in the same way: it is very seldom that I can start X again this way, even if I try many times in a row. I have to power down (usually I Alt+SysRq+REISUB and press power button during POST) to make it work again. I could not try testing network responsiveness yet (either ping or ssh).

This never happened with other drivers (vesa, nv), although I lack testing with them because I mainly run nvidia driver. Also, the blinking text cursor does not appear at all if I don't use a fb driver, but behavior is the same (and is consistent across fb drivers too).
Attached Files
File Type: log nvidia-bug-report.log (96.7 KB, 97 views)
lloeki is offline   Reply With Quote
Old 03-12-08, 02:30 PM   #2
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Sporadic lock-up upon X startup (up to 169.12 affected)

By syncing+rebooting (using sysrq) and starting back in runlevel 3, I managed to get a Xorg.0.log of the crash.

It seems to block around glx module.
Attached Files
File Type: log Xorg.0.log (19.7 KB, 92 views)

Last edited by lloeki; 03-13-08 at 04:42 PM.
lloeki is offline   Reply With Quote
Old 03-13-08, 09:25 AM   #3
uggwar
Registered User
 
Join Date: Mar 2008
Posts: 1
Default Re: Sporadic lock-up upon X startup (up to 169.12 affected)

Same here. Running on a dell d820 with a Quadro NVS 110M.
uggwar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.