Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-19-07, 11:04 PM   #1
///MVinny
WSP Most Wanted
 
///MVinny's Avatar
 
Join Date: Apr 2007
Posts: 39
Default 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1 ]

Display: 60-inch rear projection 1080i, HDTV, Sony KDS-R60XBR1.

Card: GeForce 7900 GS, AGP 8X, DVI to HDMI.

Box: AMD64, Linux Kubuntu Edgy 6.10,

Kernel: 2.6.17-11 generic. Xorg 7.1.1. Nvidia 1.0-9755.

The graphics and platform are very stable. KDE runs a beautiful 32 bpp display with excellent 3D and 2D motion.

The panel's native resolution is 1080i, [ xorg EDID section snip: ]
Code:
(--) NVIDIA(0): --- EDID for SONY TV (DFP-0) ---(--) NVIDIA(0): Detailed Timings:
...
...
(--) NVIDIA(0):   1920 x 1080 @ 60 Hz
(--) NVIDIA(0):     Pixel Clock      : 74.25 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1920, 2008
(--) NVIDIA(0):     HSyncEnd, HTotal : 2052, 2200
(--) NVIDIA(0):     VRes, VSyncStart : 540, 542
(--) NVIDIA(0):     VSyncEnd, VTotal : 547, 562
(--) NVIDIA(0):     H/V Polarity     : +/+
(--) NVIDIA(0):     Extra            : Interlaced

The problem: 1080i (or other interlaced resolutions it seems) are unused, nvidia-auto-select will instead use:
Code:
(II) NVIDIA(0): Native backend timings for SONY TV (DFP-0):
(II) NVIDIA(0):   1280 x 720 @ 60 Hz
(II) NVIDIA(0):     Pixel Clock      : 74.25 MHz
(II) NVIDIA(0):     HRes, HSyncStart : 1280, 1390
(II) NVIDIA(0):     HSyncEnd, HTotal : 1430, 1650
(II) NVIDIA(0):     VRes, VSyncStart :  720,  725
(II) NVIDIA(0):     VSyncEnd, VTotal :  730,  750
(II) NVIDIA(0):     H/V Polarity     : +/+
(II) NVIDIA(0): 
(II) NVIDIA(0): 
(II) NVIDIA(0): --- Modes in ModePool for SONY TV (DFP-0) ---
(II) NVIDIA(0): "nvidia-auto-select" : 1280 x  720 @  60.0 Hz  (from: EDID)
(II) NVIDIA(0): "1280x720"           : 1280 x  720 @  60.0 Hz  (from: EDID)
(II) NVIDIA(0): "1280x720_60"        : 1280 x  720 @  60.0 Hz  (from: EDID)
...
...
1920x1080i worked perfectly on this same platform, display panel, using ATI Radeon 9600.

Bug report attached, Xorg.0.log attached [startx -- -logverbose 5], look forward to troubleshooting further and thank you for your assistance in advance.

Cheers,

Vinny.

[link to Sony KDS-R60XBR1 specs]
http://www.sonystyle.com/is-bin/INTE...me=specs&var2=
Attached Files
File Type: log nvidia-bug-report.log (119.9 KB, 185 views)
File Type: log Xorg.0.log (33.4 KB, 186 views)
///MVinny is offline   Reply With Quote
Old 04-20-07, 01:35 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

I think you need to start with -logverbose 6 to get the detailed mode validation log.
AaronP is offline   Reply With Quote
Old 04-20-07, 08:37 AM   #3
rerushg
Registered User
 
Join Date: Mar 2007
Location: South Carolina, USA
Posts: 99
Send a message via AIM to rerushg
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1 ]

MVinny:
Very curious to see how this works out. I have very similar set-up except Panasonic PTV and PCI-E card.
Could not get DVI/DVI to work properly. EDID recognition was "DFP" (digital flat panel), same as your log shows. Recognition is fine in WinXP and NV Control Panel gives complete control of display.
In Linux (Ubuntu 6.06) I switched to S-video output with splitter to component input and used "TV" modes in Xorg.conf to get display. Suspected "buggy" EDID and gave up on DVI/DVI.
Hopefully these friendly folks can get you fixed and I'll get "fixed" too.

Good luck
(and thanks in advance NV)
rerushg is offline   Reply With Quote
Old 04-20-07, 10:42 AM   #4
///MVinny
WSP Most Wanted
 
///MVinny's Avatar
 
Join Date: Apr 2007
Posts: 39
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Good morning Aaron, Done...

[ Modes rejected ?? Interesting, want to buy a TV? ] Thanks for the help on this. -6 reveals quite a bit.

Rerushg, I'm hoping I can stick with the DVI-HDMI setup, but we'll see.

This looks to be the problem:
Code:
(II) NVIDIA(0): --- Building ModePool for SONY TV (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 74.25 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart :  540,  542
(II) NVIDIA(0):       VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):       Extra            : Interlace
(WW) NVIDIA(0):     Mode is rejected: VertRefresh (120.1 Hz) out of range
(WW) NVIDIA(0):     (59.000-61.000 Hz).
120 Hz, yeah I wish. Aaron, any thoughts? Thank you in advance. I also see my panel reports:
Code:
(--) NVIDIA(0): Connected display device(s) on Unknown at PCI:1:0:0:
(--) NVIDIA(0):     SONY TV (DFP-0)
 ...
 ...
(--) NVIDIA(0): SONY TV (DFP-0): DFP modes are not limited to 60 Hz refresh
Attached Files
File Type: zip 2.Xorg.0.zip (13.3 KB, 185 views)
File Type: zip 2.nvidia-bug-report.zip (28.6 KB, 156 views)
///MVinny is offline   Reply With Quote
Old 04-20-07, 08:36 PM   #5
miltiad
Registered User
 
Join Date: Jun 2006
Posts: 26
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Let me know the result of your tests my HDMI cable is ordered.
miltiad is offline   Reply With Quote
Old 04-20-07, 08:58 PM   #6
xbobmx
Registered User
 
Join Date: May 2003
Posts: 191
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Try adding:
Code:
Option "ModeValidation" "NoVertRefreshCheck"
to your xorg.conf file.
xbobmx is offline   Reply With Quote
Old 04-21-07, 03:23 AM   #7
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Quote:
Originally Posted by ///MVinny
120 Hz, yeah I wish.
This has been discussed before. You will probably find several other threads by sarching for this.
pe1chl is offline   Reply With Quote
Old 04-21-07, 01:53 PM   #8
///MVinny
WSP Most Wanted
 
///MVinny's Avatar
 
Join Date: Apr 2007
Posts: 39
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Quote:
Originally Posted by xbobmx
Try adding:
Code:
Option "ModeValidation" "NoVertRefreshCheck"
to your xorg.conf file.
xbobmx: Although I need some further tweaking, this yielded some success! I did try this setting before however, not without some other options which may have done more harm than good.

So far so good though:
Code:
(II) NVIDIA(0): --- Building ModePool for SONY TV (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 74.25 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart :  540,  542
(II) NVIDIA(0):       VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):       Extra            : Interlace
(II) NVIDIA(0):     Mode is valid.
I need to do a little poking around here, it looks like the 1920 x 540 resolution is being used instead of 1920x1080, (picture is stretched vertically). Albeit a success in the sense I'm making some progress!
///MVinny is offline   Reply With Quote

Old 04-21-07, 07:00 PM   #9
///MVinny
WSP Most Wanted
 
///MVinny's Avatar
 
Join Date: Apr 2007
Posts: 39
Question Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Next question: The best resolution displaying is 1920 x 540, rather than 1920 x 1080. I looked around the other posts and tried various Screen options to no avail, permit me to start here:

Code:
(II) NVIDIA(0): --- Building ModePool for SONY TV (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60 Hz
(II) NVIDIA(0):     Mode Source: EDID
 . . .
 . . .
(II) NVIDIA(0):     Mode is valid.
Okay, but:
Code:
(II) NVIDIA(0): --- Modes in ModePool for SONY TV (DFP-0) ---
(II) NVIDIA(0): "nvidia-auto-select" : 1920 x 1080 @ 120.1 Hz Interlace  (from: EDID)
(II) NVIDIA(0): "1920x1080"          : 1920 x 1080 @ 120.1 Hz Interlace  (from: EDID)
(II) NVIDIA(0): "1920x1080_120i"     : 1920 x 1080 @ 120.1 Hz Interlace  (from: EDID)
(II) NVIDIA(0): "1920x1080_120i_0"   : 1920 x 1080 @ 120.0 Hz Interlace  (from: EDID)
Xorg:
Code:
Section "Screen"
 . . . 
 . . .
     Option       "Modevalidation" "NoVertRefreshCheck"
 . . .
 . . . 
         Modes "1920x1080"
I also used 1920x1080_120i , and 1920x1080_120i_0 as well on the modes line, same result and display sticks to 1920x540. Thank you all for any help in advance.
Attached Files
File Type: zip 3.nvidia-bug-report.zip (34.0 KB, 165 views)
File Type: zip 3.Xorg.0.zip (13.9 KB, 167 views)
///MVinny is offline   Reply With Quote
Old 04-24-07, 05:37 PM   #10
///MVinny
WSP Most Wanted
 
///MVinny's Avatar
 
Join Date: Apr 2007
Posts: 39
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Bump

{ I put the ATI radeon 9600 back in, 1920 x 1080 works great, still ! }
///MVinny is offline   Reply With Quote
Old 04-24-07, 10:25 PM   #11
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

What exactly is reporting 1920x540? Your log file indicates that your desktop is 1920x1080.
Code:
(II) NVIDIA(0): MetaMode "1920x1080":
(II) NVIDIA(0):     Bounding Box: [0, 0, 1920, 1080]
(II) NVIDIA(0):     SONY TV (DFP-0): "1920x1080"
(II) NVIDIA(0):         Size          : 1920 x 1080
(II) NVIDIA(0):         Offset        : +0 +0
(II) NVIDIA(0):         Panning Domain: @ 1920 x 1080
(II) NVIDIA(0):         Position      : [0, 0, 1920, 1080]
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
AaronP is offline   Reply With Quote
Old 04-25-07, 07:58 AM   #12
rerushg
Registered User
 
Join Date: Mar 2007
Location: South Carolina, USA
Posts: 99
Send a message via AIM to rerushg
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

Aaron:
Not an expert here so hope I'm not "stating the obvious" to you.

Note that in MVinny's original bug report the 1920x1080 mode was rejected because vertrefresh was out of range from EDID data.
He then added the option to ignore vertrefresh check so mode was accepted. But he got a vertically stretched 1920x540 display. That suggests to me that the same 1920x540 data was "interlaced with itself", resulting in apparent vert stretch.

Seems to be a "factor of 2" misunderstanding going on. (Same with my Panasonic.)
I.e.: I believe that in interlaced mode a frequency of 60 Hz is "per pass" @ 1920x540. At the needed 2 passes per "total picture" the "net frequency per picture" is 30 Hz.
Perhaps NV's 120 Hz mode frequency is a bug? Perhaps EDID should report 120 hz?
Seems the two are out of sync.
rerushg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.