Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-07, 11:24 AM   #13
bucky
Registered User
 
Join Date: May 2007
Posts: 8
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

tried under debian unstable works like a charm.

I have one ubuntu machine will it work there ?


Thanks ___Jul___
bucky is offline   Reply With Quote
Old 05-04-07, 02:29 PM   #14
___Jul___
Debian Maniac
 
Join Date: May 2007
Location: Europe::Germany::Darmstadt
Posts: 21
Send a message via ICQ to ___Jul___
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Thanks bucky,
well as long as Ubuntu is actually debian clone it should work. I can't guarantee that the paths to kbuild will be the same however that is why you might have to slightliy modify these in the nvidia-patch.sh script. If you have problems post them here or pm me I'll be glad to help.
Jul
___Jul___ is offline   Reply With Quote
Old 05-05-07, 06:12 AM   #15
Greek Geek
Registered User
 
Join Date: Jan 2005
Posts: 10
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Hiya Debian Maniac,

I've tried your, "Patched version of the NVidia driver for 2.6.20 kernel," & it worked like 300 Spartans!

Many thanx! :-)

Greek Geek :-)
Greek Geek is offline   Reply With Quote
Old 05-05-07, 01:17 PM   #16
___Jul___
Debian Maniac
 
Join Date: May 2007
Location: Europe::Germany::Darmstadt
Posts: 21
Send a message via ICQ to ___Jul___
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Just for a little more information of what is actually going on in this archive and how the solution work i tried to summarize it on the following page :

http://grizach.servebeer.com/nvpatch/index.php

And thanks for the support from all that reported the patch working
Jul
___Jul___ is offline   Reply With Quote
Old 05-06-07, 09:27 AM   #17
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Hi,

Neat. Except I have to use the 9631 driver because of the MX-440 and MX-4000 videocards. Is there a description as to how to create the patched version of that driver?

Thanks!

Hugo
hvw59601 is offline   Reply With Quote
Old 05-06-07, 09:29 AM   #18
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Too quick!
I found http://grizach.servebeer.com/nvpatch/index.php
Thanks!
hvw59601 is offline   Reply With Quote
Old 05-06-07, 10:58 AM   #19
___Jul___
Debian Maniac
 
Join Date: May 2007
Location: Europe::Germany::Darmstadt
Posts: 21
Send a message via ICQ to ___Jul___
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Quote:
Originally Posted by hvw59601
No problem,
however I packaged the 9631 version and it is available for download from the same page. I didn't try to install in on my computer but the kernel module compiles so I guess it should be working too.
___Jul___ is offline   Reply With Quote
Old 05-07-07, 12:36 PM   #20
giraf
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Hi ,
Can you describe step by step how should I use this patch ? How exactly do I run it ?
Thanks.
giraf is offline   Reply With Quote

Old 05-07-07, 05:11 PM   #21
___Jul___
Debian Maniac
 
Join Date: May 2007
Location: Europe::Germany::Darmstadt
Posts: 21
Send a message via ICQ to ___Jul___
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Well if you want to use the already patched version of the driver that is provided in the links from the previous posts you just have to run it from the console like this

Code:
me@mycomp:path$ ./NVIDIA-Linux-x86-100.14.03-pkg1-patched.run
And follow the instructions on screen.

Maybe what is good to know you have to make sure you have the packages for the kernel headers, kbuild installed. If you are running debian you can run

apt-get install linux-headers-2.6.20-1-k7 linux-kbuild-2.6.20 (make sure to replace the k7 suffix with your proper type of kernel - you can use uname -r to see it)

If you'd like to patch the original driver from NVidia than you'll have to read the instructions on the internet page supplied and try to follow them - they are not that diffilcult but I won't try it alone if I were not sure as of exactly how it is meant to work.

Good Luck and if still in trouble don't hesitate to ask again but please describe what you already achieved and what are your troubles/concerns for me to help you in a more concrete way.

Jul
___Jul___ is offline   Reply With Quote
Old 05-08-07, 12:53 AM   #22
giraf
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

OK thanks , I'll try it , now that I know how to run the patch.
giraf is offline   Reply With Quote
Old 05-11-07, 06:50 AM   #23
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

Hi,

There is a second option of course and that is changing Debian 2.6.20-1-k7. Change it just to turn off CONFIG_PARAVIRT but keep all the Debian patches that are installed.

I have set up a wiki:
http://wiki.debian.org/HowToRebuildA...nKernelPackage

Hugo
hvw59601 is offline   Reply With Quote
Old 05-16-07, 06:49 AM   #24
giraf
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: Install fails with Debian 2.6.20-1-k7 + Linux-x86-1.0-9755/Linux-x86-100.14.03

HI Jul,
I finally tried it (09631) but when I wanted to load it (X) he told me it couldn't find the glx and the nvidia modules, although it finish successfully running the patch . (so i moved back to the old X config)
any ideas ?

Thanks.
giraf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.