Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-21-07, 11:54 PM   #1
r27182818
Registered User
 
Join Date: Apr 2007
Posts: 3
Default CRT whistles with GeForce MX 4000

Hi folks,

I have dual monitors. One is a 1280x1024 flat panel, and the other is a 1024x768 CRT. Until this morning, I did not realize that I could drive both from my nVidia card. After setting up TwinView, everything works great except for one thing: the CRT sometimes emits a high-pitched whistle/squeal. It is very annoying, and it gets worse when large white areas are displayed. Power-cycling the CRT or smacking it sometimes make the squeal go away temporarily.

This same problem occurred when the CRT was attached to the other video card (an ATI), and I solved it by placing the following modeline in the Monitor section for the CRT:

Modeline "1024x768" 88.50 1024 1088 1200 1376 768 769 772 804 -HSync +Vsync

Now that I only have one Monitor section, I've place the above modeline in there, but the problem persists.

I am using driver version 8776.

Any suggestions would be very welcome. Please let me know what additional information would be helpful. My xorg.conf is attached.

Thanks,

Reid
Attached Files
File Type: txt xorg.conf.txt (3.2 KB, 91 views)
r27182818 is offline   Reply With Quote
Old 04-22-07, 12:56 AM   #2
LycosV
Registered User
 
LycosV's Avatar
 
Join Date: Jul 2003
Posts: 888
Default Re: CRT whistles with GeForce MX 4000

I've had my CRT monitors whine before, change the refresh rate to something else, that generally fixes it (or at least changes the pitch of the whining sound to something outside the audible range).
LycosV is offline   Reply With Quote
Old 04-22-07, 12:36 PM   #3
r27182818
Registered User
 
Join Date: Apr 2007
Posts: 3
Default Re: CRT whistles with GeForce MX 4000

Yeah, that's what I figured. I assume that's what the modeline did. But how can I change the refresh rate?

Thanks!

Reid
r27182818 is offline   Reply With Quote
Old 04-22-07, 02:58 PM   #4
r27182818
Registered User
 
Join Date: Apr 2007
Posts: 3
Default Ignoring EDID on one TwinView display but not the other

Further investigation reveals that I was actually overdriving the CRT slightly, and the nvidia driver was rejecting the custom modeline for this reason (because the PixelClock was exceeded).

The whistling happens at 75Hz. I can drive the monitor at 70Hz fine but then I can see the flicker.

'Option "UseEDID" "False" made the CRT work but hosed up the flat panel. It seems what I need to do is ignore EDID on the CRT but not the flat panel. Can this be done?

xorg.conf which was closest to working is attached.

For now I'm back to plain Xinerama with the CRT hanging off the ATI card, which is OK, but it's an old card so 3D and videos don't work on that screen (and in fact running 3D apps there causes a hard lockup).

Thanks,

Reid
Attached Files
File Type: txt xorg.conf.txt (3.0 KB, 89 views)
r27182818 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 12:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.