Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-07, 07:47 PM   #1
obra
Registered User
 
Join Date: Aug 2006
Posts: 66
Default issues with xorg-server 1.3.0.0

i've been running separate x-screens for tvout for about a year now and when my tv died a few weeks ago i was left without it. Anyway, during this time i upgraded to xorg-server 1.3 and everything went on just fine. Today, however i bought a new tv and noticed that video on the tv (xv) running in fullscreen was strange. Turns out that xv somehow gets centered all wrong. the top of the screen is left unrendered and lots renders outside the screen. If i use the same res on both screen, xv centers just fine.

Im not sure this is a bug specific for nvidia or if its a xorg bug but perhaps someone can shed some light on this.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (23.2 KB, 82 views)
obra is offline   Reply With Quote
Old 04-26-07, 11:47 AM   #2
Nias
Registered User
 
Join Date: Aug 2004
Posts: 24
Default Re: issues with xorg-server 1.3.0.0

exactly the same here.

i've found out that the display-geometry for the second screen is taken from first screen. Hence the movie was scaled to a larger size and you see only the upper left corner on your second screen. Same applies to desktop apps which want to center their window (popup windows or similair) they will be displayed centered to wrong geometry data.

i've written a simple test program (with qt3) which confirms this bad behaviour. I've attached it.

Called with:
# DISPLAY=:0.0 ./vidtest
Total desktop dim: 1400x1050, with 1 screen[s].
Using screen 0, 1400x1050 at 0,0

# DISPLAY=:0.1 ./vidtest
Total desktop dim: 1024x768, with 1 screen[s].
Using screen 0, 1400x1050 at 0,0

Compiled with: g++ -o vidtest vidtest.cpp -lqt-mt

But i don't know what was the reason for this problem. It's really ugly. Some programs i can override with -geometry switch but not all. Looks like some xinerama stuff was applied also in dual-head setups?
Attached Files
File Type: gz vidtest.cpp.tar.gz (503 Bytes, 80 views)
Nias is offline   Reply With Quote
Old 04-26-07, 01:44 PM   #3
Nias
Registered User
 
Join Date: Aug 2004
Posts: 24
Default Re: issues with xorg-server 1.3.0.0

looks like a bug in xserver-xorg-core modules.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=420679
https://bugs.freedesktop.org/show_bug.cgi?id=10771
Nias is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with 173.14.35 and xorg 1.12 joedoe NVIDIA Linux 4 07-09-12 03:11 PM
Fujitsu Marries GPUs and Xeon in High-Density HPC Server News Archived News Items 0 06-13-12 07:30 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 04:42 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 10:11 AM

All times are GMT -5. The time now is 06:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.