Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-27-07, 07:40 PM   #1
paulmer2003
Registered User
 
Join Date: May 2004
Posts: 15
Default nVidia driver won't work

Odd error in dmesg after loading nvidia, can't start X with driver set to nvidia, can't cat /dev/nvidia0. Read down for all the details.

[root@Illicit] (524.431 MB) [/home/paulmer2003] # rmmod nvidia
[root@Illicit] (524.431 MB) [/home/paulmer2003] # lsmod
Module Size Used by
i2c_viapro 8180 0
i2c_core 20368 1 i2c_viapro
[root@Illicit] (524.431 MB) [/home/paulmer2003] # modprobe -v nvidia
insmod /lib/modules/2.6.20.7/video/nvidia.ko
[root@Illicit] (524.431 MB) [/home/paulmer2003] # dmesg | tail
sd 0:0:0:0: Attached scsi removable disk sda
sd 0:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
NTFS volume version 3.1.
NTFS-fs error (device hda1): load_system_files(): Volume is dirty. Mounting read-only. Run chkdsk and mount in Windows.
eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
eth0: no IPv6 routers present
NVRM: isr request failed 0xffffffda
NVRM: isr request failed 0xffffffda
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007

It seems the "NVRM: isr request failed 0xffffffda" error occurs after I start X with the nvidia driver and it fails.

Now, seems its loaded fine...lets fire up X with the driver set to nvidia:
(==) Using config file: "/etc/X11/xorg.conf"
NVIDIA: could not open the device file /dev/nvidia0 (Input/output
error).
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Screen(s) found, but none have a usable configuration.

I also cant cat /dev/nvidia0, heres the error:
cat: /dev/nvidia0: Input/output error

Using x86 ACCEPT_PROFILE. ~x86'ed x/udev/nvidia-drivers. gcc version 4.1.1 (Gentoo 4.1.1-r3).
Linux Illicit 2.6.20.7 #1 Wed Apr 25 16:30:34 PDT 2007 i686 AMD Athlon(tm) XP 2400+ AuthenticAMD GNU/Linux

[paulmer2003@Illicit] (524.432 MB) [~] # lspci | grep -i nv
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

Can someone help me please, ive been stuck in crappy resolutions and such for over two weeks now, need my nvidia driver...

At first I started with x86 udev/nvidia drivers. when it didn't work I tried ~x86'ing them. I first started with ~x86'ed gentoo-sources, and when that didn't work I tried the vanilla ones.
paulmer2003 is offline   Reply With Quote
Old 04-27-07, 08:36 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nVidia driver won't work

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 08:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.