Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-07-07, 12:12 PM   #1
akimalahey
GTX 470 SOC @ Gentoo
 
akimalahey's Avatar
 
Join Date: Jun 2007
Location: Germany
Posts: 17
Default 7950gx2: freezes when multigpu is enabled

hi

with just one gpu my system is running perfect but if i enable multigpu in xorg.conf the system crashes after short time. most time it happens when 3D applications are started like glxgears or beryl.

to ensure that my gentoo isn't the problem i started an ubuntu live system from cd and installed the nvidia driver. same problem here. i tried 9631 and 9755.

kernel parameter pci=nommconf and idle=poll were no solution.


my system:
athlon 64 4400+
asus a8n-e with nforce 4 ultra
Leadtek WinFast PX7950 GX2 TDH
Gentoo x86_64


any ideas?


http://home.arcor.de/akimalahey/nvidia-bug-report.log
akimalahey is offline   Reply With Quote
Old 06-07-07, 12:17 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7950gx2: freezes when multigpu is enabled

Does this problem persist with the 100.14.06 beta driver?
Have you verified that you're using the latest motherboard BIOS?
netllama is offline   Reply With Quote
Old 06-07-07, 12:58 PM   #3
akimalahey
GTX 470 SOC @ Gentoo
 
akimalahey's Avatar
 
Join Date: Jun 2007
Location: Germany
Posts: 17
Default Re: 7950gx2: freezes when multigpu is enabled

hi

the latest bios is installed.

with 100.14.06 i often get a black screen when loggin in kde (beryl is starting).
multigpu isn't working so there are no freezes.
akimalahey is offline   Reply With Quote
Old 06-07-07, 05:28 PM   #4
akimalahey
GTX 470 SOC @ Gentoo
 
akimalahey's Avatar
 
Join Date: Jun 2007
Location: Germany
Posts: 17
Default Re: 7950gx2: freezes when multigpu is enabled

hi


In rare cases multigpu worked with 100.14.06 but beryl had graphic errors and effects were blinking. Same with Quake.

Now i am back at 9755. Sometimes it freezes while loggin in, sometimes i can play Quake using both gpus. Beryl is blinking again and glxgears most time starts as black window.

I found messages like that in Xorg.0.log and kdm.log

Quote:
(WW) NVIDIA: No matching Device section for instance (BusID PCI:3:0:0) found
(II) Module already built-in
(EE) NVIDIA(0): The NVIDIA graphics device PCI:4:0:0 bound to this Multi-GPU X
(EE) NVIDIA(0): screen is not the Multi-GPU parent device. This
(EE) NVIDIA(0): configuration is not currently supported. Please add
(EE) NVIDIA(0): 'BusID "PCI:3:0:0"' to the Multi-GPU "Device" section in
(EE) NVIDIA(0): the X configuration file.
(EE) NVIDIA(0): Only one GPU will be used for this X screen.

Quote:
(II) Primary Device is: PCI 04:00:0
(WW) NVIDIA: No matching Device section for instance (BusID PCI:3:0:0) found
(--) Assigning device section with no busID to primary device

my xorg-device part:

Quote:
Section "Device"

Identifier "nvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7950 GX2"
Option "NoLogo" "true"
Option "MultiGPU" "Auto"
Option "RenderAccel" "true"
Option "Coolbits" "1"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "True"

EndSection
Something horrible wrong? How should the config look like for a 7950gx2?

After adding BusID "PCI:3:0:0" X doesn't start anymore. Without a BusID and MultiGPU entry the system runs normal.

Do i need one Device entry for every card or just one with MultiGPU option? I don't want to configure an x-server on every gpu.
akimalahey is offline   Reply With Quote
Old 06-07-07, 05:32 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7950gx2: freezes when multigpu is enabled

You need a Device section for each GPU that has a display device attached to it.
netllama is offline   Reply With Quote
Old 06-07-07, 06:20 PM   #6
akimalahey
GTX 470 SOC @ Gentoo
 
akimalahey's Avatar
 
Join Date: Jun 2007
Location: Germany
Posts: 17
Default Re: 7950gx2: freezes when multigpu is enabled

I have one display and nvidia-settings showed both GPUs for X Screen 0. I think the config is ok but it isn't stable.

Framerates in Quake with 8s AA and 16 AF were as good or even better as in Windows.
akimalahey is offline   Reply With Quote
Old 06-08-07, 09:18 PM   #7
akimalahey
GTX 470 SOC @ Gentoo
 
akimalahey's Avatar
 
Join Date: Jun 2007
Location: Germany
Posts: 17
Default Re: 7950gx2: freezes when multigpu is enabled

Hi

No freezes with 100.14.09 and MultiGPU is working

There are only problems when Beryl is started. Some effects like cube rotation are showing graphic errors (is blinking). Most of the blinking stuff stops after short time but Quake keeps blinking and seems to use only one GPU while Beryl is running. At least FPS is low.


i am wondering about this:

eselect opengl list
Available OpenGL implementations:
[1] xorg-x11 *

Shouldn't there be something with nvidia?
akimalahey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 08:23 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.