Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-19-07, 01:29 PM   #1
m-singh
Registered User
 
Join Date: May 2007
Posts: 40
Default Reboot kills new driver install

The system is a Debian Lenny system and due to the fact that attempts to initiate a hibernate to disk (the system never powers off after the screen goes blank) fail with driver version 8766, I am trying to upgrade.

The hardware is a PCI-E card (7400 GeForce Go).

The package (./NVIDIA-Linux-x86-100.14.03-pkg1.run) installs correctly against kernel 2.6.21. nvidia module is loaded. There are no errors in Xorg.log.0 (attached). The X display does not start. An attempt to get some more info with startx -- -verbose 5 -logverbose 5, yields only the following :

...
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"^M
after 0 requests (0 known processed) with 0 events remaining.^M

The way I installed the driver was :

1. Switched to a tty, logged in as root (btw. I cannot switch unless I am logged into on the graphical session with nvidia drivers).
2. Stopped kdm. Unloaded nvidia driver.
3. apt-get removed all the nvidia related packages, including the kernel module package.
4. Ran ./NVIDIA-Linux-x86-100.14.03-pkg1.run.
5. It compiled and installed correctly.
6. Without rebooting, I started kdm again. (/etc/init.d/kdm start).
7. This works. I then ran nvidia bug-report shell script. This is the file *-before attached to this post.
8. Then I rebooted. During the bootup, it spent quite some time removing NVIDIA TLS links (whatever they are).
9. Now, kdm won't fire up the login screen. When I pressed any key (ctrl+alt, even before I press f1), it takes me to the text mode tty login. I now ran another nvidia bug-report shell script. This is the file *-after attached to this post.
10. The result is that I have no errors in the Xorg.log file. Only a 104 error described earlier with startx.

What is going on ?
Attached Files
File Type: log Xorg.0.log (22.6 KB, 79 views)
File Type: bz2 nvidia-bug-report.log.before.bz2 (32.2 KB, 83 views)
File Type: bz2 nvidia-bug-report.log.after.bz2 (30.3 KB, 79 views)
m-singh is offline   Reply With Quote
Old 05-19-07, 05:22 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Reboot kills new driver install

Please see http://nvnews.net/vbulletin/showthread.php?t=72490, specifically the part about removing the Debian packages with the --purge option.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
How to install my nvdia driver... danyal_r NVIDIA Linux 2 10-11-02 12:06 PM
Getting bizarre errors with driver install clutch NVIDIA Linux 1 09-14-02 09:53 PM
NVIDIA driver doesn't install successfully on RH 7.3 Sunni NVIDIA Linux 3 08-28-02 02:30 PM

All times are GMT -5. The time now is 05:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.