Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-24-03, 03:23 PM   #1
blakieto
Registered User
 
blakieto's Avatar
 
Join Date: Mar 2003
Location: Los Angeles
Posts: 2
Default RH8 + Nvidia was working until kernel patch...

New to having a personal linux station, (used them at various jobs,) I started with installing Red Hat 8 from CD, let 'up2date' bring the workstation up to the latest patch/fix level and then followed the instructions here in this forum to install an Nvidia driver (it has an old GeForce2 GTS...) I downloaded the NVchooser script, ran it, downloaded the indicated Nvidia kernel src rpm and the Nvidia GLX rpm... and so on. The src rpm compiled fine and everything installed fine. After about an hour of mucking about I had working Nvidia drivers and pleasingly accelerated OpenGL rendering.

But after a few days I received a noticed from the Red Hat Network, saying that I needed to install a new kernel patch for some security issue. Running up2date again seemed to work fine, but after rebooting, the X server failed to start. The file /var/log/XFree86.0.log states that it failed to initialize the Nvidia kernel module, with the fatal error being "no screens found"...

After following several web descriptions of how to fix this issue I still am unable to get the Nvidia driver to work with the latest version of the kernel. I've been attempting to fix this for about a week, 2-4 hours a day. (Most of that time being tracking down "solutions" that I have not tried yet.)

So, I ask: When a new kernel is released, do I need to wait until Nvidia releases a kernel that matches? Has anyone successfully achieved a working Nvidia driver with Red Hat 8, kernel version 2.4.18-27.8.0 or above???

Note that I can simply work with the previous kernel (2.4.18-26.8.0) but that is before the last security fix...

Any suggestions would be great.
blakieto is offline   Reply With Quote
Old 03-24-03, 04:21 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

No, you don't have to wait. You need to rebuild the kernel module against your running kernel. This means that you'll also need to grab an updated kernel-source package from up2date. Please make sure you've got kernel-source-2.4.18-27.i386.rpm installed, and rebuild the driver with the SRPM as you did before.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 03-24-03, 08:43 PM   #3
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

I run RH8.0 too. And to solve this kernel update problem I wrote a script to do all the recompiling for me. Checkout my reply to this post. As it has all the details.

http://www.nvnews.net/vbulletin/show...&threadid=8909

And like Andy said, make sure that you also update the kernel source, and not to mention BOOT into the NEW kernel before running the script. As it needs to recompile the drivers on the RUNNING kernel.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 03-25-03, 03:46 PM   #4
blakieto
Registered User
 
blakieto's Avatar
 
Join Date: Mar 2003
Location: Los Angeles
Posts: 2
Default

Everything works now.

Wolfman, you are my hero!

Thank you very much.
blakieto is offline   Reply With Quote
Old 06-26-03, 09:53 PM   #5
TaBaTaN
Registered User
 
Join Date: Jun 2003
Posts: 1
Default

I have nforce2 with nvidia lan, and is not working , it use to work, but when i make a kernel upgrade stop working.
Im a newbie , can you tell me what i need to do?


Thanks.

Sorry for my english
TaBaTaN is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 09:30 PM
NVIDIA kernel not loading on boot-up, but insmod loads it Kyle NVIDIA Linux 3 09-10-02 01:01 AM

All times are GMT -5. The time now is 01:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.