Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-08-07, 07:16 AM   #1
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:08 PM.
humphrey9 is offline   Reply With Quote
Old 05-08-07, 12:59 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: XvMC: Xorg 7.3 (slackware current) nvidia newest, xine no working XvMC

Please see http://www.nvnews.net/vbulletin/showthread.php?t=46678
AaronP is offline   Reply With Quote
Old 05-08-07, 03:33 PM   #3
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:09 PM.
humphrey9 is offline   Reply With Quote
Old 05-08-07, 03:36 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMC: Xorg 7.3 (slackware current) nvidia newest, xine no working XvMC

XVMC appears to be working in the mplayer output. Please generate and attach an nvidia-bug-report.log. Also please provide or point me to where I can obtain the movie content required to reproduce this problem.
netllama is offline   Reply With Quote
Old 05-08-07, 03:41 PM   #5
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:09 PM.
humphrey9 is offline   Reply With Quote
Old 05-08-07, 03:48 PM   #6
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:11 PM.
humphrey9 is offline   Reply With Quote
Old 05-08-07, 03:55 PM   #7
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:10 PM.
humphrey9 is offline   Reply With Quote
Old 05-08-07, 03:55 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMC: Xorg 7.3 (slackware current) nvidia newest, xine no working XvMC

How did you determine that this issue is tied to Xorg-7.3?

Please attach the nvidia-bug-report.log here, and provide the URL for movie content which reproduces the MPlayer problem.
netllama is offline   Reply With Quote

Old 05-08-07, 04:06 PM   #9
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:13 PM.
humphrey9 is offline   Reply With Quote
Old 05-09-07, 05:01 AM   #10
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:12 PM.
humphrey9 is offline   Reply With Quote
Old 05-17-07, 09:50 AM   #11
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: XvMC: Xorg 7.3 (slackware current) nvidia newest, xine no working XvMC

Someone resolved xine and xorg 1.3.0 incompatibility? I have just run into xine crash/hang problem with both xvmc/xxmc output. Xv is OK. Mplayer in xvmc output is OK.
Nvidia 100.14.03. Kernel 2.6.21.1 xine-lib 1.1.6

xine -V xxmc --verbose=5 dvd://
video_out_xxmc: XvMC extension present.
video_out_xxmc: Found 2 XvMC surface types
video_out_xxmc: Surface type 0: Max size: 2032 2032.
video_out_xxmc: Surface type 0: Max subpic size: 2046 2046.
video_out_xxmc: Surface type 0: Found 2 XvMC subpicture types
video_out_xxmc: Surface type 0: Detected and using IA44 subpicture type.
video_out_xxmc: Surface type 1: Max size: 2032 2032.
video_out_xxmc: Surface type 1: Max subpic size: 2046 2046.
video_out_xxmc: Surface type 1: Found 2 XvMC subpicture types
video_out_xxmc: Surface type 1: Detected and using IA44 subpicture type.
video_out_xxmc: this adaptor supports the yuy2 format.
video_out_xxmc: this adaptor supports the yv12 format.
video_out_xxmc: Unichrome CPU saving is on.
Allocating frame
Allocating frame
Allocating frame
Allocating frame
Allocating frame
Allocating frame
Allocating frame
Allocating frame
video_out: thread created
video_out_xxmc: VO_PROP_ASPECT_RATIO(0)
video discontinuity #2, type is 2, disc_off 30304
waiting for audio discontinuity #2
audio discontinuity #2, type is 2, disc_off 30304
waiting for in_discontinuity update #2
video_out_xxmc: VO_PROP_INTERLACED(1)
video_out_xxmc: New format. Need to change XvMC Context.
width: 720 height: 576 mpeg: 2 acceleration: 7
video_out_xxmc: Surface type 0. Capabilities 0x 2 0x 2
video_out_xxmc: Requests: 0x 2 0x 4
video_out_xxmc: Surface type 1. Capabilities 0x 2 0x 1
video_out_xxmc: Requests: 0x 2 0x 4
video_out_xxmc: Surface type 0. Capabilities 0x 2 0x 2
video_out_xxmc: Requests: 0x 2 0x 2
video_out_xxmc: Creating new XvMC Context 1413694537
0 0;0 0;0 0;0 0;
video_out_xxmc: Created subpicture 0
video_out_xxmc: Disposing of subpicture 0
0 1;0 0;0 0;0 0;
video_out_xxmc: Using hardware decoding for this stream.
0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;
video_out_xxmc: Created surface 0
1 1;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;
audio_decoder: error, unknown buffer type: 02000000
audio_decoder: error, unknown buffer type: 04000000
audio_decoder: error, unknown buffer type: 01060000
audio_decoder: suggested switching to stream_id 00
audio discontinuity #3, type is 2, disc_off 25854
waiting for in_discontinuity update #3
(hang up/crash)

xine -V xvmc --verbose=5 dvd://
video_out_xvmc: checking adaptor 0
video_out_xvmc: IDCTaccel 03
video_out_xvmc: using Xv port 275 from adaptor NV17 Video Texture
for hardware colorspace conversion and scaling
idct and motion compensation acceleration
With Overlay = 0; UnsignedIntra = 0.
video_out: thread created
xine_stream_new
video_out: thread created
video discontinuity #2, type is 2, disc_off 30304
waiting for audio discontinuity #2
audio discontinuity #2, type is 2, disc_off 30304
waiting for in_discontinuity update #2
video discontinuity #3, type is 2, disc_off 25854
waiting for audio discontinuity #3
audio_decoder: error, unknown buffer type: 02000000
audio_decoder: error, unknown buffer type: 04000000
audio_decoder: error, unknown buffer type: 01060000
audio_decoder: suggested switching to stream_id 00
audio discontinuity #3, type is 2, disc_off 25854
waiting for in_discontinuity update #3
vpts adjusted with prebuffer to 700271
load_plugins: plugin a/52 will be used for audio streamtype 00.
audio_alsa_outpen pause_resume=1
output sample rate 48000
audio jump, diff=0
(hang up/crash)
zbiggy is offline   Reply With Quote
Old 06-11-07, 10:24 AM   #12
humphrey9
Registered User
 
Join Date: Dec 2005
Posts: 13
Default .

.

Last edited by humphrey9; 06-25-10 at 12:14 PM.
humphrey9 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Working RedHat 7.3 with Nvidia?? Be'Lal NVIDIA Linux 3 08-03-02 05:16 PM

All times are GMT -5. The time now is 09:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.