Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-07, 04:26 AM   #1
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default enable/disable turbocache via xorg.conf / kernel module argument

hello,

is there a way to disable (since it's enabled by default) the turbocache feature of cards like go7400?

I think that's an interesting feature, esp. for debugging. if this option is non-existent as of now, I'd like to see it in an future driver.

thanks.
lloeki is offline   Reply With Quote
Old 05-09-07, 10:28 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: enable/disable turbocache via xorg.conf / kernel module argument

No, Turbocache is a feature of the GPU you've purchased. If you do not want Turbocache, you'll need to purchase cards which do not have Turbocache functionality.
netllama is offline   Reply With Quote
Old 05-09-07, 11:35 AM   #3
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: enable/disable turbocache via xorg.conf / kernel module argument

I fail to understand something: back before the 9xxx line, driver did not have turbocache support, thus vram was reported to be 64M for my card, yet you seem to say that turbocache is a non-controllable, hardwired feature. well, I must have gotten something wrong.

anyway, thanks for the answer.
lloeki is offline   Reply With Quote
Old 05-09-07, 11:47 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: enable/disable turbocache via xorg.conf / kernel module argument

I'm not sure what you're referring to. Turbocache was always supported in the driver.
netllama is offline   Reply With Quote
Old 07-03-08, 08:28 PM   #5
Pwm
Registered User
 
Join Date: Jul 2008
Posts: 1
Default Re: enable/disable turbocache via xorg.conf / kernel module argument

In the Driver "nvidia" section of xorg.conf:

Option "RegistryDwords" "RMDisableRenderToSysmem=1"


With driver 173.14.09, this causes nvidia-settings to report the memory size as the graphics card ram size only. Looks like it's disabled turbocache.
Pwm is offline   Reply With Quote
Old 07-05-08, 05:21 PM   #6
Sasha_A
Slackware!
 
Join Date: Apr 2008
Location: Nova Scotia
Posts: 18
Default Re: enable/disable turbocache via xorg.conf / kernel module argument

Quote:
Originally Posted by Pwm View Post
In the Driver "nvidia" section of xorg.conf:

Option "RegistryDwords" "RMDisableRenderToSysmem=1"


With driver 173.14.09, this causes nvidia-settings to report the memory size as the graphics card ram size only. Looks like it's disabled turbocache.
Hey that is interesting!

To the OP: Did it work?

To Pwm: Where did you come across that option? I wonder how many other interesting options there are that are scarcely documented (or not at all..)?

S
Sasha_A is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 05:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.