Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-17-07, 08:16 AM   #1
Tunix
Registered User
 
Join Date: May 2007
Posts: 13
Default Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Beginning with kernel 2.6.20 I'm getting graphical glitches on a Dell Latitude D620 which comes with aforementioned Quadro card. Sometimes textures get filled up with lots of small randomly colored rectangles. Especially big textures cause those rendering glitches to appear very quickly (i.e. the flipscreen3d screen saver).

At first I thought that I might have got defective hardware but I could not reproduce this bug with kernels <= 2.6.19, no matter how hard I tried. Also Windows 2000 does not seem to suffer from this bug. I've run various 3D benchmarks to provoke potential overheating but there was no problem. Eight hours of memtest86 (23 passes) did not reveal any errors, either. Also there is at least one other guy who has the same problem (apologies for the cross posting but I think it's better to discuss this problem here at nV News).

I'm using Ubuntu 7.04 with kernel 2.6.20-15-generic and the nvidia-glx-new package (97.55). I could also reproduce this bug both with a vanilla 2.6.20.11 and a vanilla 2.6.21.1 kernel. The new beta driver 100.14.03 does not mitigate problem.

My hardware is a Dell Latitude D620 notebook with the following configuration: Core 2 Duo T7200, 1 GB RAM, Quadro NVS 110M (64 MB dedicated video RAM + 192 MB "TurboCache"), WXGA+ Screen (1440x900)

Steps to reproduce the bug:
  • get an Ubuntu Desktop 7.04 Live CD and boot from it
  • as soon as Gnome has been started open a terminal (Applications/Accessories/Terminal)
  • make sure you have a working internet connection
  • type sudo apt-get install nvidia-glx && sudo nvidia-glx-config enable
  • type sudo depmod -a
  • hit Ctrl-Alt-Backspace to force the x-server to restart (so that the commercial driver is used)
  • either wait 10 seconds or just hit enter if GDM presents you a login screen
  • again, open a terminal and type /usr/lib/xscreensaver/flipscreen3d
Attached Thumbnails
Click image for larger version

Name:	texture_corruption.jpg
Views:	328
Size:	45.7 KB
ID:	25690  
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.4 KB, 199 views)
Tunix is offline   Reply With Quote
Old 05-17-07, 11:44 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Does this problem persist without the Composite extension in X?
Have you verified that you're using the latest BIOS?

thanks,
Lonni
netllama is offline   Reply With Quote
Old 05-17-07, 02:23 PM   #3
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

So, the new high resolution timers aren't to blame?
logan is offline   Reply With Quote
Old 05-17-07, 03:19 PM   #4
Tunix
Registered User
 
Join Date: May 2007
Posts: 13
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

@netllama:
Unfortunately, disabling the composite extension has no effect on this bug.
I'm using the latest BIOS available from Dell (version "A08" from April 11th, 2007).

@logan:
AFAIK those timers weren't added before 2.6.21. Anyway, is there a possibility to check this?
Tunix is offline   Reply With Quote
Old 05-17-07, 03:33 PM   #5
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Nevermind, I don't see CONFIG_HIGH_RES_TIMERS in .20. I remembered another post that mentioned this. I thought I looked at .20, but I must have been confused.
logan is offline   Reply With Quote
Old 05-19-07, 03:47 AM   #6
Tunix
Registered User
 
Join Date: May 2007
Posts: 13
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Looking through the forums, I stumbled across following threads which describe very similar problems:
http://www.nvnews.net/vbulletin/showthread.php?t=88482
http://www.nvnews.net/vbulletin/showthread.php?t=87058

Like me, the user lloeki has been getting this error since kernel 2.6.20 whereas previous versions did not trigger the bug. According to these threads, following cards seem to be affected:
  • Geforce 6200 Go
  • Geforce 7400 Go
  • Quadro NVS 110M
These cards have something in common: They all have TurboCache in their feature list. Maybe something interferes with the mechanism that maps texture data into system RAM? Is it possible to disable that TurboCache thing for testing purposes?

I've uploaded a video of the Flipscreen3D screensaver which triggers the bug really fast so that you can get a picture of it:
http://www.youtube.com/watch?v=3db9-U_7HL0
Tunix is offline   Reply With Quote
Old 05-19-07, 08:03 AM   #7
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

it seems turbocache cannot be disabled:
http://www.nvnews.net/vbulletin/show...ble+turbocache
http://www.nvnews.net/vbulletin/show...ble+turbocache

it should really be time that nvidia start looking seriously into this issue.

I did some test casing as described in all the other threads and it all comes down to 2.6.19 => 2.6.20.

I'd have gladly do regression testing, and test each 2.6.20-rc* but I can't find them, or even each git commit to trace the culprit commit but I don't know how to do that. and I don't feel like I have to do nvidia's work...

IIRC there have been some pci and memory management changes in 2.6.20, and I think that's the cause, but who knows.
http://kernelnewbies.org/Linux_2_6_20 (see eg under various core changes)
lloeki is offline   Reply With Quote
Old 05-19-07, 10:31 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Is anyone seeing this problem with a distribution other than Ubuntu?
netllama is offline   Reply With Quote

Old 05-19-07, 01:15 PM   #9
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

yes, arch, and gentoo
lloeki is offline   Reply With Quote
Old 05-19-07, 01:21 PM   #10
Tunix
Registered User
 
Join Date: May 2007
Posts: 13
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

Quote:
Originally Posted by netllama
Is anyone seeing this problem with a distribution other than Ubuntu?
Yes, I could reproduce this bug on a Fedora Core 7 Live CD (6.93 Beta) with driver 100.14.03 (in case you wonder: I have installed a small build environment on the live file system to make this possible). Again, I have attached a bug-report and the obligatory flipscreen3d screenshot.
Attached Thumbnails
Click image for larger version

Name:	flipscreen3d.jpg
Views:	201
Size:	57.1 KB
ID:	25778  
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.9 KB, 153 views)
Tunix is offline   Reply With Quote
Old 05-19-07, 01:53 PM   #11
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

2.6.20-rc's are at http://ftp.kernel.org/pub/linux/kernel/v2.6/testing/
logan is offline   Reply With Quote
Old 05-19-07, 03:59 PM   #12
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Texture corruption on Quadro NVS 110M (beginning with kernel 2.6.20)

thanks logan, this will be useful to me.

in the meantime, I was trying to get the hang of git and kernel, thanks to this page: http://www.fieldses.org/~bfields/kernel/git.html

I'll give up on git for now and use ftp snapshots for now. I hope to tighten the search field at least between two rc...
lloeki is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 09:22 PM

All times are GMT -5. The time now is 08:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.