Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-18-07, 09:48 AM   #1
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Disabling power saving features

Is it possible to disable/modify the power savings functionality of the Go series cards (7900GS Go in my case) so that they don't underclock when the GPU is relatively idle? I'm sure it's very useful for power savings to have GPUCurrentClockFreqs scale down to 100,100 but, it's very bad for composited desktops because it often takes some time for the card to realize that it needs to step back up to maximum speed. Because of this there is frequently a "warmup" period where everything is updating at like 5 frames per second when using things like compiz scale/switcher/cube (specifically when dealing with large windows) until the card wakes up and goes to full speed.

I've looked around for a way to disable this functionality but, I didn't notice anything. Having a writable "GPUMinimumClockFreqs" or something of that nature would be ideal because it would allow people to use laptop_mode to control the power savings features. As it currently stands, it's painful to use a composited desktops because the card is generally in low power mode and so any sort of large screen update is exceedingly slow.
shaundennie is offline   Reply With Quote
Old 04-18-07, 01:01 PM   #2
stefan42
Registered User
 
Join Date: Jul 2003
Posts: 51
Default Re: Disabling power saving features

I once asked NVIDIA because in my case the screen flickers when the clock frequency changes (also a 7900 Go GS), and Lonni Friedman from NVIDIA told me "No, that isn't possible via any direct means. You could try using Coolbits to downclock the GPU though."

Anyway what worked is adding "options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222" to /etc/modprobe.d/options. My GPU will not downclock then. But it's completely unclear what other effect this setting has or what it's meant to solve ;-) so be warned. In my case the screen is garbled after a X restart.
stefan42 is offline   Reply With Quote
Old 04-19-07, 08:44 AM   #3
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: Disabling power saving features

Quote:
Originally Posted by stefan42
Anyway what worked is adding "options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222" to /etc/modprobe.d/options. My GPU will not downclock then. But it's completely unclear what other effect this setting has or what it's meant to solve ;-) so be warned. In my case the screen is garbled after a X restart.
I'm giving this a shot now. After a lot of reading it looks like this setting also helps with the random lockups that cause the Xserver to stop responding (to the point where Ctl-Alt-Backspace won't kill it). If that's the case, it may be worth dealing with the extra heat generated by not letting the card drop down to a power saving mode.
shaundennie is offline   Reply With Quote
Old 07-04-07, 11:06 AM   #4
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: Disabling power saving features

I've recently updated to 100.14.09 and it's extremely painful on laptops with a compositing window manager. It seems that now the GPU essentially refuses to clock up to full speed when doing intensive compositing things (scale/rotate/switcher). Even doing something like rotating the cube with the keyboard continuously for 15 seconds doesn't cause the GPU to speed up. In fact, the only way I can reliably cause the GPU to speed up is to do an "nvidia-settings -q all" in a terminal. It does appear that it scales the GPU down at a slower pace after it's been forced to full speed but, I never timed it before so it could be my imagination.

Is there any way to fix this? My laptop with an i915 GPU now has a much smoother compiz experience than my 7900GS.
shaundennie is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
After Greenpeace Protests, Apple Promises to Dump Coal Power News Archived News Items 0 05-18-12 03:10 AM
ASUS GeForce GTX 670 DirectCU II Top Unveiled Features 1137MHz Boost Clock (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 06:30 AM
Disabling ACPI improves performance? VoltFox General Hardware 5 08-23-02 04:08 PM
Power Management (XP) Iron1384 Microsoft Windows XP And Vista 6 08-22-02 01:29 PM

All times are GMT -5. The time now is 01:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.