Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-30-07, 01:39 AM   #1
beap
Registered User
 
Join Date: May 2007
Posts: 3
Default Unable to build the NVIDIA kernel module. kernel 2.6.21.1-686

Quote:
Building modules, stage 2.
make -f /usr/src/linux-headers-2.6.21-1-686/scripts/Makefile.modpost
scripts/mod/modpost -m -i /usr/src/linux-headers-2.6.21-1-686/Module.symv
ers -I /tmp/selfgz16336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/Module.sym
vers -o /tmp/selfgz16336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/Module.sy
mvers -w /tmp/selfgz16336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nvidia.
o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'para
virt_ops'
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
Linux myPF5 2.6.21-1-686 , GeForce 6600 Debian Lenny/Sid
beap is offline   Reply With Quote
Old 05-30-07, 02:11 AM   #2
beap
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: Unable to build the NVIDIA kernel module. kernel 2.6.21.1-686

this thread is unecessary.

try to view here http://www.nvnews.net/vbulletin/show...85#post1271285
might save yur day
beap is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM

All times are GMT -5. The time now is 10:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.