Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-03-07, 08:30 PM   #1
securehell
Registered User
 
Join Date: Jun 2007
Posts: 6
Default nvidia-xconfig fails to generate working xorg.conf

Hi Forum,

Today I built a new 2.6.21.3 kernel and compiled and installed the latest 1.0.9639 nvidia driver. Part of the build script was to generate a new xorg.conf file but when I startx after using the script the screen goes blank/black/nothing.

My /var/log/Xorg.0.log file lists no messages nor does /var/log/messages.

This is on a Dell Inspiron 8200 with an nVidia GeForce4 440 Go video card.

I presume some change(s) must be made to the loaded modules (other than nvidia itself) and/or the HorizSync or VertRefresh.

Where can I look for resources on configuring my xorg.conf for my system since it appears I cannot use the script that comes with the driver?

Thanks.
securehell is offline   Reply With Quote
Old 06-03-07, 08:46 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nvidia-xconfig fails to generate working xorg.conf

Its not clear from your post how you determined that nvidia-xconfig fails to generate working xorg.conf. Just because X isn't doing what you expect does not mean that there's anything wrong with xorg.conf.

See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 06-05-07, 08:24 PM   #3
securehell
Registered User
 
Join Date: Jun 2007
Posts: 6
Default Re: nvidia-xconfig fails to generate working xorg.conf

OK, perhaps I should ask then... If I build and insert the nvidia.ko driver and allow the nvidia-xconfig application to alter my xorg.conf file (which really only replaces the existing driver entry from "nv" to "nvidia") and subsequently starting the X server causes a black screen, what should I look for to troubleshoot the reason?

The nvidia.ko module is loaded. No messages in the Xorg.log file. No messages in /var/log/messages. Just no video.

Suggestions?
securehell is offline   Reply With Quote
Old 06-05-07, 08:32 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: nvidia-xconfig fails to generate working xorg.conf

You should read the sticky post netllama linked to, especially the parts about how to create a bug report.
AaronP is offline   Reply With Quote
Old 06-06-07, 06:18 AM   #5
Teehahcee
Registered User
 
Join Date: May 2007
Posts: 6
Default Re: nvidia-xconfig fails to generate working xorg.conf

try this (it worked for me) rename your original xorg.conf to xorg.conf.something then duplicate xorg.in and rename it to xorg.conf run the installer and let it edit your xorg.conf.... don't forget to pray
Teehahcee is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 302.17 OpenGL not working 6200 PCI Archmbc NVIDIA Linux 1 06-18-12 11:23 AM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Nvidia 3123 not working on Mandrake 8.2 UP with Geforce 440 MMX tariqf NVIDIA Linux 1 09-17-02 08:22 AM

All times are GMT -5. The time now is 05:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.