Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-07-07, 06:57 PM   #1
kmoore134
Kris Moore
 
Join Date: May 2006
Posts: 19
Default Error with GF 8600 & Xorg 7.2

Hi!

I'm working on the next release of PC-BSD at the moment, and we plan on including the nVidia drivers in the base system. That being said, I've run into a problem on one of my dev boxes.

Since this is an GeForce 8600 GT, I've loaded the latest beta driver, and at first glance it seems to work. However, after you run anything with glx, the screen seems to revert to some sort of software rendering, and any other glx applications refuse to run. The console also shows these errors:

NVRM: Xid (0007:00): 6, PE0003
NVRM: Xid (0007:00): 30, L1 -> L0
NVRM: Xid (0007:00): 6, PE0003
NVRM: Xid (0007:00): 30, L1 -> L0
NVRM: Xid (0007:00): 6, PE0003
NVRM: Xid (0007:00): 30, L1 -> L0
NVRM: Xid (0007:00): 6, PE0003
NVRM: Xid (0007:00): 30, L1 -> L0
NVRM: Xid (0007:00): 6, PE0003
NVRM: Xid (0007:00): 30, L1 -> L0

I've tried rolling custom kernels without AGP, changing settings, disabling compositing, etc, nothing seems to make a difference. Of course this prevents beryl from running, or any other 3d app. We had similar symptoms on a 7300LE card as well, both PCI Express.

Any ideas, or anybody else run into this?
Attached Files
File Type: log nvidia-bug-report.log (66.8 KB, 154 views)
kmoore134 is offline   Reply With Quote
Old 06-07-07, 08:13 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Error with GF 8600 & Xorg 7.2

Please see http://www.nvnews.net/vbulletin/showthread.php?t=92444.
zander is offline   Reply With Quote
Old 06-08-07, 11:55 AM   #3
kmoore134
Kris Moore
 
Join Date: May 2006
Posts: 19
Default Re: Error with GF 8600 & Xorg 7.2

Ahh, thank you, thats the exact problem I have here. Do you have a timetable on the new driver release? Are we talking weeks or months?
kmoore134 is offline   Reply With Quote
Old 06-08-07, 12:41 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Error with GF 8600 & Xorg 7.2

I can't give you a definitive answer to this question, but a fixed driver should be available within the next few weeks.
zander is offline   Reply With Quote
Old 06-08-07, 03:14 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Error with GF 8600 & Xorg 7.2

Please see: http://www.nvidia.com/object/freebsd_100.14.09.html.
zander is offline   Reply With Quote
Old 06-08-07, 07:15 PM   #6
bugmeplz
*BANNED*
 
bugmeplz's Avatar
 
Join Date: Sep 2006
Posts: 427
Default Re: Error with GF 8600 & Xorg 7.2

Quote:
Originally Posted by zander
GREAT!
But now when I start xorg my vesa ttys get messed.
This didn't happen with the last beta driver.

$ dmesg | grep -i nv
nvidia0: <GeForce 8500 GT> port 0xdc00-0xdc7f mem 0xfa000000-0xfaffffff,0xd0000000-0xdfffffff,0xf8000000-0xf9ffffff irq 24 at device 0.0 on pci2
bugmeplz is offline   Reply With Quote
Old 06-08-07, 10:26 PM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Error with GF 8600 & Xorg 7.2

Yes, it looks like this is a regression that snuck in between 100.14.06 and 100.14.09; it is understood and should be fixed in future NVIDIA FreeBSD graphics driver releases.
zander is offline   Reply With Quote
Old 06-09-07, 05:51 AM   #8
bugmeplz
*BANNED*
 
bugmeplz's Avatar
 
Join Date: Sep 2006
Posts: 427
Default Re: Error with GF 8600 & Xorg 7.2

I hope soon...

Thank you.


EDIT:
If I startx then stop it, on the next startx pc hangs totally (not even ssh connection possible).
Now I had to switch back to beta drivers.
bugmeplz is offline   Reply With Quote

Old 06-10-07, 07:46 PM   #9
kmoore134
Kris Moore
 
Join Date: May 2006
Posts: 19
Default Re: Error with GF 8600 & Xorg 7.2

Great work! Faster than I anticipated, and this problem appears to be fixed, Beryl runs great now
kmoore134 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with 173.14.35 and xorg 1.12 joedoe NVIDIA Linux 4 07-09-12 02:11 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Xorg crash and system freeze l_r_mcglashan NVIDIA Linux 0 05-17-12 04:01 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 03:42 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 10:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.