Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-09-07, 07:05 AM   #1
hemebond
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Ubuntu 2.6.20-16-generic 100.14.09 Installation error

For the record, I have never, ever been able to manually install Nvidia drivers on Ubuntu from the installer downloaded from the Nvidia website. Ever.

Everything was fine until a kernel update or something today, then the Nvidia drivers crapped themselves and I can't fix them because the install procedure never works for me. Obviously I'm doing something wrong, but every tutorial or walk-through I find fails the same way.

I am running Ubuntu Feisty Fawn 7.04 on kernel 2.6.20-16-generic. I've downloaded the latest Nvidia drivers 100.14.09 and tried my best to follow the installation instructions. After that failed I tried the Envy installer and that failed too. Everything looks fine until it tries to load the module. I've had general failures to load the module. Version conflicts or incompatibilities. And even one that just said the version is wrong.

I have attached my nvidia-bug-report.log which I created right after startx failed.
Attached Files
File Type: gz nvidia-bug-report.log.gz (24.0 KB, 107 views)
hemebond is offline   Reply With Quote
Old 06-09-07, 08:52 AM   #2
Mr.A
Registered User
 
Join Date: Sep 2006
Posts: 62
Default Re: Ubuntu 2.6.20-16-generic 100.14.09 Installation error

Quote:
Originally Posted by hemebond
For the record, I have never, ever been able to manually install Nvidia drivers on Ubuntu from the installer downloaded from the Nvidia website. Ever.

Everything was fine until a kernel update or something today, then the Nvidia drivers crapped themselves and I can't fix them because the install procedure never works for me. Obviously I'm doing something wrong, but every tutorial or walk-through I find fails the same way.

I am running Ubuntu Feisty Fawn 7.04 on kernel 2.6.20-16-generic. I've downloaded the latest Nvidia drivers 100.14.09 and tried my best to follow the installation instructions. After that failed I tried the Envy installer and that failed too. Everything looks fine until it tries to load the module. I've had general failures to load the module. Version conflicts or incompatibilities. And even one that just said the version is wrong.

I have attached my nvidia-bug-report.log which I created right after startx failed.
Have you tried to follow this installations steps ?

http://www.nvnews.net/vbulletin/showthread.php?t=72490

Don't forget to uninstall the nvidia-glx drivers be for you run the nvidia installer.

To install the development tools install the package "build-essential" (sudo apt-get install build-essential).
Mr.A is offline   Reply With Quote
Old 06-09-07, 12:59 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Ubuntu 2.6.20-16-generic 100.14.09 Installation error

[ 59.713036] NVRM: API mismatch: the client has the version 1.0-9631, but
[ 59.713040] NVRM: this kernel module has the version 1.0-9755. Please
[ 59.713043] NVRM: make sure that this kernel module and all NVIDIA driver
[ 59.713046] NVRM: components have the same version.
Please see http://www.nvnews.net/vbulletin/showthread.php?t=72490; unfortunately, it has become very difficult to keep track of what is broken where with respect to [K]Ubuntu, so the instructions may be incomplete. If in doubt, it is recommended that you bring the problem(s) up on a more Ubuntu centric forum.
zander is offline   Reply With Quote
Old 06-09-07, 04:36 PM   #4
hemebond
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: Ubuntu 2.6.20-16-generic 100.14.09 Installation error

Quote:
Originally Posted by Mr.A
Have you tried to follow this installations steps ?
http://www.nvnews.net/vbulletin/showthread.php?t=72490
Don't forget to uninstall the nvidia-glx drivers be for you run the nvidia installer.
To install the development tools install the package "build-essential" (sudo apt-get install build-essential).
Yes, I tried those steps. I may have gotten a different error after trying that (one that mentioned the 100.14.09 drivers), I can't remember. I tried Envy after that.
  • All dev tools are installed
  • I have the linux-headers installed according to Synaptic
  • I did have to install xserver-xorg-dev
  • I purged nvidia-glx
  • Trying to remove linux-restricted-modules or linux-restricted-modules-common resulted in Synaptic wanting to remove linux-generic which I thought was bad, so I added DISABLED_MODULES="nv" instead.

I will have another go at this tonight and post the errors right after that.
hemebond is offline   Reply With Quote
Old 06-10-07, 01:46 AM   #5
hemebond
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: Ubuntu 2.6.20-16-generic 100.14.09 Installation error

/me enters with his tail between his legs.

Okay, it worked. I did almost everything exactly the same way. I even got the same errors/warnings as last time.

I did 2 things differently this time: I added "nvidia_new" to the DISABLED_MODULES line; I restarted the entire machine rather than just starting X after the installation had finished.

Oh well. WOOHOO! 3D again! Sorry about wasting your time.
hemebond is offline   Reply With Quote
Old 06-10-07, 03:31 AM   #6
Mr.A
Registered User
 
Join Date: Sep 2006
Posts: 62
Smile Re: Ubuntu 2.6.20-16-generic 100.14.09 Installation error

Nice to hear everything works now.

So as you mentioned that you disabled the "nvidia_new" module, it seems to me that this is still installed. (nvidia-glx-new)

I write this because I haven't to disable any modules.

Just a quick note for the next time you install the drivers.

best wishes

Mr. A
Mr.A is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 07:47 PM
295.40 295 cannot be compiled on 3.2 kernel delta32 NVIDIA Linux 4 05-27-12 10:47 PM
RPM Source problems LaoTzuTao NVIDIA Linux 10 01-19-03 06:15 AM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 03:54 AM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 10:53 PM

All times are GMT -5. The time now is 12:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.