Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-09-06, 05:11 PM   #1
ScatterBot
Registered User
 
Join Date: Feb 2006
Posts: 11
Default Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Hard lockups seem to result when using an Nvidia 6200 with a motherboard based on the ATI RS480 chipset. This has been reported in several threads, including

http://www.nvnews.net/vbulletin/showthread.php?t=63318
http://www.nvnews.net/vbulletin/showthread.php?t=61651
and my own at
http://www.nvnews.net/vbulletin/showthread.php?t=64509

Is there anybody successfully using a 6200 based video card and an RS480 based motherboard?

Because it is a hard lockup, it is very difficult to get any debugging information. Even attaching a serial console, when the machine locks, there is no oops or other message. Additionally the computer doesn't work properly with noapic or acpi=off, so these are not available as workarounds.

So far I have tested kernels 2.6.14.7 through 2.6.16-rc2-mm1 with the 1.0-8178 Nvidia drivers. Earlier Nvidia drivers freeze immediately. The 1.0-8178 driver will work for a few minutes and then the machine hard locks. If X is completely idle, or not running, the computer is stable.

The 2.6.14.7 kernel can often stay up for 30+ minutes of X activity, and 2.6.16-rc2-mm1 locks very quickly, even though it contains several fixes for issues in the ATI chipset.

This message is a plea for Nvidia to investigate this problem. I'm willing to offer whatever help I can in debugging the problem.
ScatterBot is offline   Reply With Quote
Old 02-09-06, 06:51 PM   #2
ScatterBot
Registered User
 
Join Date: Feb 2006
Posts: 11
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Attached is the log with nvidia.ko loaded with NVreg_ResmanDebugLevel=0

The computer is running 2.6.14.7. The log starts when I load the module, I then immediately started X, which only does an xsetroot -solid black, no windows appear.

Where

Code:
Debian GNU/Linux 3.1 shiner ttyS0

shiner login:
appears X has completed loading. Immediately after that I ran glxgears -display :0, and it ran for approximately 7 minutes before the machine locked. No additional information was output after the initial burst when glxgears started.

For information on the computer see the nvidia-bug-report.log attached to the first message in http://www.nvnews.net/vbulletin/showthread.php?t=64509
The hardware and X version are the same as what was in that bug report, but I am currently using kernel 2.6.14.7 instead of 2.6.15.1.
Attached Files
File Type: txt nvreg.txt (25.2 KB, 425 views)
ScatterBot is offline   Reply With Quote
Old 02-10-06, 01:55 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

I've tracked down an ATI RS480 based motherboard (MSI-7093), and installed a GeForce 6200 TC card. I've got a 2.6.15.1 kernel, with 1.0-8178 and was able to successfully start X, and run two instances of glxgears for 30 minutes without any problems.

This problem seems to be specific to something in your environment.

-Lonni
netllama is offline   Reply With Quote
Old 02-11-06, 01:32 AM   #4
ScatterBot
Registered User
 
Join Date: Feb 2006
Posts: 11
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Thanks for taking the time to run that test. It gave me the motivation to try things again.

I had previously been running with Xorg 6.9.0 sarge-backport, so I completely pulled that out and went back to the standard Debian stable XFree86 4.3.0 with kernel 2.6.15.4. I then removed all of the Debian Nvidia packages and used the standard Nvidia installer to to get things running.

I then ran two glxgears for an hour, with no problems, and then the skyrocket opengl screensaver for another hour with no problems. Then I went on to the true test, playing videos. I started a loop of video to run all night, but the machine crashed within 20 minutes of starting the video. Now, 2.5 hours was the longest I'd ever been able to run X on the Nvidia card before the machine locked, but it still isn't stable.

Just to confirm that the machine is otherwise stable, I pulled out the Nvidia card and am displaying videos using the builtin ATI Xpress 200 controller, displaying to a monitor. So far it has gone for 2 hours with no problem.

I do appreciate the help you've given me, but if you have a chance, can you run the RS480/Nvidia test for a longer period of time?

I am completely willing to accept that it is something about my environment causing the problems---a defective motherboard, a defective video card, or the oddball socket 939 Sempron 64 that Compaq put in this computer (a Presario sr1710nx) that is causing the problem.
ScatterBot is offline   Reply With Quote
Old 02-13-06, 02:57 PM   #5
ScatterBot
Registered User
 
Join Date: Feb 2006
Posts: 11
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

I replaced the PCI express 6200 with a PCI 5200 and changed nothing else, and now the system is completely stable. I ran 14 hours of videos with no crashes.
ScatterBot is offline   Reply With Quote
Old 03-21-06, 10:16 PM   #6
jrseven
Just Another User
 
Join Date: Mar 2006
Location: California
Posts: 1
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Hey ScatterBot, it's not just you or your setup: I have an HP a1310n whose Asus AMD64 motherboard has the ATI Technologies Inc RS480 Host Bridge (rev 10). Kernel is 2.6.15 custom compiled with (gcc version 4.0.3 20051201 (prerelease) (Debian 4.0.2-5)) #1 PREEMPT.

I get these results:

- Borrowed FX5200 card (PCI bus) runs perfectly; no crashes in a month, including dozens of hours of videos, etc.

- Just bought an Asus 6200TC card (PCI express bus) and it crashes just as yours did. glxgears will kill it every time -- sometimes in a few seconds.

Of course, any help, tips, workarounds, etc. would be appreciated. I'd hate to have to return this otherwise great card for a darned Radeon!

Update: It generally lasts for a few minutes while watching videos, then hangs...but sometimes when it hangs, it seems to get stuck in a classic loop - even with the playing of endlessly repeated sounds(!).

Last edited by jrseven; 03-22-06 at 03:50 PM.
jrseven is offline   Reply With Quote
Old 04-02-06, 09:28 AM   #7
Gimli
Registered User
 
Join Date: Apr 2006
Posts: 1
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Same problem here: Packard Bell pc, AMD Athlon XP 3700+, 512 MB RAM, GeForce 6200se, ATI RS480 Host Bridge (rev 10) running Ubuntu Dapper (development release), kernel 2.6.15-19-amd64-generic and nvidia drivers 1.0-8178 from Ubuntu nvidia-glx package.
X freezes at random times, even when doing nothing. Booting with nolapic seems to shorten the amount if time before lockup (kernel from breezy didn't boot with this option), no other options seems to work: noapic and anything acpi related (acpi=off and such) prevents booting completely.
Even the amount of video ram detected by the driver is wrong: under breezy it was 128 MB, with dapper it now reports only 64 MB.
GPU temperature is between 66 and 68 C at all times, but since the warning limit is set to 145 C i assume it is normal.
Updating the BIOS with the latest revision from OEM's site didn't help.
Everything works fine with Windows XP.
Bye
Attached Files
File Type: log nvidia-bug-report.log (90.9 KB, 432 views)
Gimli is offline   Reply With Quote
Old 04-03-06, 11:57 AM   #8
mcduck
Registered User
 
Join Date: Apr 2006
Posts: 8
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

I first read about this, and it matched my problem exacly..however i dident think i was running the RS480 chipset...

oh well, guess what. I just did lspci:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:12.0 IDE interface: ATI Technologies Inc ATI 4379 Serial ATA Controller
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 TurboCache] (rev a1)
02:01.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001b (rev 01)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)

I got no idea how to make bug reports when logs show nothing. It just locks up.

My two cents
mcduck is offline   Reply With Quote

Old 04-04-06, 09:43 AM   #9
mcduck
Registered User
 
Join Date: Apr 2006
Posts: 8
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Ok, here is my bug report, aswell as a html file with motherboard info (Generated in Windows, so ignore the DirectX version line :>)

Same problems as all the others, sudden crash in linux, regardless of distribution (Iv tried 5 different), and regardless of kernel (Iv tried countless)

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:12.0 IDE interface: ATI Technologies Inc ATI 4379 Serial ATA Controller
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 TurboCache] (rev a1)
02:01.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001b (rev 01)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)

linux:/home/mcduck # uname -a
Linux linux 2.6.13-15-default #1 Tue Sep 13 14:56:15 UTC 2005 i686 athlon i386 GNU/Linux
Suse 10.0
Attached Files
File Type: zip nvidia-bug-report.log.zip (21.0 KB, 357 views)
File Type: zip motherboard.htm.htm.zip (1.4 KB, 375 views)
mcduck is offline   Reply With Quote
Old 04-05-06, 12:20 PM   #10
sysbuild1
Registered User
 
Join Date: Apr 2006
Posts: 1
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

Hello.

Is this issue beeing tested or is there a solution in the end of the tunnel?

We just shipped over 200 computers with this configuration for linux use (HP w5150.no Athlon 64)

Kind regards
sysbuild1 is offline   Reply With Quote
Old 04-05-06, 05:13 PM   #11
ScatterBot
Registered User
 
Join Date: Feb 2006
Posts: 11
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

I've been running with the 5200 for almost two months, with no crashes.

I haven't tried the 6200 back in the computer yet, but I will if Nvidia releases a new driver, or some change to the Linux kernel seems significant enough to be worth testing. I haven't had the opportunity to test any PCIe card other than the 6200.
ScatterBot is offline   Reply With Quote
Old 04-07-06, 11:32 AM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia 6200 and ATI RS480/482 chipset incompatibilities

1.0-8756 has been officially released:
http://www.nvnews.net/vbulletin/showthread.php?t=67864

Can those of you experiencing problems with the GeForce 6200-TC card and ATI-RS480/482 chipset motherboards please test and confirm whether the instability still exists?

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.