Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-07, 05:55 AM   #1
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default 8600M GT trouble

Hello,

I got a new laptop (ASUS G1S).

Code:
T7500 - 2.2 GHz
4GB RAM <-- Important? FYI 8600M GT's BAR are remapped beyond 32Bit-range!
8600M GT
debian  sid/lenny. X64
latest bios!
BUT, X.org doesn't really work:
Code:
(WW) ****INVALID MEM ALLOCATION**** b: 0x140000000 e: 0x14fffffff correcting
and the results are:
nice psychedelic colors and crashes (no lockups, even the screen is NOT messed up after X died!!)
Attached Thumbnails
Click image for larger version

Name:	8600M-nvidia.jpg
Views:	891
Size:	205.9 KB
ID:	26231  Click image for larger version

Name:	8600M-vesa.jpg
Views:	509
Size:	167.0 KB
ID:	26232  
Attached Files
File Type: log nvidia-bug-report.log (135.0 KB, 253 views)
File Type: log nvidia-crash.log (60.3 KB, 210 views)
chunkey is offline   Reply With Quote
Old 06-15-07, 06:24 AM   #2
blk
Registered User
 
Join Date: Jun 2007
Posts: 30
Default Re: 8600M GT trouble

same here

config:
Code:
"Santa Rosa" MacBookPro 2.4Ghz
2Gb RAM
512Mb 8600M GT Bios 60.84.49.03.00
NVidia 100.14.09 driver, GCC 4.2, custom-compiled 2.6.22-rc3 kernel
Ubunty Gutsy (development branch)
i don't get the INVALID MEM warning though and X doesn't crash (it crashed the whole PC when i used the original 97.something driver that came with ubuntu, but that's probably because it didn't have support for the 8600M GT)
blk is offline   Reply With Quote
Old 06-15-07, 06:34 AM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 8600M GT trouble

k? can you generate a nvidia-bug-report.log too? (just run nvidia-bug-report.sh
or read the sticky)
chunkey is offline   Reply With Quote
Old 06-15-07, 06:38 AM   #4
blk
Registered User
 
Join Date: Jun 2007
Posts: 30
Default Re: 8600M GT trouble

i was just doing that..

here you go

..the (EE) NVIDIA(0): Error recovery failed. come from me playing with nvidia-settings.. they don't occur when just running Xorg (the No video decoder detected, does appear though)
Attached Files
File Type: gz nvidia-bug-report.log.gz (22.7 KB, 353 views)
blk is offline   Reply With Quote
Old 06-15-07, 06:43 AM   #5
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 8600M GT trouble

Code:
NVRM: Xid (0001:00): 13, 0001 00000000 00005097 00000884 ff000000 00000080
NVRM: Xid (0001:00): 6, PE0001 
NVRM: Xid (0001:00): 6, PE0001 
...
NVRM: Xid (0001:00): 6, PE0001 
NVRM: Xid (0001:00): 13, 0001 00000000 00005097 00000680 000204d4 00000080
...
NVRM: Xid (0001:00): 30,  L1 -> L0
NVRM: Xid (0001:00): 30,  L1 -> L0
NVRM: Xid (0001:00): 13, 0001 00000000 00005097 00000680 000204b7 00000080
NVRM: Xid (0001:00): 13, 0001 00000000 0000502d 00000208 00000040 00000100
Ouch, that doesn't look so good!

EDIT: [seems to be a x64 problem, atleast the current knoppix vesa driver works!)
chunkey is offline   Reply With Quote
Old 06-15-07, 07:24 AM   #6
blk
Registered User
 
Join Date: Jun 2007
Posts: 30
Default Re: 8600M GT trouble

now the question is, wait for a patch or setup the whole thing again on x86..
blk is offline   Reply With Quote
Old 06-15-07, 08:50 AM   #7
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 8600M GT trouble

Quote:
Originally Posted by blk
now the question is, wait for a patch or setup the whole thing again on x86..
Hmm, I've only tested the vesa driver on x86, not nvidia..

But, it would be very nice if nvidia can confirm this bug and MAYBE have possible solution or workaround handy.

OT: Yes, my "old" 6600GT had a similar bug, "NORENDEREXTENSION"!
chunkey is offline   Reply With Quote
Old 06-15-07, 10:11 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8600M GT trouble

blk,
From your bug report, it appears that you're experiencing a completely different issue than what chunkey is reporting. I'd recommend starting a new thread for your issue.

chunkey,
In your bug report, I see :
PCI: Cannot allocate resource region 9 of bridge 0000:00:01.0
PCI: Cannot allocate resource region 1 of device 0000:01:00.0
mtrr: type mismatch for fbc00000,200000 old: write-back new: write-combining
mtrr: type mismatch for fb800000,400000 old: write-back new: write-combining
mtrr: type mismatch for fb000000,800000 old: write-back new: write-combining

It looks like there are some potential BIOS problems here that should be addressed by ASUS.
netllama is offline   Reply With Quote

Old 06-15-07, 10:22 AM   #9
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 8600M GT trouble

Thanks!

but can you tell me what exactly should I ask ASUS to fix?
- MTRR table (type mismatch)
- e820 table (MCFG area is not reserved)
- ACPI for the (cannot alloc resource ... mess & bad ATKG checksum)
- ?hpet?
or do you see more potential problems?
chunkey is offline   Reply With Quote
Old 06-15-07, 10:27 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8600M GT trouble

What you've listed is what stands out in your bug report. There may or may not be other problems that are not obvious to me.
netllama is offline   Reply With Quote
Old 06-15-07, 10:37 AM   #11
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 8600M GT trouble

64-bit BARs mapped above 4GB are not currently supported; this is due primarily to traditional limitations in most Linux kernels and X servers.
zander is offline   Reply With Quote
Old 06-15-07, 10:48 AM   #12
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 8600M GT trouble

@zander,

in "most" Linux kernels and X servers or in "ANY"?
chunkey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble in startx rahman NVIDIA Linux 12 10-24-02 05:53 AM
POSSIBLE AGP TROUBLE (mandrake 9.0) chrono86 NVIDIA Linux 4 10-12-02 12:09 PM
NVidia Trouble ixion NVIDIA Linux 4 09-27-02 08:08 AM
nForce/Fortissimo III 7.1 trouble... koneill General Hardware 2 09-08-02 09:34 PM
trouble enabling 3d mukluk123 NVIDIA Linux 3 08-12-02 01:52 PM

All times are GMT -5. The time now is 04:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.