Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-25-07, 05:43 PM   #1
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

OMG, I just tried 100.14.03 on my 6600gt and doubtfully turned on subpixel rendering in KDE again.

Was I ever surprised! I can hardly believe it! It's actually fast now!

No slowdowns with scrolling text. Konqueror scrolls nice and smooth again like my old gf3.

I can't believe this wasn't in the changelog. For me this is the biggest fix to the Nvidia driver since I bought this card 2 years ago. It's like I have a new card.

Whatever you did, Nvidia, THANK YOU!

John
_john_i_ is offline   Reply With Quote
Old 04-25-07, 06:02 PM   #2
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

How can I check this stuff too??
djdoo is offline   Reply With Quote
Old 04-25-07, 06:23 PM   #3
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Quote:
Originally Posted by djdoo
How can I check this stuff too??
I'm not really sure what you are asking. If you are not familiar with the problem you can see this thread for more info: http://www.nvnews.net/vbulletin/showthread.php?t=65857

It seems to be mainly on the 6x00 series, but reported on others. To see the problem on the older drivers, turn on font antialiasing, with subpixel, and full hinting. Most kde apps including konqueror, and konsole were very slow, and slowed down the system with it when they were rendering text.

This problem has finally gone away with the beta driver.
_john_i_ is offline   Reply With Quote
Old 04-25-07, 07:12 PM   #4
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

I didn't get it... You mean that with antialiasing fonts in KDE apps subpixel hinting=on you got very very slow writing coloured text on 6600 card and the new driver solved the problem?
I don't face this kind of problem with my FX 5200. I always had been working with these settings in KDE switched on, but I'm glad to hear that there is finally a bug that this driver solved... Even if it's not in the changelog...
djdoo is offline   Reply With Quote
Old 04-25-07, 08:15 PM   #5
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Yes, that is correct. The 5200 was not affected as I recall so that is probably why you aren'tfamiliar with it. Myself and many others have been suffering from this for years. Many including myself thought this would never be fixed.
_john_i_ is offline   Reply With Quote
Old 05-15-07, 02:08 PM   #6
yelo
Registered User
 
Join Date: May 2006
Posts: 1
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Quote:
Originally Posted by _john_i_
OMG, I just tried 100.14.03 on my 6600gt and doubtfully turned on subpixel rendering in KDE again.

Was I ever surprised! I can hardly believe it! It's actually fast now!
Wow, you're right! Thanks for the heads-up. (found the post via google) I never got a chance to experience sub-pixeled fonts before, due to the performance issues. This is real eyecandy.
yelo is offline   Reply With Quote
Old 05-17-07, 12:11 PM   #7
ocilent1
Registered User
 
Join Date: Jan 2004
Posts: 19
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Yep, I can confirm this is fixed with the 100.14.03 beta driver and my 6600gt as well :-) Whoohoo! No more slow font rendering with kde apps when subpixel font hinting enabled!



Why won't nvidia this type of stuff in their changelog? I would have enabled subpixel hinting immediately if I had known.....
ocilent1 is offline   Reply With Quote
Old 05-17-07, 03:26 PM   #8
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

They could fix it accidentally...
That is why there no changelog for this bugfix
zbiggy is offline   Reply With Quote

Old 05-21-07, 04:52 PM   #9
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Quote:
Originally Posted by zbiggy
They could fix it accidentally...
That is why there no changelog for this bugfix

If they fixed it accidentally, I just hope they don't accidentally break it again
_john_i_ is offline   Reply With Quote
Old 05-21-07, 05:15 PM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

The fix was not accidental. The official non-beta release will have a more complete changelog.
AaronP is offline   Reply With Quote
Old 05-22-07, 01:33 PM   #11
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Quote:
Originally Posted by AaronP
The fix was not accidental. The official non-beta release will have a more complete changelog.
Aaron,

Thanks for the info, and especially for the fix.

It looks like you guys are getting a lot of grief here in the forum today, and I just want you to know the hard work of you, netllama, and others is greatly appreciated by me.

It is rare to have closed source developers so active in the end-user forums. Its good to have you here.

John
_john_i_ is offline   Reply With Quote
Old 05-22-07, 09:19 PM   #12
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 100.14.03 Fixes slow subpixel-AA fonts!!!!!!!!

Quote:
Originally Posted by _john_i_
Aaron,

Thanks for the info, and especially for the fix.

It looks like you guys are getting a lot of grief here in the forum today, and I just want you to know the hard work of you, netllama, and others is greatly appreciated by me.

It is rare to have closed source developers so active in the end-user forums. Its good to have you here.

John
Me too. I used to complain but treat my complains as source of motivation
zbiggy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.