Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-17-07, 12:55 PM   #1
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Xorg hangs at "Loading extension NV-GLX"

Hi,

I have two 7600GS cards with different Xorg servers running on these cards:
1. twinview with beryl
2. only tv-out

2nd X server is being started (with -sharevts) when I log in and it is working great.

Problems appear after waking up from suspend:
1. X server on the 1st card with twinview is working great
2. X server on the 2nd card is still running, but there is no picture on the TV after waking up

So I decided to kill 2nd X server before suspend mode and restarting it after waking up.

But X hangs (cpu running at 100%) after restarting at this line:
Code:
(II) NVIDIA(0): Setting mode "800x600"
(WW) NVIDIA(0): WAIT (0, 1, 0x8000, 0x000005c0, 0x000005c0)
(WW) NVIDIA(0): WAIT (0, 3, 0x8000, 0x00000af4, 0x00000af4)
(WW) NVIDIA(0): WAIT (0, 11, 0x8000, 0x00000b14, 0x00000b14)
(II) Loading extension NV-GLX
I waited for a minute, but nothing happened. Killing/restarting 1st X server resolves the problem. But this is not a solution, because it kills all my applications.

I hope to get some of the great comments from netllama or some other specialists to resolve this problem. I am using 1.0-9755 with kernel 2.6.21.3.

Thanks a lot.

M.
mirza.m is offline   Reply With Quote
Old 06-19-07, 04:09 PM   #2
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Re: Xorg hangs at "Loading extension NV-GLX"

Am I asking strange questions?

Nobody with an idea what might be going on?

M.
mirza.m is offline   Reply With Quote
Old 06-19-07, 04:10 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg hangs at "Loading extension NV-GLX"

I'd suggest reading the forum sticky posts.
netllama is offline   Reply With Quote
Old 06-19-07, 07:12 PM   #4
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Re: Xorg hangs at "Loading extension NV-GLX"

You are talking about "If you have a problem, PLEASE read this first"?

I hope so ... Here is the nvidia-bug-report.

I had to gzip it because it is pretty big.


I added also the log of Xorg.1.log at the of the regular nvidia-bug-report.log, because that is the log file of the 2nd Xorg server (started with -logverbose 6). I can split it in two files if you want.

I hope you have an idea, what is going on.

Thanks a lot.

M.
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.1 KB, 154 views)
mirza.m is offline   Reply With Quote
Old 06-19-07, 08:34 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg hangs at "Loading extension NV-GLX"

I don't see any issues with NV-GLX in your bug report.

Also note that 1.0-9755 is no longer supported. You should upgrade to 100.14.09 if you're still having problems.
netllama is offline   Reply With Quote
Old 06-20-07, 03:52 AM   #6
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Re: Xorg hangs at "Loading extension NV-GLX"

OK, I will upgrade.

Quote:
I don't see any issues with NV-GLX in your bug report.
Do you see at the end of the log file, how to 2nd X server just stops at "Loading extension NV-GLX"?

It stops there and cpu is running with 100%. X does not get started, and none o of the commands from xinitrc does not start.

M.
mirza.m is offline   Reply With Quote
Old 06-20-07, 09:30 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg hangs at "Loading extension NV-GLX"

Sorry, I had missed that you appended the 2nd X log to the end of the bug report. In the 2nd X log, I see several WAIT messages, which can be triggered when the nvidia driver is mpt receiving interrupts from the graphics card. This could be a driver bug, or it could be a bug elsewhere (X server, kernel, BIOS, etc).

Please retest with 100.14.09, and if the problem persists, please verify:
0) That you're using the latest motherboard BIOS
1) Whether the problem persists if you run one X server for both GPUs

thanks,
Lonni
netllama is offline   Reply With Quote
Old 06-22-07, 01:47 PM   #8
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Re: Xorg hangs at "Loading extension NV-GLX"

Quote:
Originally Posted by netllama
Please retest with 100.14.09
retested ... same situation

Quote:
Originally Posted by netllama
and if the problem persists, please verify:
0) That you're using the latest motherboard BIOS
1) Whether the problem persists if you run one X server for both GPUs
I am not using latest motherboard BIOS, but I will update tomorrow. I also tried with swapping two cards (I moved 1st card in the PCIe slot of the 2nd card and 2nd in the 1st slot) but no changes.


Back to the root of the problem. As I told in the 1st post:
Quote:
2. X server on the 2nd card is still running, but there is no picture on the TV after waking up

So I decided to kill 2nd X server before suspend mode and restarting it after waking up.
The problem with these WAIT messages appear only if I (after waking up from suspend) kill the 2nd server and start it again. It does not appear when I start it first time (before suspend). But as I told, after waking up, there is no picture on the TV. That's why I kill 2nd X server and start it again.


But when I start X first time (before suspending), I get these messages, but only on the 2nd X server, not on the 1st:

Code:
(II) NVIDIA(0):
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R7/lib/modules/libint10.so
(II) Attempted to read BIOS 128KB from /sys/bus/pci/devices/0000:07:00.0/rom: got 0KB
(II) xf86ReadPciBios: modifying membase[-1] for device 7:0:0
(II) xf86ReadPciBios: modifying membase[-1] for device 7:0:0
Requesting insufficient memory window!: start: 0xf7000000 end: 0xf9ffffff size 0x10000000
(EE) Cannot find empty range to map base to
(EE) NVIDIA(0): Cannot read V_BIOS
(EE) NVIDIA(0): Unable to initialize the X Int10 module; the console may not
(EE) NVIDIA(0):     be restored correctly on your TV.
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
Is/Could this be a reason for no picture on the TV after waking up?
Is int10 being used only for TV? I am asking this because I do not see the message Loading sub module "int10" when I start 1st X server on the 1st card. I see it only when I start 2nd X server on the 2nd card.

Thanks a lot.

M.
mirza.m is offline   Reply With Quote

Old 06-22-07, 01:56 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg hangs at "Loading extension NV-GLX"

Yes, int10 is normally only needed for TVs. Based on the latest information, it looks like the problem here is outside of the nvidia driver.
netllama is offline   Reply With Quote
Old 06-22-07, 02:12 PM   #10
mirza.m
Registered User
 
mirza.m's Avatar
 
Join Date: Jan 2006
Posts: 11
Default Re: Xorg hangs at "Loading extension NV-GLX"

Suggestions? Reinstalling/recompiling X server?

M.
mirza.m is offline   Reply With Quote
Old 06-22-07, 02:14 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg hangs at "Loading extension NV-GLX"

Its not clear where the problem is. It might be a kernel or BIOS bug, it might be Xorg. All that is clear to me, is that the first fatal error is not coming from the nvidia driver.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 03:42 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 08:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.