Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-23-07, 02:41 AM   #1
ashrafkadry
Registered User
 
Join Date: Aug 2006
Posts: 4
Default DFP monitor after installing the nvidia drivers

hi

First of all I have to state the specs of system: I have a Gigabyte GA-965P-DS3 (ver 3.3), a Viewsonic 20.1" VX2025WM monitor, a XFX 8600 GT video card, oh and E6600 Pentium Core 2 Duo processor. Guess that's we all need.

I have three oeprating systems running on the same harddrive, I just keep them there in rainy days, where I have to install, Uninstall, and reinstall many times the OS. The first OS is Windows XP Pro, the second one is Windows Vista Business, and thirdly I have Ubuntu 7.04 (Feisty Fawn)

I'm not that new to linux since I already had Yellow Dod installed on my PS3, I know my away a little, that is, but don't expect an expert keyboard dasher when it comes to using the command prompt.

Anyhow, I installed ubuntu, usually I get an error during installation, when I use the live CD, that the program has failed to start the Xserver, the graphical interface, because no display devices were found, so I installed ubuntu by choosing the Safe Mode Graphics which ran fine and enabled me to install the OS with no trouble. After installing ubuntu, oh and by the way during the installtion and after I logged in I choose a resolution of 1680x1050 @60 GHz and I chose that resolution from the initial installation window just press f4.

So After I installed Ubuntu, I headed over to nvidia and downloaded the drivers appropriate for my video card which is ver. 100.14.11. I downloaded them to my desktop.

I began the installation by following the steps in this sticky post http://www.nvnews.net/vbulletin/showthread.php?t=72490

and this is what I did exactly:

1. I searched the synapted manager for gcc and make packages and installed them both.

2. installed a linux headers package for my kernel which is the current one.

3. installed both pkg-config and xserver-xorg-dev packages

4. the nvidia-glx package: ok I had a problem locating this package. I mean I searched for it in synapted manager and I found it listed, but it was not installed on my machine, obviously the post assumed that most ubuntu owner would download this package first before using the Beta drivers released by Nvidia.

5. The two packages linux-restricted-modules or linux-restricted-modules-common were uinstalled completely from my system which resulted in the two files: etc/default/linux-restricted-modules or /etc/default/linux-restricted-modules-common configuration not to be found and therefore the following command could not be applied:

DISABLED_MODULES="nv nvidia_new"

so I restarted the computer..chose ubuntu from the grub menu..and logged in successfully in ubuntu..

But, the resolution sucks, I went to the nvidia xserver configuration, and looked up my monitor and all I found was DFP-1 Monitor, with maximum resolution of 640x480 WHY??? really WHY??

I don't know what happened but it doesn't look good?

since then, and that happened yesterday, I haven't went back to ubuntu, oh and one more thing, the restritced managers module is asking me to install one of the restricted linux common packaged for it to function again.

By the way, before I installed the nvidia drivers, everytime I tried to open the restricted drivers manager I always got this message "your hardware does not need any restricted drivers" ...

can anyone help me please? because I've seen it all from this whole ubuntu stuff..

anyhelp is appreciated thank you all

regards
redheat
ashrafkadry is offline   Reply With Quote
Old 06-23-07, 09:32 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: DFP monitor after installing the nvidia drivers

Please start X with the following command:
startx -- -logverbose 6

and then generate and attach an nvidia-bug-report.log (per the forum sticky posts).
netllama is offline   Reply With Quote
Old 06-23-07, 09:46 PM   #3
ashrafkadry
Registered User
 
Join Date: Aug 2006
Posts: 4
Default Re: DFP monitor after installing the nvidia drivers

Quote:
Originally Posted by netllama
Please start X with the following command:
startx -- -logverbose 6

and then generate and attach an nvidia-bug-report.log (per the forum sticky posts).
netllama, thank you for your reply. I have reformatted my system and installed it again and then, I thought, I might have done something wrong using nvidia's method of installation, so I used Albertomoleno's envy, and guess what? it just gave the same result.

When I open the desktop, and then go to xserver nvidia settings, by the way his envy program downloaded the same driver for me just like I would on my own, and then it did the installation for me. But the same problem happened. My monitor is seen as DFP-1 Monitor with maximux resolution of 640x480. The same problem happened to some people on the ubuntu forums: here are links to their posts: (and this is just for example)

1. http://ubuntuforums.org/showthread.p...20070624051447

fyi, I got the same error when I tried to change the resolution and this is what I wrote in the terminal:

sudo dpkg-reconfigure xserver-xorg -phigh

and then it opened a blue scree within the terminal asking me to choose which video car I'm using and which resolution, so I chose nvidia, and resolution 1680x1050 and then it gave me this message:

xserver-xorg postinst warning: overwriting possibly-customised configuration
file; backup in /etc/X11/xorg.conf.20070624053451


so I thought I should also post my xserver configuration file around here:

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection

SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection


EndSection

Section "DRI"
Mode 0666
EndSection


sorry if I've repeated some parts headers because I'm typing this from a 640x480 resolution, so I was just cutting and pasting piece by piece.

regards
ashraf kadry
ashrafkadry is offline   Reply With Quote
Old 06-23-07, 10:19 PM   #4
younker
Registered User
 
Join Date: May 2004
Posts: 20
Default Re: DFP monitor after installing the nvidia drivers

Hi, I have the same issue, I use gentoo, and updated to the latest driver, after I reboot, I can not use the standard resolution of my viewsonic wm2025, from the log file I see a line that mentioned my video card (GF76600GS) cannot detect the EDID information of my display?

By using the 9xxx drivers,everything is ok.

Anyone have this issue and solved it?
younker is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
monitor not recognised after installing nvidia drivers Horaciusl NVIDIA Linux 3 08-10-12 10:59 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.