Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-24-07, 11:58 AM   #1
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Compiz performance under load

When using compiz I get bad performance under load. To be precise - mouse is jerky when a program demands more cpu power (not only mouse, moving windows, resizing get also jerky). As I remember this never happened before on same hardware configuration, but 32-bit kernel (now I have 64-bit).
The problem is always visible, e.g. when launching koqueror, when using smart (installing new programs). Mouse gets really jerky.
When moving windows around (slowly) or slowly rotating cube, I can see CPU usage going to high levels (90% +), process causing this was Xorg.

Normally in 2d mode none of this problem is seen. Curently I'm launching compiz with:
Code:
#export __GL_YIELD="NOTHING"; compiz --replace --loose-binding --indirect-rendering ccp &
I read many performance optimization tweaks, did xorg.conf tweaks... don't know what else to do anymore.
Can you please help me to kill this problem. I started to think switching back to 32 bit, where compiz was really smooth under heavy load.... but better solution is to pinpoint the real problem, so I'm asking you - graphics experts.

EDIT: here I found someone describing my problem too:
http://lists.freedesktop.org/archive...ch/001686.html

Last edited by kriko; 05-31-11 at 01:34 PM.
kriko is offline   Reply With Quote
Old 07-19-07, 06:52 AM   #2
user5124
Registered User
 
Join Date: Jul 2006
Posts: 8
Default Re: Compiz performance under load

The gl yield nothing option improved it for me, but definitely didn't completely solve it. Thanks for the tip.

I'm running a Athlon 64 X2 4600 and a geforce 8800gtx. I guess I need to upgrade for smooth gui effects :P
user5124 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
poor kde X windows performance after restart HeadStrong NVIDIA Linux 5 08-19-02 07:17 PM

All times are GMT -5. The time now is 11:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.