Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-27-07, 04:32 AM   #1
damunix
Registered User
 
Join Date: Jun 2007
Posts: 5
Default software rendering ?

Hi,

I buy a geforce 6200 128Mb of RAM 2 mounth ago, to have a direct rendering on my linux desktop. I made some test, and I see that glxinfo says direct rendering : true, and a lot of glx extensions.

But When I move a window, top says the X process use 60%-70% of processor !!! And when I watch a movie, I have some lag and the console output says I have a "too slow computer", but I have a 2700+, and my processor is use at 100%....


So I test an other distrib, fedora 7, same problem.

I update my bios revision, same problem...

here is the bug-report : http://casalinux.net/nvidia-bug-report.log

Any idea ?


thanks

damunix
damunix is offline   Reply With Quote
Old 06-27-07, 06:59 AM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: software rendering ?

hm, maybe clean up your installation?

the installer complains about old versions and not uninstalling it:
> Validating previous installation:
-> The previously installed file '/usr/lib/libXvMCNVIDIA.a' has a different
checksum (1945485504) than when it was installed (3363329715).
/usr/lib/libXvMCNVIDIA.a will not be uninstalled.
-> The previously installed file '/usr/lib/xorg/modules/drivers/nvidia_drv.so'
has a different checksum (103512064) than when it was installed
(3272284986). /usr/lib/xorg/modules/drivers/nvidia_drv.so will not be
uninstalled.
-> The previously installed file '/usr/bin/nvidia-settings' has a different
checksum (1490376568) than when it was installed (3419427026).
/usr/bin/nvidia-settings will not be uninstalled.
-> The previously installed file '/usr/bin/nvidia-xconfig' has a different
checksum (2655063421) than when it was installed (2989717027).
/usr/bin/nvidia-xconfig will not be uninstalled.
-> The previously installed file '/usr/bin/nvidia-bug-report.sh' has a
different checksum (1650134379) than when it was installed (2774419135).
/usr/bin/nvidia-bug-report.sh will not be uninstalled.
-> The previously installed file
'/usr/share/applications/nvidia-settings.desktop' has a different checksum
(1937527717) than when it was installed (977511138).
/usr/share/applications/nvidia-settings.desktop will not be uninstalled.
-> The previously installed symlink '/usr/lib/libGL.so.1' has target
'/usr/lib/libGL.so.1.0.9755', but it was installed with target
'libGL.so.1.0.8776'. /usr/lib/libGL.so.1 will not be uninstalled.
-> The previously installed symlink '/usr/lib/libGL.so' has target
'/usr/lib/libGL.so.1.0.9755', but it was installed with target 'libGL.so.1'.
/usr/lib/libGL.so will not be uninstalled.
-> The previously installed symlink '/usr/lib/libGLcore.so.1' has target
'/usr/lib/libGLcore.so.1.0.9755', but it was installed with target
'libGLcore.so.1.0.8776'. /usr/lib/libGLcore.so.1 will not be uninstalled.
-> The previously installed symlink '/usr/lib/libnvidia-tls.so.1' has target
'/usr/lib/libnvidia-tls.so.1.0.9755', but it was installed with target
'libnvidia-tls.so.1.0.8776'. /usr/lib/libnvidia-tls.so.1 will not be
uninstalled.
-> The previously installed symlink '/usr/lib/libnvidia-cfg.so.1' has target
'/usr/lib/libnvidia-cfg.so.1.0.9755', but it was installed with target
'libnvidia-cfg.so.1.0.8776'. /usr/lib/libnvidia-cfg.so.1 will not be
uninstalled.
-> The previously installed symlink
'/usr/lib/xorg/modules/extensions/libglx.so' has target
'/usr/lib/xorg/modules/extensions/libglx.so.1.0.9755', but it was installed
with target 'libglx.so.1.0.8776'.
/usr/lib/xorg/modules/extensions/libglx.so will not be uninstalled.
-> The previously installed symlink '/usr/lib/libXvMCNVIDIA_dynamic.so.1' has
target 'libXvMCNVIDIA.so.1.0.9755', but it was installed with target
'libXvMCNVIDIA.so.1.0.8776'. /usr/lib/libXvMCNVIDIA_dynamic.so.1 will not
be uninstalled.
-> done.
WARNING: Your driver installation has been altered since it was initially
installed; this may happen, for example, if you have since installed
the NVIDIA driver through a mechanism other than nvidia-installer
(such as your distribution's native package management system).
nvidia-installer will attempt to uninstall as best it can. Please see
the file '/var/log/nvidia-installer.log' for details.

go there, remove the cruft, try again?

oh, and maybe clean up xorg.conf too.. do you really need twinview?
energyman76b is offline   Reply With Quote
Old 06-27-07, 07:17 AM   #3
damunix
Registered User
 
Join Date: Jun 2007
Posts: 5
Default Re: software rendering ?

Yes I have 2 screen.

ok their is a lot of problem on this version, but do you think it is the same on fedora ? I can't give you the nvidia-bug-report for the moment, cause I'm not at home, but It was a new install, so I don't think It is an opengl problem
damunix is offline   Reply With Quote
Old 06-27-07, 07:37 AM   #4
damunix
Registered User
 
Join Date: Jun 2007
Posts: 5
Default Re: software rendering ?

the new : http://casalinux.net/nvidia-bug-report.log

This is with a dual screen, bug with a mono screen, it is the same result, with an original Xorg.conf file generated by nvidia utils
damunix is offline   Reply With Quote
Old 06-27-07, 08:12 AM   #5
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: software rendering ?

Hi,

that X causes a high load on moving windows is 'normal' and nothing to worry about. I have a dual core and a 6600.. and moving a window around fast can give up to 70% load in htop.

Your video load is strange.

Do you have a high load, if you only use one screen?

Can you make sure, that you are using xv?

Oh, and you could try turning on backingstore.

(and please, don't replace the logs. give every single on a unique 'name'.. not really important, but it prevents confusion )
energyman76b is offline   Reply With Quote
Old 06-27-07, 08:28 AM   #6
damunix
Registered User
 
Join Date: Jun 2007
Posts: 5
Default Re: software rendering ?

ok I while think about changing name.

I test it with a single screen, I have the same problem. A friend come at home, at tell me that He didn't have the same load problem with a ATI card.

If I test with beryl, I can see tahta only my cpu is using, cause When I move a window, I have lots of lags, and processor is at 100%.

Are you sure that when you move your processor is use ? cause I test it on my parents computer, with an nvidia card and a Core 2 duo, but none cpu is use when I move a window....
damunix is offline   Reply With Quote
Old 06-27-07, 09:25 AM   #7
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: software rendering ?

Some things I saw in your log:

Quote:
/proc/driver/nvidia/agp/status
Status: Disabled
Not sure specifically what that implies, but it certainly doesn't sound good.

Quote:
(**) Option "AIGLX" "off"
Quote:
(WW) NVIDIA(0): 32-bit ARGB GLX visuals require the Composite extension.
(WW) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
Quote:
Option "AIGLX" "off"
Somewhat important if you're using beryl (ugh, why are you using that POS?)

Quote:
Jun 25 22:13:23 damunix-fixe NVRM: API mismatch: the client has the version 100.14.11, but
Jun 25 22:13:23 damunix-fixe NVRM: this kernel module has the version 100.14.09. Please
Jun 25 22:13:23 damunix-fixe NVRM: make sure that this kernel module and all NVIDIA driver
Jun 25 22:13:23 damunix-fixe NVRM: components have the same version.
That is very telling. You've got two different versions of the driver installed at the same time. Wipe out all of the NVIDIA installation, reinstall, and then make sure you restart X.
__________________
What?
elanthis is offline   Reply With Quote
Old 06-27-07, 11:21 AM   #8
damunix
Registered User
 
Join Date: Jun 2007
Posts: 5
Default Re: software rendering ?

Aiglx was put at false by the nvidia utils, and I don't use beryl for the moment, I just said that if I launch beryl, their is a lot of lag, I mean taht I don't think X use my video card.

Quote:
/proc/driver/nvidia/agp/status
Status: Disabled
do you think it can be the problem ? how can I solve it ?

I will send the nvidia report of fedora version, we will see if it is at false too
damunix is offline   Reply With Quote

Old 06-27-07, 02:18 PM   #9
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: software rendering ?

elanthis, AIGLX off is correct for nvidia. Nvidia does NOT use AIGLX.

hm, from the dmesg output in the log it looks like AGP is enabled.

damunix, compare dmesg output and agp-status.

Maybe that status was from the mismatching.
energyman76b is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Now Available: Knights Corner Open Source Software Stack News Archived News Items 0 06-05-12 08:00 PM
ArcSoft Total Media Theatre 5 Software Blu-ray 3D Player Promo News Archived News Items 0 06-01-12 05:30 AM
Xoreax Software Finds Diamonds in the Cloud News Archived News Items 0 05-25-12 12:20 PM
Slidecast: Allinea Software ' Meeting the Quest to Run Applications Faster News Archived News Items 0 05-21-12 06:30 AM
What Has Happened with Roxio's Cineplayer BD With 3D Software News Archived News Items 0 05-13-12 05:20 PM

All times are GMT -5. The time now is 05:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.