Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-28-03, 08:59 PM   #157
greenjelly84
Registered User
 
Join Date: Apr 2003
Location: Canada
Posts: 18
Default

Hi, try a 2.4.20 kernel

http://www.kernel.org/pub/linux/kern...-2.4.20.tar.gz

just unpack it to /usr/src/

update the linux simlink to point to this new kernel and try patching
greenjelly84 is offline   Reply With Quote
Old 05-29-03, 02:04 AM   #158
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default

Quote:
Originally posted by D3F4U7T
I am still getting the agp_backend.h error.
What do you mean you are still getting that error ? You are only supposed to install the patch *once*. After it failed to update agp_backend.h make that one little change that didn't get done automatically (the one I posted earlier). That's it. Really!

Based on responses I have seen in other forums that patch works on 2.4.20 and 2.4.21.
leibold is offline   Reply With Quote
Old 05-30-03, 12:06 AM   #159
Maliekieth
Registered User
 
Join Date: May 2003
Location: Auckland, New Zealand
Posts: 5
Default

Well I got DRI working finally .

I used the build_mod that was given in the thread nonolk linked too. I tried the kernel patch as well, it appared to work but crashes X if I try to do glxgears or glxinfo, so I went back to the ATI driver internal AGPGART. It says it is running in AGP 3.0 natively 8x, with SBA and FW (from the fireglcontrol program).

My only problem is that I get a lower framerate in glxgears than I got when it was running purely software mode.

Software = 255fps
DRI = 75-80fps.

Something seems dreadfully wrong.

I'm running the 2.9.12 w/ build_mod from wardy. I'm using Debian Stable with 2.4.21-rc2 kernel and Xfree 4.1.0

Any ideas?

Last edited by Maliekieth; 05-30-03 at 12:09 AM.
Maliekieth is offline   Reply With Quote
Old 05-30-03, 02:22 AM   #160
Kiamu
Registered User
 
Join Date: Apr 2003
Location: Germany
Posts: 77
Default

checked glxinfo?

are you running on the ati libGL.so or on the native one?
Kiamu is offline   Reply With Quote
Old 06-01-03, 11:03 AM   #161
bladerunner.cz
Registered User
 
Join Date: Mar 2003
Location: Czech Republic
Posts: 4
Send a message via ICQ to bladerunner.cz
Default

maybe your fglrx has activated vertical synchronization.
depends on fglrx configuration.
bladerunner.cz is offline   Reply With Quote
Old 06-01-03, 03:39 PM   #162
MidnightWatcher
Registered User
 
Join Date: Jun 2003
Posts: 53
Default Registered for this thread

Hi everyone, I'm relatively new to Linux and have just installed the new Mandrake 9.1.

I tried to install the patch mentioned here, but when I type in patch -p0 <name> it seems to just sit there, doing nothing except for a blinking cursor. Is this normal and do I need to wait a while, or should it patch immediately and give me some information? I'd really like to get this working. Thank you all in advance.

MW
MidnightWatcher is offline   Reply With Quote
Old 06-01-03, 03:42 PM   #163
Kiamu
Registered User
 
Join Date: Apr 2003
Location: Germany
Posts: 77
Default

try: patch -p0 -E < 'patch'

for further info try: patch --help or man patch
Kiamu is offline   Reply With Quote
Old 06-02-03, 09:08 AM   #164
bladerunner.cz
Registered User
 
Join Date: Mar 2003
Location: Czech Republic
Posts: 4
Send a message via ICQ to bladerunner.cz
Default

also you can try
patch -Np0 -i $patch_name
I'm using patch -p0 -f -i $patch_name for kernel patches
take a look in `man patch` for details
where file $patch_name is outside but the same level of to be patched directory.
bladerunner.cz is offline   Reply With Quote

Old 06-08-03, 08:22 AM   #165
omen
Registered User
 
Join Date: Jun 2003
Location: germany
Posts: 1
Default

Hi, the http://www.epitech.net/~nonolk Webpage is down.
Could everyone send me the patch please.
omen is offline   Reply With Quote
Old 06-10-03, 01:46 AM   #166
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default

Quote:
Originally posted by omen
Could everyone send me the patch please.
I think you meant "someone" or do you really have such a big mailbox ?

I have the initial version of the agpgart patch from nonolk (and that's what I'm using myself). I also seem to have picked up a later version of that same patch as well as the fglrx patch (but I don't think it was the final version). If you are interested in any or all of the above send me your email address.
leibold is offline   Reply With Quote
Old 07-01-03, 06:55 PM   #167
dom521
Registered User
 
Join Date: Jun 2003
Posts: 12
Default

Ok, since kernel 2.4.21 is out, we also been a working agp patch for it Nvidia finally updated their drivers, but, the patch seems to be for the 2.4.20 kernel. Did anyone see the patch floating around anywhere? If so, posting the link would be appreciated. Thanks.
dom521 is offline   Reply With Quote
Old 07-02-03, 01:49 AM   #168
nonolk
Registered User
 
Join Date: Apr 2003
Posts: 26
Default

Hi dom521,

you can find a patch for 2.4.21 here :

http://members.optusnet.com.au/ckolivas/kernel/

or use the 2.4.21-ac4 patch.

Enjoy
__________________
Asus A8N-SLI
AMD Athlon 64 3500+
Asus 6600 GT pciX
1024 Mo ddr 3200 Corsair
nonolk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.