Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-25-07, 09:08 AM   #1
harvey22
Registered User
 
Join Date: Jun 2007
Posts: 2
Default Can't configure nvidia with sax

Hi,
I would like to run the nvidia driver on my Suse 10.2 system, but I can't configure the driver with sax.

I followed the instructions in the "HOWTO for SUSE LINUX users" until I reached the sax2 -r command. In the monitor section only the monitor information can be changed. The graphic card is desribed as VESA, but there seems to be no option to change this.

What's wrong?
harvey22 is offline   Reply With Quote
Old 06-26-07, 07:58 PM   #2
chawknz
Registered User
 
Join Date: Nov 2006
Posts: 1
Default Re: Can't configure nvidia with sax

I have the same problem as you. I followed the "Easy " instructions from SUSE's website, installed both drivers, typed sax2 -r (and also rebooted) and there is no change in my graphic drivers. Everything is still slow (moving windows around).

Not sure what to do as there's no further steps except compiling an nvidia source.
chawknz is offline   Reply With Quote
Old 06-28-07, 05:55 AM   #3
kaptajnen
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: Can't configure nvidia with sax

I have the same problem - I did a full compilation with the nvidia driver source and now the graphics card is recognized (GeForce 8400M G) but I can't change the resolution!
kaptajnen is offline   Reply With Quote
Old 06-28-07, 01:00 PM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Can't configure nvidia with sax

I have no specific experience with SuSE 10.2, but using sax on all earlier SuSE versions just drives me crazy.
I know I select very nice settings but still it adds all its own junk. More or less like Nvidia drivers and their helpful manipulation of modelines.

Normally I just edit the xorg.conf with a text editor, and delete all the junk from the Screen section(s) so that only something like this remains:

Code:
Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      24
    Modes      "1920x1200"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection
pe1chl is offline   Reply With Quote
Old 06-28-07, 04:32 PM   #5
dev0
Registered User
 
Join Date: Jun 2007
Posts: 6
Default Re: Can't configure nvidia with sax

'sax2 -m 0=nvidia' or if ya need:
'sax2 -r -m 0=nvidia'
eventually 'info xmode'
in case of probs read this:
http://us.download.nvidia.com/XFree8...ppendix-b.html

and just as an example (beryl for nvidia enabled):

'cat /etc/X11/corg.conf'
Code:
# /.../
# SaX generated X11 config file
# Created on: 2007-05-25T19:32:58+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "freetype"
  Load         "type1"
  Load         "dbe"
  Load         "glx"
  Load         "extmod"
  Load         "v4l"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "logiclx300"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "7"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "USB Mouse"
  Option       "Protocol" "auto"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  DisplaySize  474 296
  HorizSync    30-82
  Identifier   "Monitor[0]"
  ModelName    "VIEWSONIC VX2235WM-EU"
  Option       "DPMS"
  VendorName   "VSC"
  VertRefresh  50-75
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1680x1050" "1600x1024" "1400x1050" "1280x1024" "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1680x1050" "1600x1024" "1400x1050" "1280x1024" "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1680x1050" "1600x1024" "1400x1050" "1280x1024" "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1680x1050" "1600x1024" "1400x1050" "1280x1024" "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "GeForce 7600 GS"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVIDIA"
  Option       "RenderAccel" "true"
  Option       "AllowGLXWithComposite" "true"
  Option       "backingstore" "true"
  Option       "TripleBuffer" "true"
  Option       "AddARGBGLXVisuals" "True" 
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
  Group        "0"
  Mode         0666
EndSection

Section "Extensions"
  Option       "Composite" "Enable"
EndSection
enjoy
/dev0

Last edited by dev0; 07-05-07 at 10:49 AM.
dev0 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Nvidia configure laasunde NVIDIA Linux 9 09-29-02 06:19 AM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 07:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.