Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-30-07, 09:27 PM   #1
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Thumbs down Controlling the screen blanker

I'm running Fedora 7 and using the latest drivers I downloaded a few days ago. The screen wants to go black on it's own after about 15 minutes (power down) and as far as I can tell I don't have it set to do that. Is there some secret setting in these nVidia drivers where the real setting is?

Thanks in advance.
mperkel is offline   Reply With Quote
Old 07-01-07, 12:27 AM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Controlling the screen blanker

there are no secret settings.

try xset

xset --help
energyman76b is offline   Reply With Quote
Old 07-01-07, 09:56 AM   #3
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Question Re: Controlling the screen blanker

Nope - that didn't work. Screen still goes blank on it's own.
mperkel is offline   Reply With Quote
Old 07-01-07, 03:26 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Controlling the screen blanker

Which xset options did you set? You need to set at least "xset s off" and "xset -dpms".
AaronP is offline   Reply With Quote
Old 07-01-07, 06:06 PM   #5
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Question Re: Controlling the screen blanker

Quote:
Originally Posted by AaronP
Which xset options did you set? You need to set at least "xset s off" and "xset -dpms".
Yep - I did xset s off and when I did xset -dpms it said "server does not have extension for -dpms option.

Thanks to everyone for your help on this.
mperkel is offline   Reply With Quote
Old 07-02-07, 03:22 AM   #6
bearoso
Registered User
 
Join Date: Sep 2003
Posts: 57
Default Re: Controlling the screen blanker

Chances are you're unknowingly running gnome-power-manager, and you should be able to find configuration options through the menu: System->Preferences->(Either System or Hardware)->Power Management.
bearoso is offline   Reply With Quote
Old 07-02-07, 04:13 AM   #7
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Controlling the screen blanker

Quote:
when I did xset -dpms it said "server does not have extension for -dpms option.
maybe you should add "option dpms" somewhere in your xorg.conf (google for it), so as to enable X dpms module, else blanking may be bios-controlled (hence not disablable).
lloeki is offline   Reply With Quote
Old 07-03-07, 06:41 PM   #8
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Default Re: Controlling the screen blanker

Quote:
Originally Posted by lloeki
maybe you should add "option dpms" somewhere in your xorg.conf (google for it), so as to enable X dpms module, else blanking may be bios-controlled (hence not disablable).
I do have option "dpms" set. Any other suggestions?
mperkel is offline   Reply With Quote

Old 07-04-07, 04:46 AM   #9
bearoso
Registered User
 
Join Date: Sep 2003
Posts: 57
Default Re: Controlling the screen blanker

Run the utility "gnome-power-preferences" in a terminal and check out the window that appears. HAL overrides X's DPMS.
bearoso is offline   Reply With Quote
Old 07-06-07, 09:14 PM   #10
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Default Re: Controlling the screen blanker

I don't have gnome installed and the kde utils have no effect.
mperkel is offline   Reply With Quote
Old 07-06-07, 11:46 PM   #11
kidb
Registered User
 
Join Date: May 2004
Posts: 3
Default Re: Controlling the screen blanker

xset s noblank
kidb is offline   Reply With Quote
Old 07-15-07, 12:48 PM   #12
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Default Re: Controlling the screen blanker

No xset setting have ANY affect at all. Surely there is SOME way to stop the screen from going blank. I tell you what I'm not going to use nVidia chip sets anymore if they can't get a damn video driver written for linux a year after they produce a product.
mperkel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 06:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 07:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 04:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM

All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.