Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-07, 06:41 PM   #1
gga13
Registered User
 
Join Date: Nov 2006
Posts: 7
Default [Development] OpenGL Texture VBlank Issues

I'm developing a simple application on Linux (an image and movie player) and I have some questions regarding some issues I am seeing under a GeForce 7300GTX.

Currently, I am playing my video by mapping a quad with a multitexture shader pipeline. The texture gets regenerated every 1/24-60th of a second using glTexSubImage2D and the application runs under the FLTK toolkit.

The problem I am seeing are issues with the redraw/update leading to some minor 'tears' during playback, as if the opengl was not properly synced with the monitors' vsync.

I was also getting similar issues just when I was trying to pan an image very fast. Turning OFF the "Allow Flipping" option in the nvidia settings fixed that problem. However, the video tearing problem remains. All the Sync To VBlank options are switched on.

I'm looking for hints or some help as to what could I be doing wrong.
If this is not appropriate forum, please point me in the right direction.
gga13 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.