Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-07, 04:39 PM   #1
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Fullscreen problem in text mode

Hello out there!

I am using VMWare Workstation 5.5 (currently 5.5.4 build-44386) under OpenSuSE 10.2 (KDE 3.5.7 "release 35.1") with Original NVIDIA-Driver (Versions 1.0-9631 and 100.14.09) on a

DELL PRECISION M90 Notebook
with NVIDIA Quadro FX 2500M
and SEIKO SEC KH164 LCD Monitor
using a resolution of 1024x768 with 24 bit colour.

Since I installed OpenSuSE 10.2 with VMWare Workstation 5.5 (different releases) I am experiencing problems running the VM fullscreen in text mode (80x25). On the x axis there is a disalignment of the screen and the lines of characters are broken by black lines.

I have been using VMWare Workstation 5.0 under OpenSuSE 10.0 (even with the original NVIDIA drivers) and did not experience such problem.

Using xorg.conf with Driver "nv" in Section "Device" makes the problem disappear.

Anybody with a good idea? I am using a lot of virtual DOS machines, and would prefer running them fullscreen in text mode.

Thanks!

Michael
Attached Thumbnails
Click image for larger version

Name:	Full.jpg
Views:	274
Size:	253.2 KB
ID:	26562  
MLeimann is offline   Reply With Quote
Old 07-02-07, 04:46 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Fullscreen problem in text mode

I've seen a few reports of this. My investigation showed that VMWare is requesting an interlaced mode when it goes to full screen, which results in the problem that you're reporting. This is a VMWare bug.

You can attempt to work around it with the ModeValidation option, by disallowing interlaced modes. You'll need to generate a verbose bug report per the sticky post if you need further assistance.
netllama is offline   Reply With Quote
Old 07-03-07, 12:28 AM   #3
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

Thanks for the info!

Please see attached file 'nvidia-bug-report.log'.

Can you help with that?

Best wishes

Michael
Attached Files
File Type: log nvidia-bug-report.log (117.0 KB, 93 views)
MLeimann is offline   Reply With Quote
Old 07-03-07, 09:34 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Fullscreen problem in text mode

Per the sticky post, you need to generate a verbose X log before generating the bug report.
netllama is offline   Reply With Quote
Old 07-03-07, 01:12 PM   #5
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

Does this help you?

What do you mean by

> Per the sticky post?

How do I

> generate a verbose X log?

Why this

> before generating the bug report?

There is no *bug* except the wrong screen. So will there be a system event that can be logged?

I generated nvidia-bug-report.log from the console while VMWare Workstation was running fullscreen on X.

Does nvidia-bug-report.log contain /var/log/Xorg.0.log?

Thanks for your help!

Michael
Attached Files
File Type: log Xorg.0.log (25.4 KB, 90 views)
MLeimann is offline   Reply With Quote
Old 07-03-07, 01:17 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Fullscreen problem in text mode

No, that's still not correct. Please start X with the following command:
startx -- -logverbose 6

reproduce the problem, then generate a new bug report.
netllama is offline   Reply With Quote
Old 07-03-07, 01:32 PM   #7
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

So let me see. I followed this instruction

----- quote -----
a) Please always include a copy of an nvidia-bug-report.log file, which can be generated with the `nvidia-bug-report.sh` script shipped with the NVIDIA Linux/FreeBSD graphics drivers and installed in your PATH; the log file will be placed in the current working directory. To make sure this log file includes as much relevant information as possible, please start the X server with `startx -- -logverbose 6` and run `nvidia-bug-report.sh` after the problem has occurred. If X can not be started or the machine appears to have crashed, please check if you can log into it remotely (e.g. via ssh or telnet) and run `nvidia-bug-report.sh` in the remote shell, if possible. If the machine can not be logged into remotely, please run the bug report script with X running (this will ensure that data points only available when the device is initialized, such as the VBIOS revision, are captured in the log file).
----- unquote -----

As you can see, I learn a bit every day ;-).

Hope this is better now.

Thanks!

Michael
Attached Files
File Type: log Xorg.0.log (106.5 KB, 78 views)
MLeimann is offline   Reply With Quote
Old 07-03-07, 01:34 PM   #8
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

And here the rest (filesize limit).
Attached Files
File Type: zip nvidia-bug-report.zip (35.3 KB, 88 views)
MLeimann is offline   Reply With Quote

Old 07-03-07, 01:41 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Fullscreen problem in text mode

The issue here is that VMWare is requesting an 800x512 mode:
(II) NVIDIA(0): Setting mode "800x512"

but the only available 800x512 mode in the modepool is a doublescan mode, which is basically getting treated as an interlaced mode.

The only way to work around this is to add the following to the Device section of xorg.conf:
Option "ModeValidation" "NoXServerModes"
netllama is offline   Reply With Quote
Old 07-03-07, 02:07 PM   #10
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

Ok, that works! Fine.

Is VMWare Workstation requesting the same mode when using

Section "Device"
Driver "nv"?

I do not yet understand the difference. Why is there no problem with Driver "nv"? (see attached files)

Thanks

Michael
Attached Files
File Type: zip nvidia-bug-report.zip (29.5 KB, 88 views)
File Type: log Xorg.0.log (38.8 KB, 92 views)
MLeimann is offline   Reply With Quote
Old 07-03-07, 02:18 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Fullscreen problem in text mode

With the 'nv' driver all I see is a request for an 800x600 mode, never 800x512. 800x512 fails to get validated:
(II) NV(0): Not using default mode "800x512" (bad mode clock/interlace/doublescan)
netllama is offline   Reply With Quote
Old 07-03-07, 02:25 PM   #12
MLeimann
Registered User
 
Join Date: Jul 2007
Posts: 7
Default Re: Fullscreen problem in text mode

Well done! Thank you very much for your help.

Have a nice day!

Michael
MLeimann is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 11:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.