Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-07-07, 06:23 AM   #1
robvdl
Registered User
 
Join Date: Aug 2007
Posts: 2
Unhappy NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Hi, I am posting this bug here, because I don't know where else to, and believe this bug has been around for far too long now. I have noticed this bug appear ever since the release of the 9xxx Linux drivers, and it has been there in every subsequent release thereafter. The bug still exists in the latest 100.14.11 drivers.

Ok, so first of all, here are some things I have observed:

I use Ubuntu, the refresh rate used to read properly when you go to "System->Preferences->Screen Resolution" with the older 8xxx drivers on Dapper. It used to read something like 85Hz, and my monitor itself would confirm this too.

As soon as I started using the 9xxx drivers (this was still on Dapper at the time), my monitor itself would properly read it was running at 85Hz, but when opening "System->Preferences->Screen Resolution", it started reading the wrong refresh rate of 50hz.

I have observed this bug on a number of different machines, and on the following cards: GeForce FX 5600, GeForce FX 5200, GeForce 7600 GS AGP, GeForce 7950 GT, and onboard GeForce 6100 on the NForce 430 based boards, so it definitely seems to happen on a wide range, possibly all GeForce based cards.

I have observed this bug on the binary NVidia drivers since the 9xxx series, in Dapper with a custom kernel module compiled, the binary driver in the Ubuntu Edgy repository, the binary driver in the Ubuntu Feisty repository, and even on the latest 100.14.11 drivers with a plain vanilla kernel, compiled from source. Which indicates to me the problem is most definitely with the NVidia drivers, and not Ubuntu.

The reason why this bug is so annoying, is because if you run the Beryl or Compiz Fusion 3D desktop, everything is very jumpy, as Compiz thinks the monitor is running at 50hz, so tries to sync to that framerate. Off course you can fix this by unticking "detect refresh rate" in Compiz, but not everybody would know this.

Come'on NVidia, fix this bug please, it's been broken for far too long now.

Attached is a screenshot that shows the NVidia control panel reading 60Hz for my digital flat panel, but the screen resolution applet reading 50hz. This is using the latest 100.14.11 drivers. Note that Compiz also detects 50hz, so it's not just the "screen resoltion" applet doing it.
Attached Thumbnails
Click image for larger version

Name:	nvidia_refresh_bug.jpg
Views:	430
Size:	131.6 KB
ID:	27109  

Last edited by robvdl; 08-07-07 at 06:36 AM. Reason: Added a screenshot
robvdl is offline   Reply With Quote
Old 08-07-07, 06:45 AM   #2
rakshasa
Registered User
 
Join Date: Dec 2005
Posts: 8
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

I've got basically the same problem, except; My computer is connected to the vga-in of the 27" Samsung lcd-tv, and when using any drivers 9xxx+ the refresh rate is 54hz. And the refresh really _is_ 54hz considering the flickering, so it's not just a problem in refresh rate reporting.

Using 8xxx drivers the refresh rate is 60hz and the flickering goes away. I haven't touched the xorg configuration, so the display mode is set to 1360x768_60. I've tried to use different modelines, but using them renders the 1360x768 resolution unusable by the xserver and forces the use of 1024x768 mode.
rakshasa is offline   Reply With Quote
Old 08-07-07, 07:07 AM   #3
robvdl
Registered User
 
Join Date: Aug 2007
Posts: 2
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Oh! I found a solution here http://ubuntuforums.org/showthread.php?p=1557092 to fix, I had to add Option "DynamicTwinView" "False" to my xorg.conf file. Makes me wonder why all those tutorials I find around the net on "how to install nvidia driver in ubuntu" fail to mention this, even though it seems like quite a critical setting. I am just wondering though, should the NVidia drivers not return the correct refresh rate, regarding of this setting?
robvdl is offline   Reply With Quote
Old 08-07-07, 08:26 AM   #4
rakshasa
Registered User
 
Join Date: Dec 2005
Posts: 8
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Hey, thanks a bunch robvdl, that fixed my little problem too. ^^
rakshasa is offline   Reply With Quote
Old 08-07-07, 10:28 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Also see the driver README's discussion of DynamicTwinview which explains this behavior and why its expected.
netllama is offline   Reply With Quote
Old 08-09-07, 05:00 PM   #6
DebianCoder
Registered User
 
Join Date: Jul 2007
Posts: 14
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Quote:
Originally Posted by netllama
Also see the driver README's discussion of DynamicTwinview which explains this behavior and why its expected.
This hack is bad. Most people do not have two monitors. The default should be FALSE without user intervention in xorg.conf.

Monitor modes are one of the most critical settings in xorg.conf and playing with them like this is just extremely bad. Those who need fancy dual- or multi-monitor setups should be the ones who need to fiddle, not everyone else.
DebianCoder is offline   Reply With Quote
Old 08-09-07, 05:04 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

The DynamicTwinview option is not specific to using multiple display devices. As I recommended earlier, please see the driver README for more information (or search this forum, as this topic has been discussed many times in the past).
netllama is offline   Reply With Quote
Old 08-09-07, 05:19 PM   #8
DebianCoder
Registered User
 
Join Date: Jul 2007
Posts: 14
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Then the option is misnamed.

Users do not want, and should not be asked, to become xorg.conf and nVidia News Forum experts. Many things have been discussed before - but even I get confused by all the nVidia developments and options. And I am a developer. So in short you expect too much of users.

The defaults in the driver should be sensible for "most" users, not developers.
DebianCoder is offline   Reply With Quote

Old 08-09-07, 05:23 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

I'm sorry that you feel that way, however the overwhelming majority of NVIDIA customers are quite pleased with the DynamicTwinview option.

I regret that you're in the small minority that dislike this option. You can certainly disable it at your convenience.

I have nothing further to add on this topic.
netllama is offline   Reply With Quote
Old 08-09-07, 05:30 PM   #10
Dr. Tyrell
Registered User
 
Dr. Tyrell's Avatar
 
Join Date: Aug 2004
Posts: 100
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

To NVidia:
Thanks for this and the growing number of options.

Satisfied so far,
The Doctor
__________________
P7811-FX | Nvidia 9800M GTS 512MB DDR3 | 17" 1920x1200 | Centrino2 P8400 | 4GB DDR3 | 2x320Gb 7200RPM RAID 0 | DVD+-/DL
Dr. Tyrell is offline   Reply With Quote
Old 08-09-07, 07:53 PM   #11
DebianCoder
Registered User
 
Join Date: Jul 2007
Posts: 14
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Quote:
Originally Posted by netllama
I'm sorry that you feel that way, however the overwhelming majority of NVIDIA customers are quite pleased with the DynamicTwinview option.

I regret that you're in the small minority that dislike this option. You can certainly disable it at your convenience.

I have nothing further to add on this topic.
That's too much psychology (I do not "feel" anything, I made a rational point of business success) and wrong (everyone enjoys features). Saying defaults should make sense for the majority of average users is helping that majority. People who need to activate special configurations can become xorg.conf and nVidia news forum experts.

Average users should not be asked to decipher weird sub-options. They only need their one monitor to function and report correct values to GNOME/KDE. How does an average person make sense of these two options with almost identical names but different defaults?

1.0-9639

Quote:
Originally Posted by nVidia
Option "TwinView" "boolean"

Default: off (TwinView is disabled).

Option "DynamicTwinView" "boolean"

Default: DynamicTwinView is enabled.
DebianCoder is offline   Reply With Quote
Old 08-10-07, 03:59 AM   #12
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: NVidia binary driver wrongly has been displaying 50Hz since 9xxx drivers

Quote:
Originally Posted by DebianCoder
They only need their one monitor to function and report correct values to GNOME/KDE.
Why do they need that exactly? Why does an average user need to know the refresh rate of their monitor? And even if they do need to know, they don't have to become xorg.conf experts, they just need to open nvidia-settings, the correct rate is printed there.

Think about it this way: before, users needed to be xorg.conf experts if they wanted to plug in their TV and watch a movie on it. Now, they just plug the TV in and DinamicTwinView will do its thing. It's definitely better for this to be on by default.
Gusar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 06:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.