Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-06-07, 12:39 PM   #1
HamRadio
Linux user #291116
 
Join Date: Mar 2007
Location: Italy
Posts: 8
Default No tv-out before X

Hi,

I have a Nvidia GeForce FX 5200 graphic card in a media center pc (Debian Etch amd64, official kernel, nvidia drivers 100.14.11) where the only display is the tv set connected to the s-video out.

The problem is that when I turn on the pc nothing is displayed on the tv until X is started, when the nvidia drivers are loaded. So I can't see the bios screen, I can't enter the bios setup, I can't see the text console in Linux and I don't know what's happening if for some reason X can't be started (perhaps when e2fsck is checking my filesystems..).

Actually in file /usr/share/doc/NVIDIA_GLX-1.0/html/chapter-16.html
I can read:
"If a TV is the only display device connected to your graphics card, it will be used as the primary display when you boot your system (i.e. the console will come up on the TV just as if it were a CRT)."
This is not true for me...

I've tried adding one 75 ohm resistor in parallel with the luminance out and another one with the chrominance out, just to be sure that the output were correctly terminated (and perhaps the tv-out recognized at boot time) but the problem remains.

I don't want to add a vga monitor every time I need to see the bios and/or the console.

Is there a way to enable tv-out for all the video modes, just as the vga out normally does?
Perhaps changing/hacking the videocard bios?
Maybe is there some option that I can pass to modprobe when loading nvidia module so that at least I can see the console (entering the bios is less frequently needed)?

Thanks for answering.
HamRadio is offline   Reply With Quote
Old 07-06-07, 01:50 PM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: No tv-out before X

Back when I had an FX5200 card with TV-out this worked OK. Until the X server was started, the TV just showed the same picture as on the VGA monitor.
I should say I always had the monitor connected. Did you try connecting a VGA monitor and is there no TV picture in this case either?
pe1chl is offline   Reply With Quote
Old 07-07-07, 12:59 AM   #3
HamRadio
Linux user #291116
 
Join Date: Mar 2007
Location: Italy
Posts: 8
Default Re: No tv-out before X

Quote:
Originally Posted by pe1chl
Did you try connecting a VGA monitor and is there no TV picture in this case either?
Yes, I did.
All the installation and setup of the media center has been made with both a vga monitor and a tv set connected.
HamRadio is offline   Reply With Quote
Old 07-07-07, 03:28 AM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: No tv-out before X

Hmmm that is the case that worked OK for me. I used composite out, but even if there is a problem with S-Video you should at least have a B/W picture.
Of course it is all determined by the video card BIOS, not the driver. However, I have never seen a video card BIOS with a SETUP section where you would be able to change an option like this.
pe1chl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.