Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-12-07, 08:34 PM   #1
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default TwinView & Ubuntu - bad DFP display

I used nvidia-settings to configure xorg.conf with the two displays of my
Quadro2 MXR/EX/Go on two different desktops.

The two displays have been detected, I restarted the X-Window server
but the DFP display is ugly. It's like if it was using a different color depth
for the DFP display.

I installed Ubuntu yesterday on a WindowsXP desktop, both displays
were working fine under Windows XP before the Ubuntu installation.

First installation a couple of weeks ago showed the same
problem. On both desktops the restricted nvidia driver has been used.

Searches in various forums and attempts to apply found recipes on the
first desktop did not solve the issue.

The first desktop had hardware options swapped in/out, we did the
installation on a proven configuration yesterday,
everything was working under Windows XP.

What's wrong here ? Is this card supported properly or not ? Is there an
option I should enable ?


Any ideas ? The second display is unusable...
Attached Files
File Type: log nvidia-bug-report.log (87.2 KB, 72 views)
File Type: txt xorg.conf.txt (2.0 KB, 110 views)
lprefontaine is offline   Reply With Quote
Old 07-12-07, 08:43 PM   #2
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default Re: TwinView & Ubuntu - bad DFP display

Forgot to add the xorg0.log file in the previous post...
Attached Files
File Type: log Xorg.0.log (21.0 KB, 93 views)
lprefontaine is offline   Reply With Quote
Old 07-12-07, 10:25 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: TwinView & Ubuntu - bad DFP display

If this problem persists with 1.0-9639, please start X with the following command:
startx -- -logverbose 6

and then generate and attach a new bug report.

thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-17-07, 12:19 AM   #4
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default Re: TwinView & Ubuntu - bad DFP display

I update to 1.0-9639, restarted the system and no changes.

Here are the bug report and the Xorg log file.

Too bad I cannot take a picture of the screen and post it somewehre.
It almost feels like if it was
using shades of gray except that the grey has been replaced by the
color of the default ubuntu desktop background (kind of brown).
The grading is also not too good looking, it looks like a coarsed grain picture.

Any idea ?

Thank you,

Luc
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.2 KB, 80 views)
File Type: gz Xorg.0.log.gz (18.1 KB, 81 views)
lprefontaine is offline   Reply With Quote
Old 07-17-07, 10:11 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: TwinView & Ubuntu - bad DFP display

I don't see much in your bug report that would suggest that this is a driver problem.

Is there a reason why you're requesting a "1600x1200" mode when all of your metamodes are 1280x1024 or smaller?

Is this problem only present when using Twinview?
netllama is offline   Reply With Quote
Old 07-17-07, 03:07 PM   #6
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default Re: TwinView & Ubuntu - bad DFP display

I am not asking for a 1600x1200 mode as far as I know.

Using nvidia-settings, I asked for a resolution of 1280x1024 for each
display.

According to the screen resolution panel in gnome, I currently use 2560x1024.
This fits the resolution chosen in nvidia-settings (1280x1024 for both displays).

The resolution choices available are the following:

2560x1024
2432x1024
2304x1024

....

And that fits what is shown in nvidia-settings (for both displays).

1600x1200 does not fit at all with what is visible about the configuration.

Is there a glitch between gdm and the driver about the display sizes ?
That could explain the odd look.

We tried to use two different X screens and we had the same problem.

Any idea where that wrong mode request comes from ?
lprefontaine is offline   Reply With Quote
Old 07-17-07, 03:10 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: TwinView & Ubuntu - bad DFP display

1600x1200 is explicitly requested in the xorg.conf in the bug report that you provided. I'd suggest removing it if you're not interested in using that mode.

Does this problem persist if you're only using the DFP (a single display)?
netllama is offline   Reply With Quote
Old 07-17-07, 05:26 PM   #8
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default Re: TwinView & Ubuntu - bad DFP display

I edited the xorg.conf file to remove the 1600x1200 mode. Looks
like it has been added by nvidia-settings.

I used nvidia-settings to disable CRT-0 and applied the change
and yes the DFP display is messed up in the same fashion.

lprefontaine is offline   Reply With Quote

Old 07-17-07, 06:00 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: TwinView & Ubuntu - bad DFP display

I'd like to see another verbose bug report generated with this configuration.
netllama is offline   Reply With Quote
Old 07-19-07, 07:28 PM   #10
lprefontaine
Registered User
 
Join Date: Jul 2007
Posts: 6
Default Re: TwinView & Ubuntu - bad DFP display

Here' s the bug report. I could not restart X with only the DFP display enabled.
The configuration reverts to twinview. Looks like CRT-0 is required at all times.

I forgot to mention, we also tried with Suse 10 on the first desktop and had the same behavior.
I cannot remember the driver version but it was 1-0.96xx.

Initially I suspected the hardware but now we are working on untouched
hardware that was working under Windows XP just before installing
Ubuntu. (I was about to say that the desktop was working well under
XP... gulp, the system is 2-3 times faster with Ubuntu ).
Attached Files
File Type: gz nvidia-bug-report.log.gz (26.8 KB, 78 views)
lprefontaine is offline   Reply With Quote
Old 07-19-07, 08:37 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: TwinView & Ubuntu - bad DFP display

I'm afraid I don't understand what you mean by "the configuration reverts to twinview". There's nothing in the nvidia driver that would cause this behavior.

I'll need to see a bug report without Twinview.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 02:20 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 09:52 AM

All times are GMT -5. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.