Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-15-07, 02:52 AM   #1
ppd
Registered User
 
Join Date: Jan 2006
Posts: 6
Default console stays blank after resume

Hi,

I've got a "little" problem with 100.14.11 on ubuntu feisty on a asus z53t notebook with a Geforce Go 7600. Whenever I do a suspend/resume cycle on that notebook the consoles all stay blank and so cannot be used anymore. However the XServer ist still fully functional and does remain functional even if restarted.

Do you have any suggestions or hints?

Greetings

ppd
ppd is offline   Reply With Quote
Old 07-15-07, 03:59 AM   #2
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: console stays blank after resume

could be related to this: http://www.nvnews.net/vbulletin/showthread.php?t=94247
Dragoran is offline   Reply With Quote
Old 07-15-07, 07:33 AM   #3
ppd
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: console stays blank after resume

Thanks for the answer. Seems like there's no solution yet.

ppd
ppd is offline   Reply With Quote
Old 07-31-07, 10:01 AM   #4
David Dumas
Registered User
 
Join Date: Oct 2004
Posts: 3
Default Re: console stays blank after resume

I have a similar problem with my system:

Dell Latitude D630
Quadro NVS 135M
Debian unstable / i386 2.6.22 kernel
Nvidia driver 100.14.11

After a suspend to RAM, all of the VTs are blank, though Xorg works fine. Ctrl-Alt-F1 still switches to a text-mode display, but all I see is a cursor in the upper left corner. (The VTs are also unresponsive to keyboard input, it isn't just that the display is blank and everything else is "working".)

This also seems to make a complete shutdown impossible. Running "shutdown now -h" as root results in power-off if the system has not been suspended since the last boot, but otherwise the system hangs during the shutdown process, just after Xorg is terminated.

I also think this may be unrelated to the problem from thread 94247, because X restarts fine on my system, and the problem is not affected by NVreg_SaveVBios=1.

I have not seen any errors in the Xorg log file or syslog related to the nvidia driver.

Is there a separate nvidia internal bug report about this? (Separate from the "X fails to restart after suspend" problem, which I don't have, and the "2D rendering slowdown on suspend" problem, which I do have.)
David Dumas is offline   Reply With Quote
Old 08-13-07, 08:28 PM   #5
David Dumas
Registered User
 
Join Date: Oct 2004
Posts: 3
Default Re: console stays blank after resume

Anyone still experiencing the blank console problem? (bumping this thread)

It would also be nice to know if some people with 7- or 8-series mobile GPUs and 100.14.11 are not having this problem.
David Dumas is offline   Reply With Quote
Old 09-14-07, 11:38 AM   #6
psYchotic
Registered User
 
Join Date: Sep 2007
Posts: 2
Default Re: console stays blank after resume

Quote:
Anyone still experiencing the blank console problem? (bumping this thread)

It would also be nice to know if some people with 7- or 8-series mobile GPUs and 100.14.11 are not having this problem.
I have a Go 7600, and I also have this exact same problem. I've tried the 1.0-9755 and the 100.14.11 versions, neither of which give me a usable text console after resuming from a suspend
psYchotic is offline   Reply With Quote
Old 09-19-07, 04:40 AM   #7
lech
Registered User
 
Join Date: Sep 2007
Posts: 4
Unhappy Re: console stays blank after resume

Driver 100.14.19 does not solve this problem on my T61p, Quadro FX 570 M.
lech is offline   Reply With Quote
Old 09-19-07, 12:21 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: console stays blank after resume

Please see http://www.nvnews.net/vbulletin/show...8&postcount=34; the problem you are seeing may be related.
zander is offline   Reply With Quote

Old 09-23-07, 04:38 PM   #9
David Dumas
Registered User
 
Join Date: Oct 2004
Posts: 3
Default Re: console stays blank after resume

Upgrading to driver 100.14.19 fixed the problem for me (D630 / NVS 135m).

Now the virtual consoles continue to work after suspend, and furthermore, I no longer need the "double VT switch". (Previously, the screen was full of colorful garbage after the initial resume, and it was necessary to attempt to switch to a VT and back in order to restore graphics.)

As for the suggestion,
Quote:
Originally Posted by zander
Please see http://www.nvnews.net/vbulletin/show...8&postcount=34; the problem you are seeing may be related.
I made sure that vbetool was never called even before the upgrade to 100.14.19. My problem was not caused by an attempt to POST the video hardware.
David Dumas is offline   Reply With Quote
Old 09-24-07, 05:09 AM   #10
psYchotic
Registered User
 
Join Date: Sep 2007
Posts: 2
Default Re: console stays blank after resume

Quote:
Originally Posted by David Dumas
Upgrading to driver 100.14.19 fixed the problem for me (D630 / NVS 135m).

Now the virtual consoles continue to work after suspend, and furthermore, I no longer need the "double VT switch". (Previously, the screen was full of colorful garbage after the initial resume, and it was necessary to attempt to switch to a VT and back in order to restore graphics.)

As for the suggestion,

I made sure that vbetool was never called even before the upgrade to 100.14.19. My problem was not caused by an attempt to POST the video hardware.
I confirm this. My problems appear to have been fixed with 100.14.19.
Thanks a lot
psYchotic is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
BUG 302.17 - can not access TTY console legluondunet NVIDIA Linux 9 06-24-12 05:16 PM
Console Killers News Archived News Items 0 06-11-12 10:10 PM
295.53: Consoles turn blank (regression) blubb NVIDIA Linux 5 05-24-12 09:32 AM
NVS3100 (Thinkpad T410) blank screen on resume NvFuchs NVIDIA Linux 2 05-15-12 01:02 PM

All times are GMT -5. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.