Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-19-07, 01:07 PM   #1
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Slackware 12 + 7800 Go GTX Blank Screen

Hi, I recently installed a fresh copy of Slackware 12 on my laptop (Hypersonic FX7), and I've been having issues with getting the video drivers to work.

The problem is that when I attempt to startX with an xorg.conf using an nvidia driver all I get is a blank screen. To be more specific, I type "startx", the screen goes completely black as if turned off, 2 seconds later it brightens up a slight bit (as if you just turned on the laptop) and remains that way.

*Technically* the Xserver is working fine (I guess) since I can move my mouse to the bottom corner to the K menu, move the mouse a bit up (...) and log off KDE. But again, the entire screen is effectively blank (KDE plays the start up tune as well as if nothing is wrong).

I've done my research, The nvidia blank screen issue seems to go around, with various different solutions, (which I've tried myself to no avail). I've installed various different drivers (100.14.11, 97xx, 7xxx...). Always the same issue.

I've gone through X's logs, and I don't see anything particularly wrong. The only concern that I have is that the DFP pixel clock might be a bit high (300 MHz). From what I read it should be in the 150s? I tried to turn off the auto detection of the clock and to supply my own value, but couldn't figure out how.

One additional note: I'm attaching 2 bug reports, one for startx and another for startxfce4. The reason being I think I screwed up my installation of KDE since I tried to update QT from 3 to 4 (when I start KDE with the nv driver I get a motif like dialog box that tells me something about KDEinit failing. Getting KDE to work is not a priority for the moment, but the nvidia drivers are.). XFCE works, which is what I've been using for the past week

Please help?

--Jon
Attached Files
File Type: log startx_nvidia-bug-report.log (110.9 KB, 85 views)
File Type: log startxfce4_nvidia-bug-report.log (110.9 KB, 90 views)
jzencovich is offline   Reply With Quote
Old 07-19-07, 01:12 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Please see http://www.nvnews.net/vbulletin/showthread.php?t=46678.
zander is offline   Reply With Quote
Old 07-19-07, 01:22 PM   #3
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Thanks Zander for the quick reply! I have seen that post already. If you referring to the fact that the bug reports weren't attached, I apologize. I thought I attached them, but I clicked on "close" before clicking on "upload". I just realized that >_>

Otherwise, is there something else that you're hinting at?
jzencovich is offline   Reply With Quote
Old 07-19-07, 01:33 PM   #4
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Additional info: the xorg.conf I've been using for the most part are those generated completely by the nvidia config. Meaning I delete my working nv xorg.conf and generate a new one with nvidia-xconfig. Generating an nvidia xconf on top of a working nv or vesa xconf makes no difference anyways.

Feel free to ask questions!
jzencovich is offline   Reply With Quote
Old 07-20-07, 09:47 AM   #5
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Just a friendly bump, this problem has been annoying the hell outta me for the past few weeks
jzencovich is offline   Reply With Quote
Old 07-21-07, 11:56 AM   #6
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Just an update:

Initially I didn't take a look at the stability issues thread, since I did not believe it applies to me (since the display is blank, it doesn't work 100% of the time ). However, last night I gave it a look and read some interesting things that applied to smp kernel owners (me ).

I tried both kernel parameter suggestions (pci=nommconf and idle=poll), but neither made a difference

Just some additional info on my system: I have a dual core (amd; FX 60) processor and I'm using a 2.6.21.5-smp kernel, a single 7800 GTX Go and ... gcc 4.1.2 if that makes any difference.

I've tried really hard to solve this issue on my own. Any hepl whatsoever would be appreciated, even a point to some other thread that may help.

Jon
jzencovich is offline   Reply With Quote
Old 07-23-07, 03:34 PM   #7
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Just another friendly bump, lest this thread be buried and forgotten

Can no one give me any advice or help?
jzencovich is offline   Reply With Quote
Old 07-27-07, 11:23 PM   #8
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

bump
jzencovich is offline   Reply With Quote

Old 08-06-07, 08:39 PM   #9
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

I've stopped monitoring this thread for a couple days now. Any reason at why I'm not getting any constructive replies and find myself replying to my own thread just to resuscitate it a bit?

If "someone" is working on my issue but needs more time, then that's cool just say something! Otherwise, it's as if this is an invisible thread that only I can see.


I apologize if it seems that I am whining, it's just it's frustrating how I have an amazing video card that I paid a good price for... and I can't even fully use it! Sure I have 2 drawing via nv drivers, but I want some 3d drivers!

::sigh::

Anyone, please?


-------------------


A little update, I've tried several Live CDs (lastly Sabayon, which supposedly just "works", haven't tried Ubuntu, not interested in it), and none of them have been able to get the screen working after installing the latest drivers. Even Sabayon which comes with the latest drivers by default just boots to a blank screen.

Not the OSes fault, I assume the issue lies between.... I dunno. The Windows drivers worked when I used Windows (XP). Ideas?
jzencovich is offline   Reply With Quote
Old 08-06-07, 09:31 PM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Please generate a verbose bug report.
AaronP is offline   Reply With Quote
Old 08-07-07, 12:44 PM   #11
jzencovich
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Thanks Aaron for the reply, I generated a new bug report log, grabbed it from tty4 while X was running.

I got KDE running again (reverted from QT4 to 3), so the ignore the above reports. The log attached to this post is the one to be used. I used "startx -- -logverbose 6" as per http://www.nvnews.net/vbulletin/showthread.php?t=46678 states.

Thanks Aaron for the reply, it really means a lot to me.
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (32.6 KB, 79 views)
jzencovich is offline   Reply With Quote
Old 08-07-07, 03:35 PM   #12
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Slackware 12 + 7800 Go GTX Blank Screen

Try adding Option "ModeValidation" "NoVertRefreshCheck" and/or Option "UseEdidFreqs" "False" to xorg.conf.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Product Spotlight ' EVGA GTX 670 Review Round Up News GeForce GTX 670 Reviews 1 05-11-12 12:15 AM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
GALAXY Launches the GeForce GTX 670 and GTX 670 GC! News Archived News Items 0 05-10-12 09:28 AM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM

All times are GMT -5. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.