Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-22-07, 09:03 AM   #1
mistercool
Registered User
 
Join Date: Jan 2005
Posts: 5
Default low resolution on twinview DFP-0 under 100.14.11

Hi all;
I'm running two Samsung SyncMaster 204B's on an FX 5700LE;
on Fedora 6 using drivers from livna repository.

Both monitors work fine at 1600x1200 (giving virtual 3200x1200) using the
9762 driver (kernel 2.6.20-1.2952). Ugrading to the 100.14.11 driver (w/ kernel
2.6.20-1.2962) only turns on one monitor (CRT-0). Running nvidia-settings
shows the DFP-0 as off; trying to turn it on only gives me an option of 1280x1024
resolution! The only clue in the log is that it says
Virtual screen size determined to be 1600 x 1200
instead of 3200 x 1200, but no clues as to _why_.

I tried grabbing the edid.bin while under 9762 and using it under 100.14.11, but
that didn't help: nvidia-setting's "Flat Panel Information" shows everything as Unknown,
but the log doesn't give any error messages about the edid.

I'm stumped.

I've attached the conf, and logs under each driver.
Thanks;
Attached Files
File Type: gz xorg.conf.gz (931 Bytes, 82 views)
File Type: gz Xorg.0.log-9762.gz (4.1 KB, 83 views)
File Type: gz Xorg.0.log-100.14.11.gz (4.1 KB, 70 views)
mistercool is offline   Reply With Quote
Old 07-22-07, 11:08 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: low resolution on twinview DFP-0 under 100.14.11

Please see the forum sticky posts.
netllama is offline   Reply With Quote
Old 07-22-07, 12:25 PM   #3
mistercool
Registered User
 
Join Date: Jan 2005
Posts: 5
Default Re: low resolution on twinview DFP-0 under 100.14.11

Quote:
Originally Posted by netllama
Please see the forum sticky posts.
OK, after re-rereading the sticky posts, I guess what you're after is
the official bug report... Attached!
Attached Files
File Type: gz nvidia-bug-report.log.gz (20.2 KB, 93 views)
mistercool is offline   Reply With Quote
Old 07-22-07, 04:56 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: low resolution on twinview DFP-0 under 100.14.11

According to your bug report, both displays are using 1600x1200.
netllama is offline   Reply With Quote
Old 07-22-07, 10:02 PM   #5
mistercool
Registered User
 
Join Date: Jan 2005
Posts: 5
Default Re: low resolution on twinview DFP-0 under 100.14.11

Quote:
Originally Posted by netllama
According to your bug report, both displays are using 1600x1200.
You'd think so, wouldn't ya
But actually, the 2nd monitor isn't getting any signal (and also see
"virtual screen size... 1600 x 1200")

When I then run nvidia-settings, it has the two monitors overlapping, DFP-0 is "Off",
and the "Flat Panel Information" shows everything as "Unknown".
If I reposition DFP-0 to the right, and try to turn it on, the highest resolution offered
is 1280x1024. I made another bug report after doing that; perhaps it is
more informative ?

Thanks for looking into this!
Attached Files
File Type: gz nvidia-bug-report.log.gz (20.3 KB, 85 views)
mistercool is offline   Reply With Quote
Old 07-22-07, 10:28 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: low resolution on twinview DFP-0 under 100.14.11

Please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report while this problem is present.
netllama is offline   Reply With Quote
Old 07-23-07, 07:58 AM   #7
mistercool
Registered User
 
Join Date: Jan 2005
Posts: 5
Default Re: low resolution on twinview DFP-0 under 100.14.11

Quote:
Originally Posted by netllama
Please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report while this problem is present.
Damn! I used startx -logverbose=6 before; it didn't complain, but it didn't give the details!

I recreated reports from the (working) 9762, from 100.14.11 with monitor off, and
after turning it on to 1280x1024 (all are attached).
The critical stage seems to be that in 9762, when it's testing the 1600x1200 @ 60Hz
for DFP-0, it ends up saying: "Reduced Blanking enabled to bring Pixel Clock in range"
and accepting that mode as valid. Under 100.14.11 it simply rejects the mode.

This seems to suggest that a tweaked modeline would provide a workaround?
(but I don't know how to create one)
Or, alternatively, use Option "ModeValidation" "NoMaxPClkCheck" ?
Are either of these advisable?
Attached Files
File Type: gz nvidia-bug-report.log-9762.gz (38.4 KB, 80 views)
File Type: gz nvidia-bug-report.log-DFP0-off.gz (38.4 KB, 84 views)
File Type: gz nvidia-bug-report.log-DFP0-lores.gz (38.5 KB, 81 views)
mistercool is offline   Reply With Quote
Old 07-23-07, 09:44 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: low resolution on twinview DFP-0 under 100.14.11

Yes, you'll need to try using this option as a workaround:
Option "ModeValidation" "NoMaxPClkCheck"
netllama is offline   Reply With Quote

Old 07-30-07, 10:52 PM   #9
mistercool
Registered User
 
Join Date: Jan 2005
Posts: 5
Default Re: low resolution on twinview DFP-0 under 100.14.11

Sorry for the delay in retesting this, but for the record;
The NoMaxPClkCheck option gets me back on 2 monitors.

Thanks!
mistercool is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
302.11 driver only allows native resolution settings of laptop DFP darinmiller NVIDIA Linux 2 05-30-12 03:45 PM

All times are GMT -5. The time now is 12:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.