Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-03-03, 02:47 AM   #1
Dark*staR
Registered User
 
Dark*staR's Avatar
 
Join Date: Apr 2003
Location: Connecticut, USA
Posts: 3
Send a message via ICQ to Dark*staR Send a message via AIM to Dark*staR
Default Problem with the new drivers (gentoo)

I cannot get the new drivers to work either. The old 3.x series work fine for me. Anyways I need to get this working so...

here is:
/etc/X11/XF86Config

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "extmod"
Load "dbe"
Load "xtrap"
Load "type1"
Load "speedo"
Load "freetype"
Load "bitmap"
Load "v4l"
EndSection

Section "ServerFlags"
Option "SuspendTime" "0"
Option "StandbyTime" "0"
Option "BlankTime" "0"
Option "OffTime" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/usbmouse"
Option "Buttons" "7"
Option "ZaxisMapping" "6 7"
Option "Resolution" "1152"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
Option "DigitalVibrance" "25"# <i>
#Option "PageFlip" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "NoLogo" # [<bool>]
#Option "Overlay" # [<bool>]
#Option "UBB" # [<bool>]
#Option "Stereo" # <i>
#Option "WindowFlip" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "VideoKey" # <i>
Option "NvAGP" "1"# <i>
#Option "PixmapCacheLines" # <i>
#Option "IgnoreEDID" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ConnectedMonitor" # <str>
#Option "ConnectedMonitors" # <str>
#Option "TVStandard" # <str>
#Option "TVOutFormat" # <str>
Option "RenderAccel" "True"# [<bool>]
#Option "CursorShadow" # [<bool>]
#Option "CursorShadowAlpha" # <i>
#Option "CursorShadowXOffset" # <i>
#Option "CursorShadowYOffset" # <i>
#Option "UseEdidFreqs" # [<bool>]
#Option "FlatPanelProperties" # <str>
#Option "TwinView" # [<bool>]
#Option "TwinViewOrientation" # <str>
#Option "SecondMonitorHorizSync" # <str>
#Option "SecondMonitorVertRefresh" # <str>
#Option "MetaModes" # <str>
#Option "UseInt10Module" # [<bool>]
#Option "SwapReady" # [<bool>]
#Option "NoTwinViewXineramaInfo" # [<bool>]
#Option "NoRenderExtension" # [<bool>]
#Option "UseClipIDs" # [<bool>]
Identifier "Card0"
Driver "nvidia"
VendorName "NVidia"
BoardName "0x0171"
ChipSet "GeForce4 MX 440"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
DefaultFbBpp 32
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Dark*staR is offline   Reply With Quote
Old 04-03-03, 02:48 AM   #2
Dark*staR
Registered User
 
Dark*staR's Avatar
 
Join Date: Apr 2003
Location: Connecticut, USA
Posts: 3
Send a message via ICQ to Dark*staR Send a message via AIM to Dark*staR
Default

and here is my

/var/log/XFree86.0.log

XFree86 Version 4.2.1 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 3 September 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.20-xfs_pre2 i686 [ELF]
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Apr 3 03:22:43 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(WW) The directory "/usr/X11R6/lib/X11/fonts/TrueType/" does not exist.
Entry deleted from font path.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "BlankTime" "0"
(**) Option "StandbyTime" "0"
(**) Option "SuspendTime" "0"
(**) Option "OffTime" "0"
(--) using VT number 7

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1022,700e card 0000,0000 rev 13 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1022,700f card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:04:0: chip 1106,0686 card 1043,8040 rev 40 class 06,01,00 hdr 80
(II) PCI: 00:04:1: chip 1106,0571 card 0000,0000 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:04:2: chip 1106,3038 card 0925,1234 rev 16 class 0c,03,00 hdr 00
(II) PCI: 00:04:3: chip 1106,3038 card 0925,1234 rev 16 class 0c,03,00 hdr 00
(II) PCI: 00:04:4: chip 1106,3057 card 1043,8040 rev 40 class 00,00,00 hdr 00
(II) PCI: 00:09:0: chip 8086,1229 card 0000,0000 rev 01 class 02,00,00 hdr 00
(II) PCI: 00:0b:0: chip 1102,0002 card 1102,8061 rev 07 class 04,01,00 hdr 80
(II) PCI: 00:0b:1: chip 1102,7002 card 1102,0020 rev 07 class 09,80,00 hdr 80
(II) PCI: 01:05:0: chip 10de,0171 card 1043,8007 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xcd000000 - 0xce6fffff (0x1700000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0xcf700000 - 0xdf7fffff (0x10100000) MX[b]
(II) Bus -1: bridge is at (0:4:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:5:0) NVidia 0x0171 rev 163, Mem @ 0xcd000000/24, 0xd0000000/27, 0xcf800000/19, BIOS @ 0xcf7e0000/17
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) Active PCI resource ranges:
[0] -1 0xcc800000 - 0xcc8fffff (0x100000) MX[b]
[1] -1 0xce800000 - 0xce800fff (0x1000) MX[b]
[2] -1 0xdf800000 - 0xdf800fff (0x1000) MX[b]
[3] -1 0xe0000000 - 0xefffffff (0x10000000) MX[b]
[4] -1 0xcf7e0000 - 0xcf7fffff (0x20000) MX[b](B)
[5] -1 0xcf800000 - 0xcf87ffff (0x80000) MX[b](B)
[6] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[b](B)
[7] -1 0xcd000000 - 0xcdffffff (0x1000000) MX[b](B)
[8] -1 0x00009800 - 0x00009807 (0x8) IX[b]
[9] -1 0x0000a000 - 0x0000a01f (0x20) IX[b]
[10] -1 0x0000a400 - 0x0000a41f (0x20) IX[b]
[11] -1 0x0000d000 - 0x0000d01f (0x20) IX[b]
[12] -1 0x0000d400 - 0x0000d41f (0x20) IX[b]
[13] -1 0x0000d800 - 0x0000d80f (0x10) IX[b]
[14] -1 0x0000e000 - 0x0000e003 (0x4) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xcc800000 - 0xcc8fffff (0x100000) MX[b]
[1] -1 0xce800000 - 0xce800fff (0x1000) MX[b]
[2] -1 0xdf800000 - 0xdf800fff (0x1000) MX[b]
[3] -1 0xe0000000 - 0xefffffff (0x10000000) MX[b]
[4] -1 0xcf7e0000 - 0xcf7fffff (0x20000) MX[b](B)
[5] -1 0xcf800000 - 0xcf87ffff (0x80000) MX[b](B)
[6] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[b](B)
[7] -1 0xcd000000 - 0xcdffffff (0x1000000) MX[b](B)
[8] -1 0x00009800 - 0x00009807 (0x8) IX[b]
[9] -1 0x0000a000 - 0x0000a01f (0x20) IX[b]
[10] -1 0x0000a400 - 0x0000a41f (0x20) IX[b]
[11] -1 0x0000d000 - 0x0000d01f (0x20) IX[b]
[12] -1 0x0000d400 - 0x0000d41f (0x20) IX[b]
[13] -1 0x0000d800 - 0x0000d80f (0x10) IX[b]
[14] -1 0x0000e000 - 0x0000e003 (0x4) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xcc800000 - 0xcc8fffff (0x100000) MX[b]
[6] -1 0xce800000 - 0xce800fff (0x1000) MX[b]
[7] -1 0xdf800000 - 0xdf800fff (0x1000) MX[b]
[8] -1 0xe0000000 - 0xefffffff (0x10000000) MX[b]
[9] -1 0xcf7e0000 - 0xcf7fffff (0x20000) MX[b](B)
[10] -1 0xcf800000 - 0xcf87ffff (0x80000) MX[b](B)
[11] -1 0xd0000000 - 0xd7ffffff (0x8000000) MX[b](B)
[12] -1 0xcd000000 - 0xcdffffff (0x1000000) MX[b](B)
[13] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0x00009800 - 0x00009807 (0x8) IX[b]
[16] -1 0x0000a000 - 0x0000a01f (0x20) IX[b]
[17] -1 0x0000a400 - 0x0000a41f (0x20) IX[b]
[18] -1 0x0000d000 - 0x0000d01f (0x20) IX[b]
[19] -1 0x0000d400 - 0x0000d41f (0x20) IX[b]
[20] -1 0x0000d800 - 0x0000d80f (0x10) IX[b]
[21] -1 0x0000e000 - 0x0000e003 (0x4) IX[b]
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4349
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "xtrap"
(II) Loading /usr/X11R6/lib/modules/extensions/libxtrap.a
(II) Module xtrap: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DEC-XTRAP
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Speedo
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.1.10
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font FreeType
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4349
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver 1.0-4349 Thu Mar 27 19:02:58 PST 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:05:0
(WW) NVIDIA: Chipset "GeForce4 MX 440" in Device section "Card0" isn't valid for this driver
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

I dunno what to make of this since my card is in fact a GeForce4 MX 400......
Dark*staR is offline   Reply With Quote
Old 04-03-03, 02:58 AM   #3
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Are you sure your card is at PCI:1:5:0? The "Chipset" message appears because "Chipset" isn't a valid keyword for the nvidia dirver.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-03-03, 03:01 AM   #4
Dark*staR
Registered User
 
Dark*staR's Avatar
 
Join Date: Apr 2003
Location: Connecticut, USA
Posts: 3
Send a message via ICQ to Dark*staR Send a message via AIM to Dark*staR
Default

I'm going to remove that line and see what happens...I am positive that it is 1:5:0....officially its 01:05:0 but it doesnt matter...it worked either way since forever.....
Dark*staR is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Problem with geforce2 mx 400 and the drivers Cloral NVIDIA Windows Graphics Drivers 23 08-28-02 01:25 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 10:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.