Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-07, 09:17 AM   #1
extensive2
Guest
 
Posts: n/a
Default 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Hello,
I have a problem with the second of my two on-board NICs on the Asus M2N-SLI Deluxe (chipset: nForce 750 SLI MCP): It is completely dead after booting Linux.

To reproduce the problem:
1) Power supply off.
2) Power supply on: both NICs get GBit link (LEDs are on).
3) System power on, waiting for GRUB to load: both NICs still have link.
4) Booting kernel: upon loading of forcedeth, both NICs get turned off (LEDs off).
5) somewhat later in the boot sequence: first NIC gets link again, but second link never comes up

This could be reproduced with forcedeth versions 0.56, 0.59 and 0.60, in kernels 2.6.18, 2.6.20 and 2.6.21-rc6 (all amd64). The processor is an Athlon64 X2 5000+. I tried Asus BIOS versions 0404 and 0903.

On some very rare occasions albeit, the second NIC "just worked". Once after cold boot and another time (surprisingly) after unplugging and replugging the network cable. (This was luck. Switching cables between the NICs does not help, usually, the problem stays with the 2nd NIC.)

Maybe another interesting point: when doing
6) reboot: the 2nd NIC stays off, even during initialisation of BIOS
Cold power off is necessary to get the 2nd NIC to work during BIOS initialisation.

Code:
# ethtool -i eth1
driver: forcedeth
version: 0.60
firmware-version:
bus-info: 0000:00:08.0
# ethtool eth1
Settings for eth1:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes
# ethtool -i eth2
driver: forcedeth
version: 0.60
firmware-version:
bus-info: 0000:00:09.0
# ethtool eth2
Settings for eth2:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: Unknown! (65535)
        Duplex: Unknown! (255)
        Port: MII
        PHYAD: 1
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: no        
# ethtool -t eth2
The test result is FAIL
The test extra info:
link      (online/offline)       1
register  (offline)              0
interrupt (offline)              0
loopback  (offline)              0
Help would be greatly appreciated!
Regards,
extensive2
Attached Files
File Type: txt dmesg.txt (35.5 KB, 176 views)
  Reply With Quote
Old 04-12-07, 10:31 AM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

your dmesg & ethtool info is a bit out of sync... (or do you remap the eths?)

dmesg:
eth0: forcedeth.c: subsystem: 01043:8239 bound to 0000:00:08.0
eth1: forcedeth.c: subsystem: 01043:8239 bound to 0000:00:09.0
eth2: (3Com PCI 3c905B Cyclone 100baseTx at ffffc20000026000.)

ethtool:
# ethtool -i eth2
driver: forcedeth
...
# ethtool -i eth1
driver: forcedeth

Anyway, I think you should talk to the forcedeth maintainer... he probably knows what's going on, or has atleast some ideas what ASUS screwed up...
chunkey is offline   Reply With Quote
Old 04-12-07, 11:06 AM   #3
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Indeed, it is remapped by udev:

Code:
# cat /etc/udev/rules.d/z25_persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, probably run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.
# MAC addresses must be written in lowercase.

# PCI device 0x10de:0x0373 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:18:f3:67:88:d1", NAME="eth1"

# PCI device 0x10de:0x0373 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:18:f3:67:97:8f", NAME="eth2"

# PCI device 0x10b7:0x9055 (3c59x)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:50:04:63:51:3f", NAME="eth0"

# PCI device 0x8086:0x107d (e1000)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:15:17:0e:84:df", NAME="eth3"
I added the Intel card as a replacement for the faulty on-board NIC, the problem shows without this card, too. Yet, I can't remember whether I ever tested without the 3com card. Tomorrow I will test again, with both additional network cards removed.

Maintainer: You mean Manfred Spraul? I found his name in forcedeth.c, but he is not listed in MAINTAINERS.
  Reply With Quote
Old 04-12-07, 11:18 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Do these options have any impact?
"options forcedeth msi=0 msix=0"
netllama is offline   Reply With Quote
Old 04-13-07, 05:41 AM   #5
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

I removed the two other NICs, so that there is no remapping being done anymore. Now the system looks like that:
Code:
# lspci
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:09.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:08.0 VGA compatible controller: ATI Technologies Inc 215CT [Mach64 CT] (rev 09)
07:00.0 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (A-Segment Bridge) (rev 09)
07:00.2 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (B-Segment Bridge) (rev 09)
08:04.0 SCSI storage controller: Triones Technologies, Inc. Unknown device 2340 (rev 09)
09:04.0 SCSI storage controller: Triones Technologies, Inc. Unknown device 2340 (rev 09)
And I put msi=0 msix=0 in /etc/initramfs-tools/modules ...
Code:
# cat /etc/initramfs-tools/modules
# List of modules that you want to include in your initramfs.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.

forcedeth msi=0 msix=0
rr2340
... which however did not improve the situation.

I got lucky once after a cold boot (out of approx. ten tries), to have both NICs working. I'm attaching dmesg output of the occasion when both NICs worked and the same for a "normal" occurence, when only the first NIC was working. Both contain full forcedeth debug output, so maybe (hopefully) that will be sufficient to figure out what is going on.
Attached Files
File Type: gz dmesg-working.gz (22.1 KB, 161 views)
File Type: gz dmesg-nonworking.gz (10.6 KB, 162 views)
  Reply With Quote
Old 04-13-07, 07:18 AM   #6
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

ahh, a lspci -v , /proc/interrupts, ... would have been nice.
chunkey is offline   Reply With Quote
Old 04-13-07, 08:03 AM   #7
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Quote:
Originally Posted by chunkey
ahh, a lspci -v , /proc/interrupts, ... would have been nice.
I re-added the intel NIC as eth2. Forcedeth is eth0 and eth1.

Code:
# lspci -v
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0
        Capabilities: [44] HyperTransport: Slave or Primary Interface
        Capabilities: [e0] #00 [fee0]

00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: 66MHz, fast devsel, IRQ 255
        I/O ports at fc00 [size=64]
        I/O ports at 1c00 [size=64]
        I/O ports at 1c40 [size=64]
        Capabilities: [44] Power Management version 2

00:01.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: 66MHz, fast devsel

00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1) (prog-if 10 [OHCI])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
        Memory at fe02f000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2) (prog-if 20 [EHCI])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
        Memory at fe02e000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [44] Debug port
        Capabilities: [80] Power Management version 2

00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1) (prog-if 8a [Master SecP PriP])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
        I/O ports at f000 [size=16]
        Capabilities: [44] Power Management version 2

00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
        I/O ports at 09f0 [size=8]
        I/O ports at 0bf0 [size=4]
        I/O ports at 0970 [size=8]
        I/O ports at 0b70 [size=4]
        I/O ports at dc00 [size=16]
        Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2
        Capabilities: [b0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/2 Enable-
        Capabilities: [cc] HyperTransport: MSI Mapping

00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        I/O ports at 09e0 [size=8]
        I/O ports at 0be0 [size=4]
        I/O ports at 0960 [size=8]
        I/O ports at 0b60 [size=4]
        I/O ports at c800 [size=16]
        Memory at fe02c000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2
        Capabilities: [b0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/2 Enable-
        Capabilities: [cc] HyperTransport: MSI Mapping

00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
        I/O ports at c400 [size=8]
        I/O ports at c000 [size=4]
        I/O ports at bc00 [size=8]
        I/O ports at b800 [size=4]
        I/O ports at b400 [size=16]
        Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2
        Capabilities: [b0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/2 Enable-
        Capabilities: [cc] HyperTransport: MSI Mapping

00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2) (prog-if 01 [Subtractive decode])
        Flags: bus master, 66MHz, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        Memory behind bridge: fb000000-fcffffff
        Prefetchable memory behind bridge: 40000000-400fffff
        Capabilities: [b8] Subsystem: nVidia Corporation Unknown device cb84
        Capabilities: [8c] HyperTransport: MSI Mapping

00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
        Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at b000 [size=8]
        Memory at fe029000 (32-bit, non-prefetchable) [size=256]
        Memory at fe028000 (32-bit, non-prefetchable) [size=16]
        Capabilities: [44] Power Management version 2
        Capabilities: [70] MSI-X: Enable- Mask- TabSize=8
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/3 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping

00:09.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        Memory at fe027000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at ac00 [size=8]
        Memory at fe026000 (32-bit, non-prefetchable) [size=256]
        Memory at fe025000 (32-bit, non-prefetchable) [size=16]
        Capabilities: [44] Power Management version 2
        Capabilities: [70] MSI-X: Enable- Mask- TabSize=8
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/3 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping

00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: fde00000-fdefffff
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
        I/O behind bridge: 00007000-00008fff
        Memory behind bridge: fdd00000-fddfffff
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=07, subordinate=09, sec-latency=0
        I/O behind bridge: 00005000-00006fff
        Memory behind bridge: fd900000-fdcfffff
        Capabilities: [40] Subsystem: nVidia Corporation Unknown device 0000
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [60] HyperTransport: MSI Mapping
        Capabilities: [80] Express Root Port (Slot+) IRQ 0
        Capabilities: [100] Virtual Channel

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
        Flags: fast devsel
        Capabilities: [f0] #0f [0010]

01:08.0 VGA compatible controller: ATI Technologies Inc 215CT [Mach64 CT] (rev 09) (prog-if 00 [VGA])
        Flags: VGA palette snoop, stepping, medium devsel
        Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at 40000000 [disabled] [size=64K]

05:00.0 Ethernet controller: Intel Corporation 82572EI Gigabit Ethernet Controller (rev 06)
        Subsystem: Intel Corporation PRO/1000 PT Server Adapter
        Flags: bus master, fast devsel, latency 0, IRQ 1273
        Memory at fdee0000 (32-bit, non-prefetchable) [size=128K]
        Memory at fdec0000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at 9c00 [size=32]
        Expansion ROM at fdea0000 [disabled] [size=128K]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
        Capabilities: [e0] Express Endpoint IRQ 0
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number df-84-0e-ff-ff-17-15-00

07:00.0 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (A-Segment Bridge) (rev 09) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=07, secondary=08, subordinate=08, sec-latency=32
        I/O behind bridge: 00006000-00006fff
        Memory behind bridge: fdb00000-fdcfffff
        Capabilities: [44] Express PCI/PCI-X Bridge IRQ 0
        Capabilities: [5c] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] Power Management version 2
        Capabilities: [d8] PCI-X bridge device
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [300] Power Budgeting

07:00.2 PCI bridge: Intel Corporation 41210 [Lanai] Serial to Parallel PCI Bridge (B-Segment Bridge) (rev 09) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=07, secondary=09, subordinate=09, sec-latency=32
        I/O behind bridge: 00005000-00005fff
        Memory behind bridge: fd900000-fdafffff
        Capabilities: [44] Express PCI/PCI-X Bridge IRQ 0
        Capabilities: [5c] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] Power Management version 2
        Capabilities: [d8] PCI-X bridge device
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [300] Power Budgeting

08:04.0 SCSI storage controller: Triones Technologies, Inc. Unknown device 2340 (rev 09)
        Subsystem: Marvell Technology Group Ltd. Unknown device 11ab
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
        Memory at fdb00000 (64-bit, non-prefetchable) [size=1M]
        I/O ports at 6c00 [size=256]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [60] PCI-X non-bridge device

09:04.0 SCSI storage controller: Triones Technologies, Inc. Unknown device 2340 (rev 09)
        Subsystem: Marvell Technology Group Ltd. Unknown device 11ab
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
        Memory at fd900000 (64-bit, non-prefetchable) [size=1M]
        I/O ports at 5c00 [size=256]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [60] PCI-X non-bridge device
  Reply With Quote
Old 04-13-07, 08:04 AM   #8
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Code:
# cat /proc/interrupts
           CPU0       CPU1
  0:     238277          0   IO-APIC-edge      timer
  1:       1655          0   IO-APIC-edge      i8042
  6:          3          0   IO-APIC-edge      floppy
  7:          0          0   IO-APIC-edge      parport0
  8:          1          0   IO-APIC-edge      rtc
  9:          0          0   IO-APIC-fasteoi   acpi
 12:          4          0   IO-APIC-edge      i8042
 16:       1329          0   IO-APIC-fasteoi   rr2340, rr2340
 20:          0          0   IO-APIC-fasteoi   ehci_hcd:usb2
 21:       4577          0   IO-APIC-fasteoi   ohci_hcd:usb1, libata
 22:       4935          0   IO-APIC-fasteoi   libata
 23:     100978          0   IO-APIC-fasteoi   libata, eth0
1273:       2593          0   PCI-MSI-edge      eth2
NMI:          0          0
LOC:     238240     237717
ERR:          0
Anything else you'd be interested in?
  Reply With Quote

Old 04-13-07, 10:39 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

You stated that you "put msi=0 msix=0 in /etc/initramfs-tools/modules". Is that traditionally where your Linux distribution keeps its kernel module options, rather than modprobe.conf? Did you rebuild the initrd & reboot after making that change?

If you boot with hpet=disable does that have any impact?
netllama is offline   Reply With Quote
Old 04-17-07, 07:12 AM   #10
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Quote:
Originally Posted by netllama
You stated that you "put msi=0 msix=0 in /etc/initramfs-tools/modules". Is that traditionally where your Linux distribution keeps its kernel module options, rather than modprobe.conf?
I was not sure whether modprobe.conf would be honoured by modules loaded from initrd, that's why I put it in /etc/initramfs-tools/modules. (I'm using Debian Etch (amd64) by the way.) Of course I also tried to modprobe forcedeth msi=0 msix=0 on the command line, but it was all to no avail.
Quote:
Originally Posted by netllama
Did you rebuild the initrd & reboot after making that change?
Yes.
Quote:
Originally Posted by netllama
If you boot with hpet=disable does that have any impact?
No, I don't see any change.
  Reply With Quote
Old 06-20-07, 10:55 PM   #11
Outtascope
Debiatant
 
Join Date: Jun 2007
Location: Michigan
Posts: 1
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

I originally posted a detailed replay, but much to my dismay, these forums appear to wipe your post if you aren't logged in when you hit quick reply so I lost it ;( Between that and the captcha on the registration page being quite possibly the worst I have ever seen...doh. But I digress, I'll give you the brief version of my now lost post.

I just built 4 machines using this mobo on 32 bit etch 2.6.21 smp (64x2 6000+). 2 machines are fine, both interfaces work as expected. On the other 2 machines, port 1 is fine and port 2 is bad. One of them is identical to the problems experienced by Extensive2, including the workaround. On the other, the 2nd nic comes up, but errors on about 5 of every 6 frames it processes. I get a throughput of around 2-4k/s on it. Using either of the good machines over the same infrastructrue works as expected. I haven't tried the msi=0, msix=0 parameters yet, I will do that now and post my experience.
Outtascope is offline   Reply With Quote
Old 06-21-07, 04:14 AM   #12
extensive2
Guest
 
Posts: n/a
Default Re: 2nd NIC is off on Asus M2N-SLI Deluxe (nForce 570 SLI MCP)

Thanks for taking the time to repost!

Quote:
Originally Posted by Outtascope
I just built 4 machines using this mobo on 32 bit etch 2.6.21 smp (64x2 6000+). 2 machines are fine, both interfaces work as expected. On the other 2 machines, port 1 is fine and port 2 is bad. One of them is identical to the problems experienced by Extensive2, including the workaround. On the other, the 2nd nic comes up, but errors on about 5 of every 6 frames it processes. I get a throughput of around 2-4k/s on it. Using either of the good machines over the same infrastructrue works as expected.
To me that seems to indicate a production error at Asus. Maybe we should just return the erroneous boards. What's your opinion?
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.